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emajuan teknologi dan perkembangan desain grafis yang sangat

pesat dewasa ini juga berpengaruh teknik pembuatan desain

. bangunan. Saat ini-untuk mendesain suatu gambar bangunan

% bisa dilakukan dengan bantuan rekayasa komputer. Salah satu aplikasi

’ yang mendukung pembuatan rancang bangun adalah AutoCAD 2010.

Kemampuan yang paling menonjol adalah mendesain gambar
bangunan dalam bentuk gambar 3 dimensi.

MILIK

Bagen Perpusiakaan ' Pada awalnya software AutoCAD digunakan untuk komputer besar atau
cia;g Yoo palonn mainframe computer, akan tetapi seiring dengan perkembangan maka
o 643 Thi

dikembangkan software untuk pemakai komputer mikro. AutoCAD

- 2010 merupakan pengembangan terbaru dari pembuat software

?\‘/ ?/,Ddo AutoCAD yaitu Autodesk yang menawarkan berbagai fasilitas baru
‘ yang lebih fleksibel dibandingkan dengan versi sebelumnya.
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Buku AutoCAD 2010 untuk Desain Bangunan Minimalis membahas
berbagai hal yang berhubungan dengan konsep dan teknik peng-
gambaran objek bangunan minimalis dengan AutoCAD 2010.

Dilarang keras menerjemahkan, memfotokopi, atau memperbanyak sebagian atau seluruh isi buku ini

’tanpa izin tertulis dari penerbit. S'rRUKTUR ‘PENUIJSAN BUKU

Buku ini menjelaskan tentang teknik pembuatan dan menggambar
objek bangunan minimalis disertai dengan beberapa latihan. Agar lebih
mudah memahami materi yang disajikan, pembahasan dibagi menjadi
enam bab yang semuanya dilengkapi dengan ilustrasi yang lengkap.

Bab 1 Desain Rumah Bertingkat

Bab ini membahas sekilas tentang pemodelan rumah bertingkat,
pembuatan dinding dan lantai, mengenal area kerja dan pengaturan

layout area kerja.
Dicetak oleh Percetakan PT Gramedia, Jakarta y )
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Bab 2 Membuat Atap dan Finishing

Bab ini membahas pembuatan atap bangunan dan penggunaan UCS
untuk membantu proses desain bangunan. Serta proses akhir untuk
mendapatkan desain bangunan secara utuh dgn lengkap.

Bab 3 Desain Rumah Tinggal Minimalis

Bab ini mengulas tentang pembuatan desain rumah tinggal minimalis,
pembuatan elemen struktur dinding. Hal lain yang dibahas adalah
pembuatan objek surface dan Solid modeling dasar.

Bab 4 Membuat Konstruksi Atap dan Finishing Bangunan

Bab ini menjelaskan teknik menggambar objek pintu dan jendela serta
konstruksi atap bangunan, menggunakan teknik surfacing dan objek
solid modelling lanjutan.

Bab 5 Membuat Bangunan Kantor Minimalis

Bab ini menguraikan cara membuat bangunan yang diawali dengan
pembuatan gambar denah, pembuatan gambar pintu, gambar jendela
dan menempatkan pintu dan jendela pada bangunan. Hal lain yang
dibahas adalah penggunaan perintah 3D solid modeling serta
pembuatan gambar perspektif.

Bab 6 Membuat Desain Ruko Minimalis

Bab ini-akan menguraikan cara membuat bangunan yang diawali
déﬁé/an menggambar dinding, menggambar lantai, pembuatan gambar
pintu, gambar jendela dan menggambar atap dan carport pada
bangunan.

APA YANG HARUS ANDA KUASAI?

Buku ini akan membahas berbagai hal berkaitan dengan pemahaman
dan penggunaan program AutoCAD 2010. Dalam buku ini akan
dibahas mengenai teknik-teknik pembuatan objek 3 dimensi. Untuk itu
pembaca diharapkan telah menguasai teknik pembuatan dan
modifikasi objek 2 dimensi sebelum mempelajari buku ini.

Walaupun dalam menyusun buku ini kami telah melakukan pengkajian
dan penelitian yang mendalam serta berusaha untuk menyampaikan
materi secara lengkap dan terstruktur, tentunya setiap karya tidaklah
ada yang benar-benar sempurna sehingga mungkin buku ini kurang
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dapat memenuhi kebutuhan para pembaca, atau mungkin para
pembaca masih mengalami kesulitan atau masalah setelah mem-
pelajari buku ini.

Untuk itu, Wahana Komputer membuka lebar-lebar kesempatan bagi
para pembaca pada khususnya dan masyarakat pengguna komputer
pada umumnya untuk melakukan konsultasi mengenai berbagai
kesulitan yang dihadapi khususnya mengenai apa yang telah dijelaskan
di dalam buku ini melalui situs web kami atau via pos, faks, ataupun
email. Di samping itu Anda dapat memanfaatkan pula layanan
pelatihan komputer kami melalui Lembaga Pendidikan Komputer
Wahana untuk lebih mendalami materi-materi yang dipaparkan di
dalam buku ini.

Wahana Komputer

JL. MT Haryono 637 Semarang

Telp. (024) 8314727, 8413238 faks. (024) 8413964
email : info@wahanakom.com

web : www.wahanakom.com
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AREA KERJA MODEL SPACE

Sebelum menggambar dan merancang desain-desain bangunan
menggunakan AutoCAD 2010, sebaiknya Anda terlebih dulu mengenal
Area kerja dari aplikasi AutoCAD 2010. Area kerja tempat Anda
membuat gambar rancangan disebut dengan Model Space dan semua
gambar akan dikerjakan dan dipersiapkan sebelum Anda melakukan
pencetakan gambar.

Area kerja model space terdiri dari beberapa bagian, yaitu pada bagian
atas terdapat Menu Browser, Quick Access Toolbar, Title Bar, Info
Center dan Ribbon Panel; di bagian bawah Status Bar dan Command.

Bagian tengah merupakan Drawing Area Model Space dan terdapat
garis silang yaitu Crosshair atau kursor gambar serta UCS Icon untuk
menentukan sistem koordinat seperti yang terlihat pada Gambar 1.2.

Gambar 1.2: Area Kerja AutoCAD 2010
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Berikut ini akan dijelaskan bagian-bagian area kerja model space agar
Anda dapat lebih memahami area kerja yang akan Anda gunakan.

TITLE BAR

Title Bar menampilkan nama aplikasi dan nama file yang aktif dan
pada bagian kanan Title Bar terdapat sizing button yang berfungsi sama
seperti control menu, antara lain:

e Tombol Minimize, untuk memperkecil ukuran tampilan aplikasi
sehingga membentuk ikon aktif pada taskbar.

e Tombol Restore, untuk mengembalikan tampilan aplikasi ke
ukuran sebelumnya

e Tombol Maximize, untuk memperbesar ukuran tampilan aplikasi
menjadi satu layar penuh.

¢ Tombol Close, untuk menutup aplikasi.

RIBBON

Ribbon digunakan untuk menempatkan ikon-ikon perintah yang mem-
punyai karakteristik yang sama untuk proses penggambaran objek
AutoCAD.

Ribbon menampilkan beberapa panel yang dikelompokkan pada
masing-masing tab, sehingga memberikan tampilan interface yang
maksimal, seperti yang terlihat pada Gambar 1.3.,

Arwdlate  Parmmele

Gambar 1.3: Tampilan Ribbon Panel
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DRAWING AREA

Drawing Area/View Window adalah daerah kosong yang berfungsi
sebagai media untuk menggambar. Segala sesuatu yang Anda gambar
akan terlihat di daerah ini.

Seperti pada aplikasi Window, Anda juga dapat melakukan minimize
atau maximize terhadap area gambar, seperti yang terlihat pada
Gambar 1.4.

DRAWING

AREA P

Gambar 1.4: Tampilan Drawing Area

COMMAND WINDOW

Command Window terletak di bagian bawah dari layar, terdiri dari dua
komponen yaitu:

e Command Line, adalah tempat untuk memberikan perintah baru
pada AutoCAD.

Command: RIBBOW
onmmmarud s | COMMANDILINE

Commarnd: ai invokenfw

Cormand: Specify opposite cormprs
Comasands  * . stylke

Commard: Y. stylie

Command: Ipedify odppozite corpnexrs

iName x

IHamel i *Cmhoel™

Gambar 1.5: Command Line
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» Command History Window, yang memuat daftar perintah-perintah
yang telah Anda kerjakan sampai dengan perintah terakhir yang
Anda akses.

Tomi AT ien TIAE IoREeR L. Ludom
mizacion file fosiey 1.

wizptvon £ike Yoadad sucdeessfuliy. Custewizetiva
prisrating nodel.,

e

Express Toals Uopyrighe @ 2Y02-J00% Autodesik, Ino,

X wiy G 1 i
i TOMEBRpLING

+ Eripertisy
it URBHBOARD

b
SEEY oppbadte corbsr:

% TEPORITE 5
21 Specify cppasite tolper:

fy o omoeer. Lofheht sedy STyle:  “Srenferd™ TENG heighit: 203 Anpooanive

Useesify Lizet comier:
Fapedity oppoaive mhrhed B {Heipdsmeevs Fy fne

Gambar 1.6: Tampilan AutoCAD Command Window

MENGGAMBAR DINDING

Buat objek dinding menggunakan gambar denah dan dinding tersebut
mempunyai ketinggian 3m dengan langkah-langkah sebagai berikut:

1. Pada toolbar Layer buat layer dinding dan tentukan sebagai layer
aktif.

2. Buat gambar outline dinding menggunakan perintah line dengan
berpedoman pada denah 2D seperti terlihat pada Gambar 1.7.

3. Rapikan garis-garis outline dinding yang saling berpotongan
menggdunakan perintah trim.

2
8

2ann

- 000 4000 -] b—z060 A 4005 ———

Gambar 1.7: Gambar Denah 2D

Desain Rumah Bertingkat | 8 .



4. Pada Menu Bar pilih menu Draw > Region.

5. Select Object. Pilih semua objek objek dinding lalu tekan Enter.
Sehingga terlihat seperti Gambar 1.8.

I S N S—

Gambar 1.8: Membuat Bidang Tertutup

6. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
Pada Menu Bar pilih menu Draw > Modeling > Extrude.

8. Select object:
Ketik All untuk memilih semua objek dinding, lalu tekan Enter.

9. Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: 3000

\} Ketik 3000 untuk menentukan tinggi dinding.
1

. Objek dinding yang ada masih belum berlubang dan masih
menyatu, untuk itu kurangi dinding bagian luar dengan dinding
bagian dalam.

11. Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
12.Select object:

Pilih objek dinding bagian luar, lalu tekan Enter.
13.Select object:

Pilih semua objek dinding bagian dalam lalu tekan Enter. Hasilnya
terlihat seperti Gambar 1.9.

14. Ulangi perintah untuk mengurangi objek dinding lantai 2.
15. Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
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le6.

17.

18.

19.
20.

21.

N
o

Gambar 1.9: Menentukan Tinggi Dinding

Select object:

Pilih objek dinding bagian luar, lalu tekan Enter.

Select object:

Pilih semua objek dinding bagian dalam, lalu tekan Enter.
Pindahkan objek dinding lantai 2 di atas objek dinding lantai 1.
Pada Menu Bar pilih menu Modify > Move.

Select object:

Pilih objek dinding lantai. 2 yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
END

Tentukan titik acuan menggunakan object snap endpoint.

. Specify second point or <use first point displacement>:

END

Gunakan object snap endpoint. Lihat Gambar 1.10.

. Pada Menu Bar pilih menu Modify > Solid Editing > Union.

.S5elect object:

Pilih semua objek dinding bangunan, lalu tekan Enter.

. Pada Menu Bar pilih menu View > Visual Styles > 3D Hidden.

Bentuk tampilan bidang dapat dilihat pada Gambar 1.11.

Desain Rumah Bertinakat ] T



Gambar 1.11: Hasil Pembuatan Objek Dinding

MENGGAMBAR LANTAI

Buat objek laritai ketebalan lantai 10 cm dengan langkah-langkah

sebagai berikut:

1.

Pada toolbar Layer buat layer lantai dan tentukan sebagai layer
aktif.

Pada Menu Bar pilih menu View > 3D Views > Top.
Anda perhatikan Gambar 1.12 buat bidang dasar objek lantai 1.

Pada Menu Bar pilih menu Draw > Polyline.
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Specify first point: END
Tentukan titik pertama menggunakan object snap endpoin.

Specify next point or
[ Arc/Halfwidth/Length/Undo/Width] : END

Tentukan titik berikutnya menggunakan object snap endpoin.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : END

Tentukan titik berikutnya menggunakan object snap endpoin.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : C

I

Gambar 1.12: Menentukan Penempatan Titik Lantai

Pada Menu Bar pilih menu Draw > Modeling > Extrude.

.Select object: L

Ketik L untuk memilih objek terakhir yang Anda buat, tekan Enter.

.Specify height of extrusion or [ Direction/Path/Taper

angle] <0.0000>: -100

Ketik -100 untuk menentukan ketebalan objek lantai.

. Anda perhatikan Gambar 1.13 buat bidang dasar objek lantai 2.

. Pada Menu Bar pilih menu Draw > ‘Polyline.
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14.

15.

16.

17.

18.
19.

20.

21.
22.

Specify first point: END
Tentukan titik pertama menggunakan object snap endpoin.

Specify next point or
[ Arc/Halfwidth/Length/Undo/Width] : END

Tentukan titik berikutnya menggunakan object snap endpoint.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : END

Tentukan titik berikutnya menggunakan object snap endpoint.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : C

Ketik C untuk memilih option Close.

[S—

Gambar 1.13: Menentukan Titik Objek Lantai 2

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object: L
Ketik L untwemilih objek terakhir yang Anda buat, tekan Enter.

Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: -100

Ketik -100 untuk menentukan ketebalan objek lantai.
Pada Menu Bar pilih menu Modify > Move.
Select object: P

Ketik P untuk memilih objek sebelumnya yang Anda pilih, tekan
Enter.

40 | AutaCad 2010 untuk Deaain Banaunan Minimalis

23.8pecify base point or [ Displacement] <Displacement>:
Klik pada sembarang tempat untuk menentukan titik acuan.

24.Specify second point or <use first point displacement>:
@0,0,3000

Ketik @0,0,300 untuk memindahkan objek ke atas.

25. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

Gambar 1.14. Memindahkan Objek Lantai 2

i.anjutkan pembuatan objek lantai dengan menambahkan objek lantai teras

depan dan belakang dengan langkah-langkah sebagai berikut:

I. Pada toolbar Layer buat layer lantai teras dan tentukan sebagai
layer aktif.

. Pada Menu Bar pilih menu View > 3D Views > Top.
. Pada Menu Bar pilih menu Draw > Rectangle.

I, Upecify first corner point or
| Chamfer/Elevation/Fillet/ Thickness/Width] : END

Tentukan sudut rectangle menggunakan object snap endpoint. Lihat
Gambar 1.15.

Spoecify other corner point or
| Afvea/Dimensions/Rotation] ¢ @3000,~-2000

Ketik @3000,-2000 untuk menentukan sudut kedua.
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Gambar 1.15: Penempatan Lantai Teras

6. Pada Menu Bar pilih menu Draw > Rectangle.

7. Specify first corner point or
[ Chamfer/Elevation/Fillet/ Thickness/Width] : END.

Tentukan sudut rectangle menggunakan object snap endpoint.

8. Specify other corner point or
[ Area/Dimensions/Rotation] : @4000,1500

Ketik @4000,1500 untuk menentukan sudut kedua.
9. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
10. Select object:

Anda pilih semua objek lantai teras, lalu tekan Enter.

11.Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: -100.

Ketik -100 untuk menentukan ketebalan objek lantai. Lihat Gambar
1.16.
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Gambar 1.16: Menentukan Tebal Lantai Teras

MENGATUR LAYOUT

Untuk dapat membantu Anda secara lebih efektif dan efisien dalam
mengakses perintah-perintah 3 dimensi pada aplikasi AutoCAD 2010,
Anda dapat mengatur area kerja dengan menampilkan berbagai
macam ribbon yang dibutuhkan dan menyembunyikan ribbon lainnya
sehingga area kerja lebih tertata serta efektif.

RIBBON PANEL

Ribbon merupakan sekumpulan perintah yang dikelompokkan ber-
dasarkan menu pada AutoCAD 2010 untuk membantu Anda dalam
penggunaan perintah-perintah AutoCAD. Untuk kustomisasi ribbon
dapat dilakukan dengan cara sebagai berikut:

I. Klik tanda panah disamping Menu Browser dan pilih Show Menu
Bar.

2. Pada Menu Bar dan pilih Tools> Customize > Interface.

3. Setelah muncul kotak dialog Customize User Interface, pilih tab
Customize. Lihat Gambar 1.17.

4. Pada kelompok Customize in All CUI Files, pilih 2D Drafting &
Annotation Default (current).
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7.
8.

B8 AutolHE Classi

% E Rishun Fanale
B Gischk Pmpeties
5 Fubover Todltins

Gambar 1.17: Kotak Dialog Customize User Interface

Untuk pengaturan klik ikon Customize Workspace pada sisi sebelah
kanan atas dari kotak dialog. Maka tampilan kotak dialog akan
tampak seperti Gambar 1.18.

Untuk menambah atau mengurangi menu Toolbar, klik tanda + di
sebelah kiri pilihan Toolbar, dan pilih daftar item toolbar dengan
cara memberi tanda cek pada checkbox.

Apabila telah selesai melakukan pengaturan klik Done.

Klik OK untuk menutup kotak dialog.

Anda juga(m\t membuat ribbon panel pilihan Anda dan
dikelompokkan dengan nama yang spesifik sehingga memudahkan
untuk pengerjaan gambar secara lebih efektif. Anda dapat membuat
ribbon panel dengan langkah-langkah berikut ini:

1.
2.
3.

Pada Menu Bar dan pilih Tools > Customize > Interface.
Pada kotak dialog Customize User Interface, pilih tab Customize.

Pada kelompok Customize in All CUI Files, klik kanan pada item
Ribbon Panel, dan pada shortcut menu pilih New Panel.
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Gambar 1.19: Membuat Toolbar
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4. Selanjutnya pada kotak masukan beri nama ribbon panel dan
sebagai contoh beri nama Ribbon Panel-1, kemudian tekan Enter.

5. Pada kelompok Command List, pilih item perintah pada Categories
seperti yang terlihat pada Gambar 1.20.

6. Pada kotak daftar Command pilih salah satu ikon perintah, lalu drag
ke Row 1.

7. Ulangi langkah 5 dan 6 untuk menambahkan ikon perintah lain, lalu
klik OK untuk mengakhiri perintah.

Fousinds and Histe fhe edga 1 obiock

ALLET
T

EXPRESS
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CONTRDE
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o]
EMPRESS
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Gambar 1.20: Pengaturan Ribbon Panel-1

MENGGUNAKAN WORKSPACE

Workspace mempunyai fungsi untuk menyimpan suatu tampilan pada
area kerja AutoCAD dengan suatu karakteristik tertentu yang sesuai
dengan kebutuhan dari penggunanya. Masing-masing workspace dapat
disimpan dengan nama-nama tertentu dan Anda dapat berpindah dari
workspace yang satu ke workspace lainnya tanpa mengubah atau
berpengaruh pada rancangan gambar yang sedang Anda kerjakan.
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4. Workspace te

Anda dapat memindahkan workspaces menggunakan menu browser,
dan workspaces yang disediakan AutoCAD 2010 yaitu 2D Drafting &
Annotation, 3D Modeling dan AutoCAD Classic. Default tampilan
workspace adalah 2D Drafting & Annotation. Lihat Gambar 1.21.

Paletter
Tookhars

Comshand tine COlsS ! aDraftng & Anvotaticn - Mk
e Sryean Cintag.

Gambar 1.21: Memilih Workspace Menggunakan Menu Bar

Pada tampilan wokspaces 2D Drafting & Annotation dan 3D Modeling
termasuk di dalam Menu Browser dan Ribbon. Sedangkan tampilan
workspaces AutoCAD Classic memuat menubar dan juga menu
browser. Selain menggunakan menu browser Anda juga dapat memin-
dahkan workspaces menggunakan ikon workspaces yang terletak pada
status bar

0 Drafing B Arnotation
30 Modelirig
AutoCAD Classic

Save Current As..
@ Workepace SEHAGE..
Customize

Gambar 1.22: Menggunakan Ikon Workspaces Switching

Setelah Anda melakukan pengaturan pada area kerja AutoCAD 2010,
Anda dapat melakukan penyimpanan terhadap area kerja tersebut
dengan cara sebagai berikut:

1. Command: workspace

2. Enter workspace option [ setCurrent/SAveas/Edit/Rename/
Delete/Settings/?] <setCurrent>: SA

Ketik SA untuk memilih perintah Saveas.
3. Save Workspace as <My Workspace>: My Workspace

Ketik nama workspace sesuai yang Anda inginkan lalu Enter.

an dengan nama My Workspace.
MIrL:xg
Buran g adaag |
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Atau Anda dapat melakukan dengan cara lain mehggunakan menubar
dengan langkah berikut:

1. Pilih menu Window > Workspaces > Save Current As.

2. Selanjutnya akan muncul kotak dialog Save Workspace, ketik
nama dari workspace lalu tekan Save.

Gambar 1.23: Kotak Dialog Save Workspace

Anda juga dapat berpindah antar workspacé dengan langkah sebagai
berikut:

1. Command: workspace.

2. Enter workspace option [ setCurrent/SAveas/Edit/Rename/
Delete/Settings/?] <setCurrent>:

Tekan Enter untuk memilih perintah setCurrent.

3. Enter name of workspace to make current [?] <My
Workspace>: My Workspace

Ketik nama workspace sesuai yang kita inginkan lalu Enter.
4. AutoCAD 2010 akan menampilkan Workspace yang Anda pilih.

Untuk menjalankan setting workspace dapat dilakukan dengan cara
sebagai berikut:

1. Pada Menu Bar dan pilih Tools > Workspaces > Workspaces
Settings

2. Selanjutnya akan muncul kotak dialog Workspace Setting seperti
yang terlihat pada-Gambar 1.24. '

3. Pada menu pop-up MyWorkspace pilih nama workspace yang akan
ditetapkan sebagai workspace default yang berfungsi sebagai
workspace yang akan menjadi default setiap kali program AutoCAD
2010 dijalankan.

4. Pada kotak daftar Menu Display and Order, pilih nama-nama
workspace yang akan ditampilkan pada toolbar workspace.
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Gunakan ikon Move Up dan Move Down untuk melakukan peng-
aturan urutan workspace.

5. Pada kelompok When Switching Workspace tentukan:

* Do not save changes to workspace, apabila Anda berpindah ke
workspace lain dengan mengabaikan semua perubahan yang
terjadi pada workpace yang sedang aktif.

¢ Automatically save workspace changes, apabila Anda meng-
inginkan penyimpanan secara otomatis terhadap setiap
perubahan dari workspace yang sedang aktif.

When Sulcbing Uoliaperes ,
53 Un piot save changes ts workepace
- 3 Actomatioaly save worksoace chamgss

Gambar 1.24: Kotak Dialog Workspace Setting

MENGENAL SISTEM KOORDINAT

(Intuk menjelaskan sistim koordinat 3D digunakan teori tangan kanan
yang dapat menunjukkan sumbu X, sumbu Y dan sumbu Z. Ibu jari
menunjukkan arah sumbu X positif, jari telunjuk menunjukkan arah
sumbu Y positif dan jari tengah menunjukkan arah sumbu Z positif.

{Intuk arah perputaran sumbu digambarkan dengan tangan kanan yang
lerkepal, ibu jari menunjukkan arah sumbu dan jari lainnya menunjuk-
kan perputaran sumbu. Dapat dilihat pada Gambar 1.25.
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Gambar 1.25: Teori Tangan Kanan

SISTEM KOORDINAT CARTESLAN

Penulisan koordinat kartesian dalam 3D tidak jauh berbeda dengan
penggunaan pada sistem koordinat 2D, perbedaannya terletak pada
sumbu Z yang menunjukkan ketinggian suatu objek. Sistem koordinat
kartesian mempunyai tiga sumbu yaitu sumbu X, Y dan Z. Ketika Anda
memasukkan titik koordinat, hal itu mewakili jarak dari suatu titik dan
arah titik tersebut terhadap sumbu X, Y dan Z dari titik awal.

Persilangan antara sumbu X, Y dan Z merupakan titik awal (0,0,0) atau
titik origin.
Penulisan: X, Y, Z

B

A
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3
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Gambar 1.26: Sistem Koordinat Cartesian 3D

SISTEM KOORDINAT RELATIF

Penulisan koordirMif 3D hampir sama dengan penulisan sistem
koordinat relatif 2D, pada sistem koordinat relatif 3D Anda
menambahkan titik koordinat dari sumbu Z yang merupakan arah
ketebalan objek.

Sama halnya dengan sistem koordinat kartesian, sistem koordinat
relatif 3D mempunyai tiga sumbu yaitu sumbu X, Y dan Z.

20 | AutoCad 2010 untuk Desain Bangunan Minimslls - ...ouislise:

Pada saat Anda memasukkan letak titik koordinat, maka hal itu
mewakili jarak dan arah suatu titik terhadap sumbu X, Y dan Z dengan
berpedoman pada titik sebelumnya.

Penulisan: @X, Y, Z
Tanda @ memberitahukan AutoCAD bahwa jarak yang Anda tetapkan
adalah relatif terhadap titik terakhir yang Anda pilih.

WORLD COORDINATE SYSTEM (WCS)

World Coordinate System (WCS) merupakan sistem koordinat global atau
koordinat absolut dan berfungsi sebagai koordinat default dari AutoCAD
2010.

Titik pusat atau titik origin dari World Coordinate System tidak dapat
dirubah atau statis sehingga dikenal dengan istilah koordinat absolut.
WCS merupakan koordinat acuan dari semua sistem koordinat yang
ada pada AutoCAD.

USER COORDINATE SYSTEM (UCS)

UCS adalah sistem koordinat pengguna, dan membantu Anda dalam
mengatur titik origin (0,0,0) serta arah orientasinya. Untuk mengatur
dan menerapkan sistem koordinat dalam 3D digunakan perintah UCS.

Titik pusat dari User Coordinate System vyaitu titik koordinat 0,0,0
mempunyai sifat tidak permanen, yang berarti dapat diletakkan di
mana saja oleh penggunanya.

MENAMPILKAN SIMBOL SISTEM KOORDINAT

Anda dapat menampilkan atau tidak dari simbol sistem koordinat
menggunakan perintah UCSICON, lakukan langkah berikut ini:

. Command: ucsicon
. ON/OFF/All/Nocrigin/ORigin:
Pilih salah satu option yang ada
Penjelasan dari masing-masing option itu adalah sebagai berikut:
e  On/Off

Pilihan ini berfungsi untuk menampilkan atau tidak menampilkan
ikon sistem koordinat pada layar monitor.
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All

Menggunakan pilihan ini berarti ikon sistem koordinat akan
memberikan reaksi sehingga Anda dapat mengaturnya untuk
bekerja di semua viewports.

Noorigin

Pilihan ini berfungsi untuk mengatur ikon sistem koordinat supaya
berada pada posisi kiri bawah layar monitor.

Origin
Pilihan ini mempunyai fungsi yang berlawanan dengan pilihan

Noorigin. Apabila ikon sistem koordinat tersebut telah berada tepat
di titik originnya, maka akan terlihat tanda +.

MENGGAMBAR PINTU

Kusen menggunakan kayu 6/15 cm, Untuk menggambar pintu Anda
dapat mengikuti langkah-langkah berikut ini:

1
2.

5o v s

10.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

Specify other corner point or
{ Area/Dimension/Rotation] : @60,150

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object, lalu pilih rectangle.

Select object, tekan Enter.

Specify height of extrusion or [ Path] : 2460
Tinggi pintu.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Pada Menu Bar pilih menu Modify > Copy.

Select object:

Pilih gambar kusen tegak.
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11.

12.

13.

14.

15.
16.

17.

18.
19.

20.
21.

22.

23.

24

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @860,0

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.
Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kiri depan kusen tegak bagian
atas. '

Specify other corner point or
[ Area/Dimension/Rotation] : @920, 150

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object:

Pilih rectangle.

Select object, lalu tekan Enter.

Specify height of extrusion or [ Path] : -60
Tinggi pintu.

Specify angle of taper for extrusion <0>:
Tekan Enter. Lihat Gambar 1.27.

Pada Menu Bar pilih menu Draw > Rectangle.

.Specify first corner point or [ Chamfer/Eevation/Fillet/

Thickness/Width] :

Tentukan sudut rectangle pada ujung atas depan kusen tegak
sebelah kanan.

.Specify other corner point or

[ Area/Dimension/Rotation} : @1520,150

Tentukan koordinat sudut rectangle kedua.
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26.
27.

28.
29.
30.
31
32.

33.
34.

35.

£
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Gambar 1.27: Pembuatan Kusen Pintu

Pada Menu Bar pilih menu Draw > Solids > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : -60
Tinggi pintu.
Specify angle of taper for extrusion <0>:

Tekan Enter.

Gandakan kusen mendatar untuk membuat kusen bagian bawah,
pada Menu Bar pilih menu Modify > Copy.

Select object:

Pilih gambar kusen mendatar.

Select object, lalu teka\ﬁinteﬁ

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @0,0,-1860

36.

37.
38.

39.

40.

41

42.

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.
Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kanan depan kusen mendatar
bagian atas.

Specify other corner point or
[ Area/Dimension/Rotation] : @-60,150

Tentukan koordinat sudut rectangle kedua.
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Gambar 1.28: Pembuatan Kusen Jendela pada Pintu

Pada Menu Bar pilih menu Draw > Modeling > Extrude.

.Select object:

Pilih rectangle.
Select object:
Tekan Enter.

3.Specify height of extrusion or [ Path] :-1920

Tinggi jendela.

.Specify angle of taper for extrusion <0>:

Tekan Enter.
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45.
46.
47.

48

49.

50.

51.

52.

53.

54.

Gandakan kusen tegak untuk membuat kusen tegak bagian kanan.

Pada Menu Bar pilih menu Modify > Copy.
Select object:

Pilih gambar kusen tegak.

.Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @-760,0

Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

Pada Menu Bar pilih menu Modify > Solids Editing > }nion. Lihat

Gambar 1.29.

Select object:

Pilih semua kusen pintu jendela.
Select object:

Tekan Enter.

A

e

Gambar 1.29: Penggabungan kusen dengan perintah Union

55.

56

57.

58.
59.

60.

61.

62.

Pada Menu Bar pilih menu Draw > Rectangle.

.Specify first corner point or [ Chamfer/Eevation/Fillet/

Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah belakang kusen tegak

sebelah kiri.

Specify other corner point or
[ Area/Dimension/Rotation] : @800,-30

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Solids > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 2400
Tinggi pintu.

Specify angle of taper for extrusion <0>:

Tekan Enter. Lihat Gambar 1.30.
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Gambar 1.30: Menggambar Daun Pintu
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MENEMPATKAN PINTU

Untuk dapat melubangi dinding, Anda membuat objek pelul.aang
dengan cara membuat outline dari pintu jendela dengan perintah
polyline kemudian beri ketebalan lebih besar dari tebal dinding.

1. Pindahkan objek pelubang dinding pada dinding bangunan dengan
titik acuan.

2. Pada Menu Bar pilih menu Modify > Move.
3. Select object:
Pilih objek pelubang dinding, lalu tekan Enter.

4. Specify base point or [ Displacement] <Displacement>:

5. Specify second point or <use first point as

Tentukan titik acuan pada objek pelubang dinding. )
displacement>: ;

Letakkan pada dinding bangunan.

Gambar 1.31: Titik Peletakan Objek Pelubang Dinding

6. Pada Menu Bar pilih menu Modify - Solid Editing > Substract.
7. Select object:

Pilih objek dinding bangunan, lalu tekan Enter.

MM Bangunan Minimalis

10.
11.

12.
13.
14.

15.

16.

20.
21.

Select object:
Pilih objek pelubang dinding, lalu tekan Enter.

Tempatkan objek pintu depan seperti yang terlihat pada Gambar
1.32.

Gambar 1.32: Menempatkan Pintu Depan

Langkah selanjutnya adalah membuat objek pintu belakang.

Untuk dapat melubangi dinding, Anda membuat objek pelubang
dengan cara membuat outline dari pintu jendela dengan perintah
polyline kemudian beri ketebalan lebih besar dari tebal dinding.

Pindahkan objek pelubang dinding pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada objek pelubang dinding.

Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter. Lihat Gambar 1.33.
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Gambar 1.33: Titik Peletakan Objek Pelubang Dindiné\

22.Select object:
Pilih objek pelubang dinding, lalu tekan Enter.

23. Tempatkan objek pintu belakang dengan perintah Move. Gambar
1.34.

24. Pada Menu Bar pilih menu View > 3D Views > SE Isometric.

25. Tambahkan objek pintu balkon lantai 2.

Gambar 1 34 Menempatkan Pintu Belakang

T  n e ik e nin Mammtiman Mintvomile s

26.

27.
28.
29.

30.

31.

32.
33.

34.

N

Gambar 1.35: Objek Pintu Balkon

Untuk dapat melubangi dinding, Anda membuat objek pelubang
dengan cara membuat outline dari pintu jendela dengan perintah
polyline kemudian beri ketebalan lebih besar dari tebal dinding.

Pindahkan objek pelubang dinding pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada objek pelubang dinding. Lihat Gambar
1.36.

Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter.

Select object:

Pilih objek pelubang dinding, lalu tekan Enter.
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1. Pada Menu Bar pilih menu Draw > Rectangle

2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

3. Specify other corner point or
[ Area/Dimension/Rotation} : @1580,150

Tentukan koordinat sudut rectangle kedua.

4. Pada Menu Bar pilih menu Draw > Modeling > Extrude

Select object:

Pilih rectangle.
6. Select object:

Tekan Enter.

7. Specify height of extrusion or [ Path] : 60

Gambar 1.36: Titik Peletakan Pelubang Dinding \ Tinggi pintu.

35. Tempatkan objek pintu balkon dengan perintah move, hingga 8. Specify angle of taper for extrusion <0>:

terlihat seperti pada Gambar 1.37. Tekan Enter.

9. Gandakan kusen mendatar untuk membuat kusen bagian atas,
Pada Menu Bar pilih menu Modify > Copy

10.Select object:
Pilih gambar kusen mendatar.

11.Select object:
Tekan Enter.

12.Specify base point or [ Displacement] <Displacement -:
Tentukan titik acuan.

13.8Specify second point or <use first point as
displacement>: @0,0,1860

Gambar 1.37: Menempatkan Pintu Lt 2 14.Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

MENGGAMBAR JENDELA 15. Untuk membuat kusen tegak Pada Menu Bar pilih menu Draw >
Rectangle

Selanjutnyn Anda akan menambahkan objek jendela. Kusen meng-

qunakan kayu 6/1% cm. (ntuk menggambar kusen jendela Anda dapat

mengikutl langkah langkah berikut ini:
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16.

17.

18.
19.

20.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kiri depan kusen mendatar
bagian atas.

Specify other corner point or
[Area/Dimension/Rotation]: @60,150

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

.Specify height of extrusion or [ Path] :-1920

Tinggi jendela.

Lonpecily angle of taper for extrusion <0>: \

"‘

27

28.
29.

30.

lekan Enter.

Gandakan kusen tegak untuk membuat kusen tegak bagian kanan
dan tongah, Pada Menu Bar pilih menu Modify > Copy

vede b et

Filih gatnbint kusen tegak

el U et

lelean Enter.

Lopecity base pointoon | Displacement] <bisplacement>:

Tentukan titik acuan.

.Specify second point or <use first point as

displacement>: @-760,0

Specify second point or [ Exit/Undo] <Exit>: @1520,0
Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

Pada Menu Bar pilih menu Modify > Solids Editing > {Union

24 1 4 net>ad 9010 untuk Deaain Banaunan Minimalls . s
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Gambar 1.38: Menggambar Kusen Jendela
31.Select object:

Pilih semua kusen jendela.

32.Select object:
Tekan Enter.

|
=

Gambar 1.39: Penggabungan kusén jendela

e

Untuk menambahkan daun jendela Anda dapat mengikuti langkah-
langkah berikut ini:

1. U.qtuk membuat daun jendela tegak sebelah kiri, Pada Menu Bar
pilih menu Draw > Rectangle
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2. Specify first corner point or [Chamfer/Eevation/Fillet/
Thickness/Widthj :

Tentukan sudut rectangle pada ujung bawah depan dari kusen
jendela sebelah Kkiri.

3. Specify other corner point or

[ Area/Dimension/Rotation] : @150, 30

Tentukan koordinat sudut rectangle kedua.
4. Pada Menu Bar pilih menu Draw > Modeling > Extrude
5. Select object:

Pilih rectangle.

6. Select object:
Tekan Enter.

7. Specify height of extrusion or [ Path] : 1800
Tinggi jendela.

8. Specify angle of taper for extrusion <0>:
Tekan Enter.

9. Gandakan daun jendela tegak untuk membuat daun jendela tegak
bagian kanan, Pada Menu Bar pilih menu Modify > Copy

10. Select object:
Pilih daun jendela tegak.

11.Select object:
Tekan Enter.

12.Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

13.Specify second point or <use first point as
displacement>: @550,0

14.Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

15. Pada Menu Bar pilih menu Draw > Rectangle.

6, specify first corner point ot [ Chamfer/Eevation/Fillet/
il ckness/Width]

B e s el PP IIMM

Tentukan sudut rectangle pada ujung bawah depan dari kusen
tegak sebelah Kiri.

17.Specify other corner point or
[ Area/Dimension/Rotation] : @40, 3

Tentukan koordinat sudut rectangle kedua.
18. Pada Menu Bar pilih menu Draw > Modeling > Extrude
19.Select object:

Pilih rectangle.
20.Select object:

Tekan Enter.
21.8pecify height of extrusion or [ Path] : 150
22.8pecify angle of taper for extrusion <0>:

Tekan Enter.

23. Gandakan daun jendela mendatar untuk membuat daun jendela
mendatar bagian atas, Pada Menu Bar pilih menu Modify > Copy.

24.Select object:
Pilih daun jendela mendatar.

25.8elect object, lalu tekan Enter.

26.Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

27. specify second point or <use first point as displacement>:
@0,0,1650

28.8pecify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

29. Pada Menu Bar pilih menu Modify > Solids Editing > Union.
30.Select object:

Pilih semua daun jendela.

31.Select object:
Tekan Enter. Lihat Gambar 1.40.
32. Pada Menu Bar pilih menu Modify > Copy




_/
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Gambar 1.40: Membuat Daun Jendela

3. 5elect object:

Pilih daun jendela sebelah Kkiri.
34 el et object: \

| ekan Enter.

35 “pacily base point or [ Displacement] <Displacement>:
lentukan titik acuan.

36 fpws 1ty acecond point or <use first point as
Absp b cment -2 @760,0

37. g ify e and point or [ Exit/Undo] <Exit>:
Iakhan M'nter

Gambar 1.41: Penggambaran Jendela

a8 I Al mnd OOANA 11mb ik Maanin Bansiinan AMinimalin

Buat variasi dari objek jendela seperti yang terlihat pada Gambar 1.42
dan tambahkan objek pelubang dinding.

Gambar 1.42: Objek Jendela Depan

MENEMPATKAN JENDELA

Untuk dapat melubangi dinding, Anda membuat objek pelubang
dengan cara membuat outline dari pintu jendela dengan perintah
polyline kemudian beri ketebalan lebih besar dari tebal dinding.

1. Pindahkan objek pelubang dinding pada dinding bangunan.
2. Pada Menu Bar pilih menu Modify > Move.
3. Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

4. Specify base point or [ Displacement] <Displacement>:
MID

Tentukan titik acuan menggunakan object snap midpoint.

5. Specify second point or <use first point displacement>:
MID

Letakkan pada tengah-tengah objek menggunakan object snap
midpoint. Lihat Gambar 1.43.
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Gambar 1.43: Titik Peletakan Objek Pelubang Dinding \

pada Menu Bar pilih menu Modify > Move.

7. Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

8. Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada sembarang tempat.

9. Specify second point or <use first point as
displacement>: @0, 0,3000
Ketik @0,0,3000 untuk memindahkan objek ke atas.

10. Pada Menu Bar pilih menu Modify > Solid Editing > Substract.

11.Select object:
Pilih objek dinding bangunan, lalu tekan Enter.

12.Select object:
Pilih semua objek pelubang dinding, lalu tekan Enter.

13. Tempatkan objek jendela depan pada lubang yang telah tersedia
seperti yangj terlihat pada Gambar 1.44.

— ek Desain Banaunan Minimalis salksiissei

Gambar 1.44: Menempatkan Objek Jendela Depan

14. Tambe?hkan objek jendela pada dinding belakang dan tempatkan
seperti yang terlihat pada Gambar 1.45.

7

Gambar 1.45: Menambahkan Jendela Belakang
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MEMBUAT ATAP d
DAN FINISHING

y etelah Anda menyelesaikan konstruksi lantai dan dinding bangun-
San, pintu dan jendela pada bab sebelumnya, selanjutnya Anda
—\)akan menambahkan objek konstruksi atap bangunan dan elemen
konstruksi lainnya untuk mendapatkan hasil yang diinginkan.

Gambar 2.1: Menggambar Desain Bangunan Bertingkat




MENGGAMBAR ATAP

Untuk menggambar atap bangunan lakukan langkah-langkah berikut T
ini:

1. Ubah UCS terhadap sumbu Y untuk membuat garis bantu atap
bangunan.

2. Pada Menu Bar pilih menu Tools > New UCS > Y
3. Current ucs name: *NO NAME*

4. Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Apply/? /World] <World>: vy

Vi

M
7

5. Specify rotation angle about Y axis <90>: -90

Tentukan sudut perputaran terhadap sumbu Y.

6. Pada Menu Bar pilih menu Tools > New UCS > Origin.

7. Current ucs name: *NO NAME™ Gambar 2.3: Membuat Garis Atap

8. Enter an option
[ New/Move/orthoGraphic/Prev/Béstore/Save/ 11. Tambahkan ketebalan pada objek atap bangunan dengan perintah
Del/RApply/? /World] <World>: ‘o extrude.

9. Specify new origin point <0,0,0>: 12. Pada Menu Bar pilih menu Draw > Solids > Extrude.
Tentukan titik origin UCS seperti pada Gambar 2.2. I 13.Select object:

10. Buat garis atap dengan perintah polyline seperti pada Gambar 2.3. Pilih garis atap.

14.Select object:

Tekan Enter.

k . 15. Specify height of extrusion or [ Path] : 4200
Lebar atap.

16.Specify angle of taper for extrusion <0>:
Tekan Enter.

17. Buat garis atap pada sisi yang berlawanan arah yang mempunyai
ukuran yang berbeda dari atap pada sisi yang telah Anda buat
| sebelumnya seperti yang terlihat pada Gambar 2.4.

18. Tambahkan dinding bangunan di bawah garis atap menggunakan
perintah polyline dan extrusi.

Gambar 2 2° Mengubah Orientasi UCS

(- miwn. ;
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Gambar 2.6: Hasil akhir yang didapat

.Gambar 2.4: Menggambar Atap Bangunan

MENGGAMBAR CARPORT DAN TAMAN

Langkah selanjutnya adalah membuat objek carport dan taman yang
dapat Anda lakukanlah langkah-langkah sebagai berikut:

enggambaran
ihat Gambar
elakang objek

Aktifkan semua layer untuk melihat hasil akhfr
bangunan dan gunakan sudut pandang SE lsometrl'c.
2.6. Untuk menyembunyikan daris yang berada di

aktif.

Pada Menu Bar pilih menu View > 3D Views > Top.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or
[ Chamfer/Elevation/Fillet/ Thickness/Width] :

Y.

Tentukan sudut rectangle pertama.

m—; s

A

». Specify other corner point or
[ Area/Dimensions/Rotation] : @4150,-5000

Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

7
\!A/ /

2

b —
_..’3..
\?\
!o!/’/’)’ £
!w--y

A

8. Pada Menu Bar pilih menu Draw > Modeling > Extrude.

/

Y. Select object:

Anda pilih bidang dasar objek carport, lalu tekan Enter.

l0.5pecify height of extrusion or [ Direction/Path/Taper

Gambar 2.5: Menggambar Atap angle] <0.0000>: -100.

Ketik -100 untuk menentukan ketebalan objek carport. Lihat
Gambar 2.7.

g —— otk Daaain Banounan Minimalis Membuat Atap dan Finishing 1 47,




Gambar 2.8: Membuat Objek Taman

MENGGUNAKAN UCS

Ketika Anda memulai dengan gambar yang baru pada AutoCAD,
otomatis Anda berada pada WCS, yaitu sistem koordinat yang umum
dan merupakan sistem koordinat dunia di mana X pada posisi

horizontal, Y pada posisi vertikal dan Z pada posisi tegak lurus terhadap
X dan.

Gambar 2.7: Membuat Objek Carng

11. Pada toolbar Layer klik menu pop-up dan pilih layer Taman.
12. Pada Menu Bar pilih menu View > 3D Views > Top.
13. Pada Menu Bar pilih menu Draw > Rectangle.

14.Specify fi]’_‘St- Ciot el }:()int or . )
[ Chamfer/Elevat ion/Fillet/ Thickness/Width] : MEMUTAR UCS TERHADAP SUMBU X

Anda dapat memutar UCS terhadap sumbu X, yaitu dengan cara meng-

gunakan sumbu X sebagai sumbu acuan perputaran.

Tentukan sudut rectangle pertama.

15.Specify other o point o
[ Area/Dimension: /it al il : Untuk memutar UCS terhadap sumbu X buatlah sebuah rectangle

Tentukan sudut rectangle kedua. seperti terlihat pada Gambar 2.9. Ikuti langkah-langkah berikut:

16. Pada Menu Bar pilih menu Draw > Modeling > Extrude. |. Pada Menu Bar pilih menu menu Draw > Rectangle.

oot : Specify first corner point or [ Chamfer/Eevation/Fillet/
17.select object: Thickness/Width] :
Anda pilih bidang dasar objek taman, lalu tekan Enter.

y y Tentukan koordinat sudut rectangle pertama.
: ] t ion] Direction/Path/Taper

18-5peilfy ?ggght of extrusion Specify other corner point or
angle] :-

| Area/Dimension/Rotation] : @50, 30
19. Letakkan objek taman di bawah objek lantai dan bangunan.

. . Tentukan sudut rectangle kedua.
20. Pada Menu Bar pilih menu View > Visual Styles > 3D Hidden. Lihat

Gambar 2.8 1. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
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Buat objek rectangle pada bidang UCS yang telah diputar terhadap
sumbu X seperti terlihat pada Gambar 2.11. Lakukan langkah berikut
ini:

1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Gunakan osnap endpoint, letakkan pada sudut kiri bawah dari
rectangle pertama.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @50, 30

L Tentukan sudut rectangle kedua.
Gambar 2.9: Menggambar Rectangle —
-

putar UCS terhadap sumbu X yang dapat dilakukan dengan langkah- ( - -
langkah berikut ini: \ ) \6)%\&
1. Pada Menu Bar pilih menu Tools > New UCS > X / \///, -~ }\
5. Current ucs name: *NO NAME* 4\\\\\\////j:¢$;/ (

‘ l ~— R v
i, Inter an option \4£?

|Nww/Muvo/orthoGraphic/Prev/Restore/Save/ ’ ’

Lol /App Ly /e /World] <World>: _x

Gambar 2.11: M bar Rectangle Pada Bid
Memilih perputaran UCS terhadap sumbu X. amboar enggambar Rectangle Pada Bidang UCS
4 e 1ty etat b anngle abont X axis <90>: 60 MEMUTAR UCS TERHADAP SUMBU Y
Lartuhan st perputaran tethadap sumbu X. (JCS dapat Anda putar terhadap sumbu Y, yaitu dengan cara
: ’———1 menggunakan sumbu Y sebagai sumbu acuan perputaran.
~ {Intuk memutar UCS terhadap sumbu Y buatlah sebuah rectangle
«-,)Q seperti terlihat pada Gambar 2.12. lkuti langkah-langkah berikut:

I. Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan koordinat sudut rectangle pertama.

specify other corner point or
| Area/Dimension/Rotation] : @30,50

Tentukan sudut rectangle kedua.

Gambar 2.10: Perputaran UCS Sumbu X 4. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
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1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/

Thickness/Width] :

Gunakan osnap endpoint, letakkan pada sudut kiri bawah rectangle
pertama.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @60, 50

i e

o
! ?\V X \/%

* Gambar 2.12: Menggambar Objek Rectangle

Tentukan sudut rectangle kedua.

Langkah-langkah untuk memutar UCS terhadap sumbu Y adalah
sebagai berikut:

1.
2.
3.

Pada Menu Bar pilih menu Tools > New acs > Y.
current ucs name: *NO NAME® .

Fnter an option
lNuw/Move/orthoGraphic/Prev/Restore/Save/
hwl/Apply/?/World]<World>: Y.

Memilih perputaran UCS terhadap sumbu Y.
e Ly rotation angle about Y axis <90>: -90
qeen 11y
Jentukan sudut perputaran terhadap sumbu Y.
-
<>
-
» ’)
S
a3 N S
' =o T
/,/
prd

Gambar 2.13: Perputaran UCS Sumbu Y

S

Gambar 2.14: Menggambar Pada UCS

MEMUTAR UCS TERHADAP SUMBU Z

Anda dapat memutar UCS terhadap sumbu Z, yaitu dengan cara
imenggunakan sumbu X sebagai sumbu acuan perputaran.

(Intuk memutar UCS terhadap sumbu Z buatlah sebuah rectangle
scperti terlihat pada gambar 2.15. lkuti langkah-langkah berikut:

|. Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan koordinat sudut rectangle pertama

specify other corner point or
| Area/Dimension/Rotation] : @40, 40

Tentukan sudut rectangle kedua

Buat objek rectangle pada bidang UCS yang telah diputar terha.dap
sumbu Y seperti terlihat pada gambar 2.14. Lakukan langkah berikut

ini:

4. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

R T 2 naciad 2010 untuk Desaln Bangunan Minimeie::debsu.. .
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*_W ‘. Specify first corner point or [ Chamfer/Eevation/Fillet/
A Thickness/Width] :
P \‘& Gunakan osnap endpoint, letakkan pada sudut kiri bawah dari
I ~~ rectangle pertama.
7 A\\R >/ gep
///// T, 7 $. Specify other corner point or
\x\\ 4//j S [ Area/Dimension/Rotation] : @40, 40
T 7 - Tentukan sudut rectangle kedua.
= S~ o
e ~
y a2 T e~
N
I o & ~— I 5&\
J & /T T s
: 2 /. ) ~ -
/ - - ‘// '///7 >
Gambar 2.15. Membuat Objek Rectangle l/‘ L\“¥N_j -~/ B =
Langkah-langkah untuk memutar UCS terhadap sumbu Z adalah "
k;
sebagai berikut: | ‘J

1. Pada Menu Bar pilih menu Tools > New UCS > Z. /

Gambar 2.17: Menggambar Rectangle
2. Current ucs name: *NO NAME*

,. knter an option ic/Proy/Restore/Save/ MENENTUKAN TITIK ORIGIN UCS
r
| N‘-w/Muvei .o%h)(f:ﬂa Sw;(r:ldV 2 litik origin merupakan titik pusat koordinat yang akan menentukan
e W N ( « o oo . . . .
el /hpply nilai koordinat dari sebuah titik. Dalam pembuatan objek 3D,
Memithh perputaran (ICS terhadap sumbu Z. Pengunaan titik origin dapat membantu Anda untuk menentukan nilai
| peooa by retation anegle about 7 axis <90>: 30. koordinat.
Pentuhan sudut perputaran terthadap sumbu Z. (Intuk men‘entukan titik origin UCS Anda dapat mengikuti langkah-
o langkah berikut:
~ I. Pada Menu Bar pilih menu Draw > Modeling > Box.
o>
- Specify corner of box or [ Center] <0,0,0>:
_ Tentukan koordinat sudut objek kotak.
) e l Specify corner or [ Cube/Length] : L.
y;‘ T~ Pilih option Length.
A

. Specify length: 50.

Gambar 2.16: Perputaran UCS terhadap Sumbu Z Tentukan panjang kotak.

i specify width: 30.
Buat objek rectangle pada bidang UCS yang telah diputar terhadap f y

sumbu Z. Lakukan langkah berikut ini: Tentukan lebar kotak.

1. Pada Menu Bar pilih menu Draw > Rectangle.

— .
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6. Specify height: 40.
Tentukan tinggi kotak.

7. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

Gambar 2.18: Membuat Objek Kotak

8. Pada Menu Bar pilih menu Tools > New dCS > Origin.
. Current uces name: *NO NAME*

[0t an opt 10N

[Hnw/MHVv/uxlhnuxuphir/Prev/Restore/Save/
Pesd Wby 78 ZWon b - Wor Ld-o o
P g 0y besw oo b point 0,0,0-:
Gunakan object snap endpoint dan tentukan titik origin UCS pada
sudut kil hawah objek

“~

2

Gambar 2.19: Menentukan UCS Origin

e
e A 4 78 & st ik IRl DR reai AN

MENENTUKAN TITIK ORIGIN UCS DENGAN Z AXIS

Menentukan letak titik origin UCS menggunakan sumbu Z sebagai
pedoman.

Untuk menentukan titik origin UCS dengan Z axis buatlah sebuah
objek, dengan langkah sebagai berikut:

I. Pada Menu Bar pilih menu Draw > Modeling > Box

% 7. Specify corner of box or [ Center] <0,0,0>:

Tentukan titik koordinat sudut pertama objek.
3. Specify corner or [ Cube/Length] : L
Ketik L lalu Enter.
1. Specify length: 50.
Tentukan panjang kotak.
. Specify width: 50.

Tentukan lebar kotak.
t. Specify height: 40.
Tentukan tinggi kotak.

7. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

]
J
NN~

e

Gambar 2.20: Membuat Sebuah Objek Kotak
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Langkah-langkah untuk menetapkan titik origin dengan Z Axis sebagai
berikut:

1. Pada Menu Bar pilih menu Tools > New UCS > Z Axis Vector.
2. Current ucs name: *NO NAME*

3. Enter an option
[New/Move/orthoGraphic/Prev/Restore/Save/
Del/Rpply/? /World] <World>: _zaxis

4. Specify new origin point <0,0,0>:
Tentukan titik 1.

5. Specify point on positive portion of Z-axis
<0.0000,0.0000,1.0000>:

Tentukan arah sumbu Z dan letakkan pada titik 2.
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Gambar 2 21 Menentukan UCS Z Axis

MENENTUKAN TITIK ORIGIN UCS DENGAN 3 POINTS

Menentukan letak titik origin UCS dengan menempatkan 3 titik untuk
membentuk sumbu koordinat, dengan urutan berikut ini:

1. Menentukan titik pertama sebagai titik origin 0,0,0.
2. Menentukan titik kedua sebagai arah sumbu X.

3. Menentukan titik ketiga sebagai arah sumbu Y.
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Untuk menentukan titik origin UCS dengan 3 points buatlah sebuah
objek seperti terlihat pada Gambar 2.22, lakukan langkah berikut ini:

1. Pada Menu Bar pilih menu Draw > Modeling > Box.
2. Specify corner of box or [ Center] <0,0,0>:
Tentukan titik koordinat sudut pertama objek.

3. Specify corner or [ Cube/Length] : L.
Ketik L lalu Enter.
4. Specify length: 40.
Tentukan panjang kotak.
». Specify width: 40.
Tentukan lebar kotak.
. Specify height: 40.
Tentukan tinggi kotak.

/. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
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Gambar 2.22: Membuat sebuah Kotak

I angkah-langkah untuk menetapkan titik origin dengan 3 points adalah
wcbagai berikut:

I. Pada Menu Bar pilih menu Tools > New UCS > 3 points.

Current ucs name: *NO NAME*
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3. Enter an option 3. Specify corner or [ Cube/Length] : L

[ New/Move/orthoGraphic/Prev/Restore/Save/ Pilih option Length

Del/Rpply/? /World]l <World>: 3.
4. Specify length: 40
4. Specify new origin point <0,0,0>:
- N Tentukan panjang kotak
Tentukan origin point pada titik 1.

[@a]

) . Specify width: 40
5. Specify point on positive portion of X-axis <1.0000,- ‘

1696.0829,0.0000>: Tentukan lebar kotak
Tentukan arah sumbu X pada titik 2. 6. Specify height: 50
6. Specify point on positive-Y portion of the UCS XY plane ‘ Tentukan tinggi kotak
<0.0000,-1695.0829, 0.0000>: . . .
§ /. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

Tentukan arah sumbu Y pada titik 3.
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Gambar 2 23 Menantukan UCS 3 Points Gambar 2.24: Membuat Objek Kotak

MENENTUKAN TITIK ORIGIN UCS DENGAN OBJECT FACE I.angkah-langkah untuk menetapkan titik origin acs ()bj(‘,(ft face adalah
sebagai berikut:

Anda dapat mengatur otientasi (JCS yang sama dengan permukaan N
bidang objek 3D solid. Option ini tidak dapat diterapkan pada objek I Pada Menu Bar pilih menu Tools > New UCS > Face
yang terbentuk dari 3D frame. . Current ucs name: *NO NAME*
Untuk menentukan titik origin UCS dengan object face buatlah sebuah ‘. Enter an option
objek seperti terlihat pada gambar 2.24. Lakukan langkah-langkah | New/Move/orthoGraphic/Prev/Restore/Save/
berikut ini: Del/Apply/? /World] <World>: fa
1. Pada Menu Bar pilih menu Draw > Modeling > Box I. select face of solid object:
2. Specify corner of box or [ Center]<0,0,0>: Pilih objek solid pada salah satu permukaannya

Tentukan koordinat sudut objek kotak

Membuat Atep dan Finishing | 81 .
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AT 8. Pilih Yflip apabila Anda akan mencerminkan sumbu X terhadap
{\,-/ \ -~ sumbu Y.
e ™
' : 3 ‘
& e
L i//{@/
~ L
Gambar 2.25: Menentukan UCS Object Face
5. Enter an option [ Next/Xflip/Yflip] <accept>:
5. Pilih Next apabila Anda ingin memilih permukaan lain dari objek
3D.
Gambar 2.28: Sub Menu Yflip
T
T / . 9. Pilih Accept atau Tekan Enter apabila permukaan objek 3D
; ] ' yang Anda pilih telah sesuai dan keluar dari perintah UCS.
~_ | e
L ‘ =
i H T,
s N e
‘ Ho T T ll// N
i’ v ] . L
- - \-rl\y ~
A
Gamba /A0 Lub Menu Noxt f/ \\\ .
- -~
"‘\\ -
b X apabiia mencerminkan sambu Y tethadap X, T
e -
e Gambar 2.29: Sub Menu Accept
e MENYIMPAN UCS

“seringkali Anda bekerja menggunakan gambar-gambar yang rumit
vang memerlukan penggunaan (UCS secara berulang kali. AutoCAD
menyediakan  fasilitas untuk menyimpan UCS dan Anda dapat
menggunakannya setiap saat diperlukan.

sebagai contoh Anda akan memutar UCS terhadap sumbu X sebesar
Wy

Gambar 2.27: Sub Menu Xflip
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1. Pada Menu Bar pilih menu Tools > New UCS > X. MENAMPILKAN UCS
2. Current ucs name: *NO NAME* Untuk menampilkan kembali UCS yang telah disimpan dapat Anda
3. Enter an option [ New/Move/orthographic/Prev/Restore/ lakukan dengan langkah sebagai berikut:
Save/Del/Rpply/?/ World] <World>: _x. 1. Pada Menu Bar pilih menu Tools > Named UCS.
4. Specify rotation angle about X axis <90>: 30: 2. Selanjutnya akan ditampilkan kotak dialog UCS seperti yang
Tentukan sudut perputaran terhadap sumbu X sebesar 30°. terlihat pada Gambar 2.32.
Pada Menu Bar dan pilih menu Tools > Named UCS. 3. Pilih tab Named UCSs, dan pilh nama UCS yang akan Anda
: tampilkan pada kotak daftar UCS.
Pada kotak dialog UCS, pilih Unnamed pada kotak daftar UCS. :
Lihat Gambar 2.30. 4. Tekan Set Current.

Tekan OK untuk menutup kotak dialog.

Currert UCS: Urinamed §' 
R | o |
% @ Viord : i i S _ze Gy, §
| € Previous % i ; ’ ;
i ' o
§ i b
, :
Giambar 2 30: Kotak Dialog UCS i
! -
I Pekan F2, lalu ketikkan nama (105, §
H  lekan Deatalle untulk mielihat status koordinat CS. Lihat Gambar ‘ BRI AR R ;
A1 - : : ‘ ) l Cancel Help
‘ 9 Wik pada setmbatang tempat, ‘ '
10 1 ekan OK. 1 Gambar 2.32: Menampitkan UCS Disimpan
LY 1iCS Dotails Shme e MENGHAPUS UCS
| o / Anda dapat menghapus UCS yang telah tidak dipergunakan lagi
melalui kotak dialog UCS dan dapat Anda lakukan dengan langkah
scbagai berikut:

|. Pada Menu Bar pilih menu Tools > Named UCS.

2. Selanjutnya akan ditampilkan kotak dialog UCS seperti yang
terlihat pada Gambar 2.33.

3. Pilih tab Named UCSs, dan pilih nama UCS yang akan Anda hapus

Gambar 2.31: Status Koordinat UCS pada kotak daftar UCS.
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4. Klik kanan untuk melihat shortcut menu, pilih Delete.

5. Tekan OK.

Curfent UCS:  Memutar UCS tehadap Sumbii
E Set Cument j
Set Current H

Rename . Ditalls

! C&@j @Aj

Gambar 2.33: Menghapus UCS

MENGGANTI NAMA UCS

Anda dapatl mengganti nama UCS yang telah Anda simpan dengan
tangglal sebagal berikout:

L

'ada Menu Bar pilih imenu Tools ~ Named UCS

Selanjutnya akan ditampitkan kotak  dialog UCS  seperti yang
terlihal pada Gambae 8

Pih tal Named UCSs, dan pilih nama (UCS yang akan Anda hapus
pada kaotale daftar QS

Klik kanan untuk melihat shortcut menu, pilih Rename.

Tekan OK.

! Hamed UCSS | Othoigraphic UCSs. Setings|
:

s Current UCS: Memutar LICS tehadap Sumbu

i

| e world

Gambar 2.34: Mengganti Nama UCS
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FINISHING DESAIN BANGUNAN

Langkah terakhir adalah menambahkan kanopi pada teras bangunan

dengan membuat objek kolom teras seperti yang terlihat pada Gambar
2.35.

Gambar 2.35: Menambahkan Kolom Teras

Tambahkan atap kanopi yang merupakan dak beton untuk menutupi
teras rumah tinggal seperti yang terlihat pada Gambar 2.36.

7

Gambar 2.36: Menambahkan Atap Kanopi Teras
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Tambahkan kanopi pada jendela rumah tinggal untuk memnambahkan
kesan minimalis seperti yang terlihat pada Gambar 2.37.

\

Gambar 2.37: Menambahkan Kanopi Jendela

Tambahkan objek balkon dan atap balkon pada teras lantai 2 seperti
yang terlihat pada Gambar 2.38.

74

/z

n ‘ 4

Gambar 2.38; Menambahkan Balkon Lantai 2
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Untuk menggunakan perspektif, Pada Menu Bar pilih menu View >
Orbit > Free Orbit, lalu klik kanan, pada menu shortcut pilih Projection
> Perspective.

Gambar 2.39: Hasil Akhir Rumah Tinggal Bertingkat
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2010 untuk membuat objek 3D dengan berbagai kemampuan
yang ada, maka selanjutnya pada bab ini Anda akan belajar
menangani sebuah proyek rancang bangun 3D.

getelah Anda mengenal semua fasilitas yang ada dalam AutoCAD
)
§

Gambar 3.1: Sumbu Denah Bangunan




MEMBUAT DENAH DASAR

?uatll:h gambar sumbu denah sebagai persiapan untuk membuat
1ena bangunan menggunakan perintah polyline, tempatkan pada
ayer sumbu denah. Lakukan seperti pada Gambar 3.2,

Ifgbtelum Andahmembuat sebuah bangunan secara 3D maka langkah
ftama yang harus Anda kerjakan adalah m b , i
acuan pembuatan objek 3D. et denah 2D sebagai
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Gambar 3.2: Sumbu Denah Bangunan
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Lakukan langkah berikut untuk membuat dinding menggunakan
perintah multiline dan tempatkan pada layer dinding:

1. Command: mline.
Scale = 1.00,

2. Current settings: Justification = Top,
Style = STANDARD.

3. Specify start point or [ Justification/Scale/Style] : 7j.

Ketik J untuk memilih Justification lalu tekan Enter.

4. Enter justification type [ Top/Zero/Bottom] <top>: z.

Ketik Z untuk memilih option Zero lalu tekan Enter.
Scale = 1.00,

5. Current settings: Justification = Zero,
Style = STANDARD.

6. Specify start point or [ Justification/Scale/Style] : s.

Ketik S untuk memilih Scale lalu tekan Enter.

450

120100

300

100 "‘I’b— 280 ! 250 ‘Jl

600

Gambar 3.3: Denah Bangunan
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7. Enter mline scalo R T I

Tentukan nilai skala multiline lalu tckan Enter.,

8. Current settings: Justification Zero,

Hcale = 15,
Style = STANDARD. ce >+ 00,

9. Specify start point or [ Justification/Scale/StyleJ :
Tentukan titik garis multiline mengikuti gambar as denah.
q
%ﬁ
4
Gambar 3.4: Denah Bangunan
10. Gunakan perintah explode untuk memisahkan objek multiline. '

11. Potong garis-garis yang bersilan
seperti pada Gambar 3.5.

-

Sebelum Trim

gan menggunakan perintah trim,

Sesudah Trim

Gambar 3.5: Menggunakan Perintah Trim
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12. Satukan garis-garis yang saling berhubungan menggunakan
perintah pedit seperti yang terlihat pada Gambar 3.6.

Gambar 3.6: Menggabungkan Garis

MEMBUAT DINDING BANGUNAN

Setelah Anda menggambar dinding bangunan, selanjutnya  adalah
memberikan ketebalan untuk mendapatkan dinding 3. lLakukan
langkah berikut ini:

1. Ubah sudut pandang menjadi isometric view dan atur tampilan
menggunakan zoom.

2. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
3. Beri ketebalan pada objek dengan perintah extrude.
4. Pada Menu Bar pilih menu Draw > Modeling > Extrude.

. Current wire frame density: ISOLINES=4.
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Gambar 3.7: Sudut Pandang Isometri

6. Select object:
Pilih objek dinding.

7. Select object:
tekan Enter

8. Specify height of extrusion or [ Path] : 300
Tentukan tinggi objek top table

9. Specify angle of taper for extrusion <0>: 0

Tentukan besarnya sudut kemiringan objek.

Gambar 3.8: Memberikan Ketebalan Dinding
10. Gunakan perintah Substract untuk mengurangi dinding luar dan
dinding dalam, sehingga didapat bentuk ruang yang kosong.
11. Pada Menu Bar pilih menu Modify > Solids Editing > Subtract
12.Select solids and regions to subtract from.

13.38elect object:
Pilih objek 3D solid bagian luar.
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14.Select object:
Tekan Eriter.
15.Select solids and region to substract.
16.Select object:
Pilih objek 3D solid bagian dalam.
17.Select object:

gl

Gambar 3.9: Pengurangan Dinding Luar dan Dalam

Tekan Enter.

18. Anda dapat melakukannya pada tiap—tiap ruang yang ada sehingga
menghasilkan gambar dinding yang lengkap.

Gambar 3.10: Hasil Dinding dengan Subtract
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MENGATUR TAMPILAN 3 DIMENSI

Dalam pembuatan objek 3D, Anda seringkali perlu melihat objek yang
Anda kerjakan dari berbagai macam sudut pandang, dimaksudkan
untuk menghindari kesalahan yang mungkin terjadi karena salah
menerapkan sebuah desain ke dalam gambar.

ORTHOGRAPIC VIEWS

Anda dapat melihat objek 3D dari berbagai macam tampilan sudut
pandang, sehingga keseluruhan detail gambar dapat Anda perhatikan
untuk mengurangi tingkat kesalahan desain gambar.

Untuk menggunakan Orthographic dapat dilakukan dengan langkah berikut
ini:

1. Pada Menu Bar pilih menu View > Named Views.

2. Pada kotak dialog View Manager, pilih salah satu item view yang
ada dalam kotak daftar. Lihat Gambar 3.11.

Tekan Set Current.
4. Klik OK. Hasilnya akan terlihat Gambar 3.12.

o View Manaper

Current view: Current

| et Currpnt,
Restore Orthe .,
15et Relative to 1y ! Mew. %

‘L L ayout Views,
=t [ Preset Views

Gambar 3.11: Kotak Dialog View

i MRS

Gambar 3.12: Orthographic View

TOP VIEW (TAMPAK ATAS)

Orthographic top view akan memperlihatkan pada Anda tampilan objek
dengan sudut pandang dari arah atas objek 3D.

Untuk membuat tampilan tampak atas dapat dilakukan dengan cara
sebagai berikut:

1. Pada Menu Bar pilih menu View > Named Views.

2. Pada kotak dialog View Manager, pilih Top pada kotak daftar view.
3. Klik Set Current.

4. Klik OK. Lihat Gambar 3.13.

Desain Rumah Tinggal Minimalis | 79



o ™
—
= |
| L
2
B >

Gambar 3.13: Orthographic Top View

BOTTOM VIEW (TAMPAK BAWAH)

Orthographic bottom view akan memperlihatkan tampilan objek
dengan sudut pandang dari arah bawah dengan cara:

1.
2.

Pada Menu Bar pilih menu View > Named Views.

Pada kotak dialog View Manager, pilih Bottom pada kotak daftar
view.

Klik Set Current.
Klik OK.

Seperti terlihat pada Gambar 3.14.

D ———

10

¥
>

Gambar 3.14: Orthographic Bottom View

FRONT VIEW (TAMPAK DEPAN)

Orthographic bottom view akan memperlihatkan tampilan objck
dengan sudut pandang dari arah depan objek 3D. Untuk membuat
tampilan tampak depan ikuti langkah-langkah berikut ini:

1.
2.

Pada Menu Bar pilih menu View > Named Views

Pada kotak dialog View Manager, pilih Front pada kotak daftar
view.

Klik Set Current.
Klik OK. Lihat Gambar 3.15.
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Gambar 3.15: Orthographic Front View

BACK VIEW (TAMPAK BELAKANG)

Orthographic back view akan memperlihatkan tampilan objek dengan
sudut pandang dari arah belakang objek 3D. Untuk membuat tampilan
tampak belakang ikuti langkah-langkah berikut ini:

1. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Back pada kotak daftar
view.

3. Klik Set Current.
4. Klik OK. Lihat Gambar 3.16.

Gambar 3.16: Orthographic Back View

S Lo
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LEFT VIEW (TAMPAK SAMPING KIRI)

Orthographic left view akan memperlihatkan pada Anda tampilan objek
dengan sudut pandang dari arah samping kiri objek 3D. Untuk
membuat tampilan tampak samping kiri ikuti langkah-langkah berikut
ini:

1. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Left pada kotak daftar view.
3. Klik Set Current.
4

Klik OK. Lihat Gambar 3.17.

B X

Gambar 3.17: Orthographic Left View

RIGHT VIEW (TAMPAK SAMPING KANAN)

Orthographic right view akan memperlihatkan pada Anda tampilan
objek dengan sudut pandang dari arah samping kanan objek 3D.

Untuk membuat tampilan tampak samping kanan ikuti langkah
langkah berikut ini:

I. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Right pada kotak daftar
view.

3. Klik Set Current.
4. Klik OK. Lihat Gambar 3.18.
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Gambar 3.18: Orthographic Right View

ISOMETRIC VIEWS

Tampilan sudut pandang gambar yang dapat dikategorikan ke dalam
tampilan isometric views antara lain sebagai berikut.

SOUTHWEST ISOMETRIC

Southwest isometric view akan memperlihatkan pada Anda tampilan
objek dengan sudut pandang dari arah bagian depan dan samping Kkiri
objek 3D. Ikuti langkah-langkah berikut ini:

1. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Southwest Isometric pada
kotak daftar view.

3. Klik Set Current.
4, Klik OK.

Gambar 3.19. Southwest Isometric View
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SOUTHEAST ISOMETRIC

Southeast isometric view akan memperlihatkan pada Anda tampilan
objek dengan sudut pandang dari arah bagian depan dan samping
kanan objek 3D.

Untuk membuat tampilan southeast isometric view ikuti langkah-
langkah berikut ini:

1. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Southeast Isometric pada
kotak daftar view.

Klik Set Current.
4. Klik OK. Lihat Gambar 3.20.

Gambar 3.20: Southeast Isometric View

NORTHEAST ISOMETRIC

Northeast isometric view akan memperlihatkan pada Anda tampilan
objek dengan sudut pandang dari arah bagian belakang dan samping
kanan objek 3D. :

{Intuk membuat tampilan northeast isometric view ikuti langkah-
langkah berikut ini:
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Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Northeast Isometric pada
kotak daftar view.

Klik Set Current.
4. Klik OK.

Gambar 3.21: Northeast Isometric View

NORTHWEST ISOMETRIC

Northwest isometric view akan memperlihatkan pada Anda tampilan
objek dengan sudut pandang dari arah bagian belakang dan samping
kiri objek 3D.

Untuk membuat tampilan northwest isometric view ikuti langkah-
langkah berikut ini:

1. Pada Menu Bar pilih menu View > Named Views

2. Pada kotak dialog View Manager, pilih Northwest Isometric pada
kotak daftar view.

Klik Set Current.
Klik OK. Lihat Gambar 3.22.
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Gambar 3.22: Northwest Isometric View

MENGGUNAKAN VIEWPORT

Viewport merupakan layar gambar dari aplikasi AutoCAD. Dalam
keadaan default layar gabar terdiri dari satu layar atau single viewport.
Anda dapat mengatur jumlah viewport yang akan ditampilkan di layar
AutoCAD yang mempunyai fungsi untuk melihat gambar dari sudut
pandang tertentu sehingga Anda dapat mengamati objek secara lebih
detail.

Selain itu dengan membagi layar kerja menjadi beberapa viewport yang
dikehendaki akan membantu melihat keseluruhan ojek 3D dari seqala
arah.

YIEWPORT OBJEK 3D

Untuk dapat melihat objek dari berbagai macam sudut pandang Anda
harus membagi layar viewport menjadi beberapa bagian yang dapal
diterapkan untuk digunakan pada pembuatan objek 3D.

Untuk melakukan pembagian viewport menjadi beberapa bagian ikuti
beberapa langkah berikut:

. Pada Menu Bar pilih menu View > Viewports > New Viewports

7. Pilih salah satu viewport pada kotak daftar viewport. Sebagai
contoh pilih Four: Equal.

3. Klik OK.
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Gambar 3.23: Kotak Dialog New Viewports

Selanjutnya Anda akan melihat layar gambar yang mempunyai
tampilan dengan sudut pandang yang sama pada masing-masing
viewport. Untuk melakukan pengaturan ikuti langkah berikut:

. Klik pada viewport yang akan diubah sudut pandangnya.

2. Jalankan perintah orthographic view, dan pilih salah satu pilihan
sudut pandang.

Ulangi langkah 1 dan 2 dan lakukan pada viewport yang lain.

Untuk berpindah antar viewport, klik pada viewport yang Anda pilih
dan viewport yang aktif terlihat lebih tebal garis tepinya. Lihat
Gambar 3.24.

MENGGABUNGKAN VIEWPORT

Pada kondisi tertentu Anda juga dapat menggabungkan dua buah
viewport menjadi satu sehingga Anda akan mendapatkan bentuk
viewport baru.

88 | ActoGad 2010 untuk Desain BangunsndiNE:

Gambar 3.24: Pembagian Viewport Menjadi Empat Bagian

Untuk menggabungkan viewport, ikuti beberapa langkah-langkah
berikut:

1. Pada Menu Bar pilih menu View > Viewports > New Viewports
2. Pilih Four: Right pada kotak daftar viewport.
3. Klik OK. Lihat Gambar 3.25.

L unent”

~ *Current” “Curnrent™

*Current*

Gambar 3.25; Viewport Four - Right
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Pada Menu Bar pilih menu View > Viewports > Join.
Selanjutnya pilih viewport pertama.

Pilih viewport kedua yang akan digabungkan.

Anda akan melihat hasilnya seperti pada Gambar 3.26.

Gambar 3.26: Hasil Penggabungan Viewport 1 dan Viewport 2.

MENYIMPAN VIEWPORT

Anda dapat menyimpan pengaturan viewport yang telah Anda lakukan
menggunakan kotak dialog viewports. Untuk melakukan penyimpanan
viewport baru, lakukanlah beberapa langkah berikut ini:

1.

M

Pada Menu Bar pilih menu View > Viewports > New Viewports.
Pada kotak dialog Viewports, pilih tab New Viewports.

Ketik nama viewport pada kotak masukan New name.

Pilih tab Named Viewport.

Anda dapat melihat viewport yang baru pada kotak daftar Named
viewports. Lihat Gambar 3.27.

Klik OK.
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Gambar 3.27: Langkah Penyimpanan Viewport

MEMANGSGIL VIEWPORT

Anda dapat mengaktifkan kembali viewport yang telah disimpan meng-
gunakan kotak dialog viewports ataupun melalui command line.

Untuk menggunakan kembali viewport yang telah Anda simpan dapat
Anda lakukan dengan langkah-langkah berikut:

1.

2
3.
4

Pada Menu Bar pilih menu View > Viewports > Named Viewports
Kemudian muncul kotak dialog Viewports,
Pilih tab Named Viewport.

Pilih viewport yang akan Anda aktifkan pada kotak daftar Named
viewports.

Klik OK.
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Gambar 3.28: Menggunakan Viewport yang Disimpan

MENGHAPUS VIEWPORT

Untuk menghapus sebuah viewport yang telah disimpan, Anda dapat
melakukannya melalui dua cara yaitu dengan mengakses mengguna-
kan kotak dialog viewports ataupun menghapus viewport melalui
command line. Untuk menghapus viewport melalui kotak dialog, ikuti
beberapa langkah berikut ini: '

1. Pada Menu Bar pilih menu View > Viewports > Named Viewports.
2. Kemudian muncul kotak dialog Viewports.

3. Pilih tab Named Viewport.
4

Pilih nama viewport yang akan Anda hapus pada kotak daftar
Named viewports.

Klik kanan untuk menampilkan menu shortcut.
6. Pilih Delete.
Klik OK.
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Gambar 3.29: Mengganti Nama Viewport

MENGGANTI NAMA VIEWPORT

Untuk melakukan penggantian nama pada viewport yang disimpan
dapat Anda lakukan melui kotak dialog viewports. Anda tidak dapat
mengaksesnya melalui command line dan hanya dapat diakses melalui
kotak dialog.

Untuk mengganti nama viewport melalui kotak dialog, lakukan
beberapa langkah berikut:

1. Pada Menu Bar pilih menu View > Viewports > Named Viewports
2. Kemudian muncul kotak dialog Viewports.
3. Pilih tab Named Viewport.

4. Pilih nama viewport yang akan Anda ganti pada kotak daftar
Named viewports. ‘

. Klik kanan untuk menampilkan menu shortcut.
6. Pilih Rename.
/. Ketikkan nama viewport yang baru, lalu tekan Enter.

8. Klik OK.
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Gambar 3.30: Melakukan Pergantian Nama Viewport

MENGEMBALIKAN KE SINGLE VIEWPORT

Pada kondisi tertentu Anda juga dapat mengembalikan layar AutoCAD
menjadi - sebuah  viewport tunggal menggunakan dua cara yaitu
mengaksesnya melalui kotak dialog dan menggunakan perintah vports
pada command line. Untuk mengembalikan layar gambar menjadi
viewport tunggal melalui kotak dialog, Anda dapat mengikuti beberapa
langkah berikut ini:

1. Pada Menu Bar pilih menu View > Viewports > New Viewports
Kemudian muncul kotak dialog Viewports.

Pilih tab New Viewport.

Pilih Single pada kotak daftar Standard Viewports.

Klik OK. Lihat Gambar 3.31.

gk won
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Gambar 3.31: Mengembalikan Layar Menjadi Viewport Tunggal

OBJEK SOLID MODELLING DASAR

Program AutoCAD memberikan kemudahan untuk membentuk objek
3D solid menggunakan bentuk-bentuk dasar yang telah ada, antara lain
kotak, prisma, kerucut, bola, silinder, dan torus atau cincin.

BOX
Box merupakan objek 3D solid yang terdil darl dua objek dengan
bentuk kubus atau balok. Apabila Anda memasukkan nilai detggan

ukuran yang sama maka Anda akan mendapatkan objek solid bes
bentuk kubus.

BALOK

Objek ini mempunyai ukuran yang tidak sama antara panjang, lebar
dan tinggi balok. Untuk menggunakan perintah box dapat dilakukan
dengan cara:

I. Pada Menu Bar pilih menu Draw > Modeling > Box.
Specify corner of box or [ Center] <0,0,0>:

Tentukan letak sudut dari balok sebagai base point
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3. Specify corner or [ Cube/Length] : L
Pilih Length.

4. Specify length: 40.
Tentukan panjang balok.

5. Specify width: 50.
Tentukan lebar balok.

6. Specify height: 60.

Tentukan tinggi balok.

/\\/\
/

/

e

VA

Gambar 3.32: Objek Solid Box

KUBUS

Objek ini mempunyai bentuk kubus yang memiliki ukuran yang sama
pada semua sisinya. Untuk menggunakan perintah kubus dapat
dilakukan dengan cara:

1. Pada Menu Bar pilih menu Draw > Modeling > Box

2. Specify corner of box or [ Center] <0,0,0>:
Tentukan letak sudut dari kubus sebagai base point

3. Specify corner or [ Cube/Length] : ¢
Pilih option Cube.

4. Specify length: 50. Tentukan panjang sisi kubus.
Lihat Gambar 3.33.
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Gambar 3.33: Box Bentuk Kubus

WEDGE

Wedge merupakan objek 3D solid berbentuk prisma yang terdiri dari
dua objek prisma dengan bentuk kubus atau balok. Apabila Anda
memasukkan nilai dengan ukuran yang sama, Anda akan mendapat-
kan objek solid prisma berbentuk kubus.

BOX WEDGE

Untuk menggunakan perintah prisma berbentuk balok dapat dilakukan
dengan cara:

1. Pada Menu Bar pilih menu Draw > Modeling > Wedge.
2. Specify first corner of wedge or [ Center]-0,0,0.:
Tentukan letak sudut dari prisma sebagai base point.
3. Specify corner or [ Cube/Length] : I
Pilih Length.
1. Specify length: 40.
Tentukan panjang prisma.
Y. Specify width: 50.
Tentukan lebar prisma.
. Specify height: 60.

Tentukan tinggi prisma.
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CONE

Cone merupakan objek 3D solid berbentuk kerucut yang terdiri dari dua
jenis objek kerucut yaitu kerucut yang mempunyai bidang dasar

dengan bentuk lingkaran dan kerucut dengan bidang dasar berbentuk
elips.

KERUCUT DENGAN BIDANG DASAR LINGKARAN

Untuk menggunakan perintah solid cone dengan bidang dasar
berbentuk lingkaran dapat dilakukan dengan cara:

K\ o~
T 1. Pada Menu Bar pilih menu Draw > Modeling > Cone

2. i f i ipti :
Gambar 3.34: Objek Solid Wedge Specify center point for base of cone or [ Elliptical]

Tentukan base point, atau masukkan nilai koordinat.
CUBE WEDGE

Untuk menggunakan perintah prisma berbentuk kubus dapat dilakukan
dengan cara:

1. Specify radius for base of cone or [ Diameter] : 30
Tentukan radius kerucut yaitu radius lingkaran.

. 4. Specify heigth of cone or [ Apex] : 80.
1. Pada Menu Bar pilih menu Draw > Modeling > Wedge.

Tinggi kerucut.
2. Specify first corner of wedge or [ Center]<0,0,0>:

Tentukan letak sudut dari prisma sebagai base point.
i, Specity corner or [ Cube/Length] @ c '
Pilih option Cube
Ao ety dengthis Lo,

Tentukan panjang sisi prisma. Lihat Gambar 3.35.

Gambar 3.36: Cone Bidang Dasar Lingkaran

tIntuk mendapatkan bidang dasar lingkaran secara sempurna jalankan
perintah viewres sehingga Anda akan mendapatkan bentuk lingkaran
Gambar 3.35: Wedge Bentuk Kubus vang halus. Lalukan langkah berikut ini:
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1. Command: viewres

2. Do you want fast zooms? [ Yes/No] <Y>:
Tekan Enter

3. Enter circle zoom percent (1-20000) <1000>: 20000.
Tentukan nilai 20000 atau nilai yang maksimal.

Jalankan perintah Hide untuk melihat bentuk objek 3D solid, apabila
Anda menilai bahwa segment yang terbentuk pada objek tersebut
masih terlihat kurang sempurna, maka Anda dapat menggunakan
perintah facetres dengan langkah sebagai berikut:

1. Command: facetres
2. Enter new value for FACETRES <0.5000>: 10.
Tentukan nilai 10 atau nilai yang maksimal.

Jalankan kembali perintah Hide dan Anda akan melihat hasilnya seperti
pada Gambar 3.37.

#.. Gambar 3.37: Perintah Facetres

KERUCUT DENGAN BIDANG DASAR ELIPS

untuk menggunakan perintah ini dapat dilakukan dengan cara:

1. Pada Menu Bar pilih menu Draw > Modeling > Cone.

2. Specify center point for base of cone or [Elliptical]{

Ketik E untuk memilih option Elliptical.

150 T AuicGad 20710 untuk Dessin Banaunan Minmeislmes:

3. Specify axis endpoint of ellipse for base of cone or
[ Center] :

Tentukan titik axis pertama dari elips.

4. Specify second axis endpoint of ellipse for base of
cone:

Tentukan titik axis kedua dari elips.
5. Specify length of other axis for base of cone:
~ Tentukan titik axis berikutnya.
6. Specify heigth of cone or [ Apex] : 11.

Tinggi kerucut.

Gambar 3.38: Cone Bidang Dasar Elips

SPHERE
Shpere merupakan objek 3D solid yang mempunyal bentuk sepeitl
bola, untuk menggunakan perintah solid sphere dapat dilakukan

dengan cara:
1. Pada Menu Bar pilih menu Draw > Modeling > Sphere.
2. Current wire frame density: ISOLINES=4.
3. Specify center of sphere <0,0,0>:

Tentukan titik pusat bola atau masukkan nilai koordinat.
4. Specify radius of sphere or [ Diameter] : 35.

Tentukan radius dari bola.

Desain Rumah Tinggal Minimalis | 101




Gambar 3.39: Objek Solid Sphere

CYLINDER

Cylinder merupakan objek 3D solid berbentuk silinder yang terdiri dari
dua jenis objek silinder yaitu silinder yang mempunyai bidang dasar
dengan bentuk lingkaran dan bidang dasar berbentuk elips.

SILINDER DENGAN BIDANG DASAR LINGKARAN

untuk menggunakan perintah ini dapat dilakukan dengan cara:

1. Pada Menu Bar pilih menu Draw > Solids > Cylinder

2. Specify center point for base of cylinder or
[Elliptical] :

Tentukan base point

t. Upecity radius for base of cylinder or [ Diameter} : 25

lentukan radius silinder yaitu radius lingkaran
Ao ety hetathe of eylinder or [ Center of other end] @ 70
Fentukan tinggi silinder
;
T

nw_ﬂﬂj

Gambar 3.40: Cylinder Bidang Dasar Lingkaran
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SILINDER DENGAN BIDANG DASAR ELIPS
untuk menggunakan perintah ini dapat dilakukan dengan cara:
1. Pada Menu Bar pilih menu Draw > Solids > Cylinder

2. Specify center point for base of cylinder or
[Elliptical] :

Ketik E untuk memilih option Elliptical.

3. Specify axis endpoint of ellipse for base of cylinder
or [ Center] :

Tentukan titik axis pertama dari elips.

4. Specify second axis endpoint of ellipse for base of
cylinder:

Tentukan titik axis kedua dari elips.

5. Specify length of other axis for base of cylinder:
Tentukan titik axis berikutnya.

6. Specify heigth of cylinder or [ Center of other end] : 70

Tentukan tinggi silinder.

Gambar 3.41: Cylinder Bidang Dasar Elips

TORUS

Torus merupakan objek 3D Solid yang mempunyai bentuk seperti
cincin, dan untuk menggunakan perintah torus dapat dilakukan dengan
cara:

|. Pada Menu Bar pilih menu Draw > Modeling > Torus

2. Current wire frame density: ISOLINES=4
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3. Specify center of torus <0,0,0>: Ikuti langkah berikut ini untuk membuat objek lampu taman yang Anda

Tentukan titik pusat torus. letakkan pada teras bangunan.

4. Specify radius of torus or [ Diameter] : 40.
Tentukan radius dari torus
5. Specify radius of tube or [ Diameter] : 10

Tentukan radius dari cincin

Gambar 3.42: Objek Solid Torus

MEMBUAT LAMPU TAMAN

Pada bagian ini Anda akan berlatih membuat lampu taman
menggunakan perintah pembuatan objek standar atau primitif seperti
yang terlihat pada Gambar 3.44.

Gambar 3.44; Ukuran Objek Latihan

1. Pada Menu Bar pilih menu Draw > Modeling > Box
2. Specify corner of box or [ Center] <0,0,0>: 0,0,0

Tentukan letak sudut dari balok pada koordinat 0,0,0

3. Specify corner or [ Cube/Lengthl |
Pilih Length.

4. Specify length: 50.
Tentukan panjang balok.

5. Specify width: 50.

Tentukan lebar balok.
6. Specify height: 40.

Tentukan tinggi balok.

Gambar 3.43: Objek Latihan 7. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
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Gambar 3.45: Membuat Objek Dasar

Pada Menu Bar pilih menu Draw > Modeling > Box

Specify corner of box or [ Center] <0,0,0>: -5,-5,40.
Tentukan letak sudut dari balok pada koordinat -5,-5,40.
Specify corner or [ Cube/Length] : L.

Pilih Length.

.Opecify length: 60

Tentukan panjang balok.

e by widt b 60,

14.

15

17.

lentukan lebar balok.

Copecity height o 1o,

Tentukan tinggi balok.

Selanjutnya buat sebuah objek silinder dan letakkan di atas objek
box kedua.

- Pada Menu Bar pilih menu Draw > Modeling > Cylinder.
16.

Specify center point for base of cylinder or
[ Elliptical] : 25,25,50.

Tentukan base point silinder pada koordinat 25,25,50
Specify radius for base of cylinder or [ Diameter] : 22

Tentukan radius silinder yaitu radius lingkaran
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Gambar 3.46: Membuat Objek Box Kedua

18.Specify heigth of cylinder or [ Center of other end] :

19.
20.
21.

150
Tentukan tinggi silinder. Lihat Gambar 3.47.

Gambar 3.47: Membuat Objek Silinder

Buat objek bagian atas dengan perintah box.
Pada Menu Bar pilih menu Draw > Modeling > Box.

Specify corner of box or [ Center] <0,0,0>:

-5,-5,200.

Tentukan letak sudut dari balok pada koordinat -5,-5,200.

. Specify corner or [ Cube/Length] : L.

Pilih Length.
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23.Specify length: 60.
Tentukan panjang balok.
24.Specify width: 60.
Tentukan lebar balok.
25.8pecify height: 10.
Tentukan tinggi balok. Lihat Gambar 3.48.
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Gambar 3.48: Membuat Objek Bagian Atas
26. Langkah terakhir adalah membuat objek sphere yang Anda
letakkan pada bagian paling atas.
27. Pada Menu Bar pilih menu Draw > Modeling > Sphere.
28.Current wire frame density: ISOLINES=4.
29.8pecify center of sphere <0,0,0>: 25,25,235.
Tentukan titik pusat objek bola pada koordinat 25,25,235.
30.Specify radius of sphere or [ Diameter] : 30.

Tentukan radius dari bola.

Gambar 3.49: Hasil Akhir Latihan
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MEMBUAT KONSTRUKSI
ATAP DAN FINISHING

BANGUNAN

embahasan berikutnya Anda akan melanjutkan latihan sebelum-
P nya dengan menambahkan objek pintu dan jendela bangunan
serta menempatkan objek pintu jendela ke dalam desain

4 bangunan. Hal lain yang dibahas adalah pembuatan objek-objek

modeling dasar AutoCAD 2010.

MENGGAMBAR PINTU
* Selanjutnya Anda akan membuat pintu dengan ukuran kusen 6/15,
” tinggi pintu 246 cm, lebar daun pintu 80 cm, tempatkan pada layer
pintu.

Ikuti langkah-langkah berikut ini:

1. Buat bentuk dasar kusen menggunakan petintaly polyline sopeit]
l pada Gambar 4.1.

2. Command: polyline.

3. Specify start point:
Tentukan titik pertama.

. Specify next point or
[ Arc/Halfwidth/Length/Undo/Width] : @0, 246.

RS
N

Tentukan titik berikutnya.

',. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @492,0




10

11

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @0,~246

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
width] : @-6,0

Tentukan titik berikutnya

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @0, 240

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @-80,0

Tentukan titik berikutnya.

.Specify next point or [ Arc/Close/Halfwidth/Length/Undo/

Width] : @0, -240

Tentukan titik berikutnya.

. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/

Width] : ¢
Ketik C untuk memilih option close.

Iambahkan ketebalan pada objek dasar kusen dengan perintah
extrude. Lihat Gambar 4.1,

%V

Gambar 4.1: Bentuk Dasar Kusen
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13.
14.

15.

16.

17.

18.

19.
20.

21.

22.

Pada Menu Bar pilih menu Draw > Modeling > Extrude

Select object:

Pilih kusen.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path} : 15

Tebal kusen.

Specify angle of taper for extrusion <0>:

Tekan Enter.

Putar objek kusen berdasarkan sumbu X dengan perintah rotate 3D.
Pada Menu Bar pilih menu Modify > 3D Operation > Rotate 3D

Current positive angle: ANGDIR=counterclockwise
ANGBASE=0

Select object:
Pilih objek kusen. Lihat Gambar 4.2.

A

Gambar 4.2: Menggambar Kusen Pintu

Select object:
Tekan Enter.

.Specify first point on axis or define axis by [ Object/

Last/View/Xaxis/Yaxis/Zaxis/2points] : x

Pilih option x axis dengan mengetik x.
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24.

25.

26.
27.
28.

29.

30.
31.

32.

35.
36.
37.

38.

39.

Clo e by g be o

Specify a point on the X axis <0,0,0>:

Tentukan titik pusat sumbu putar.

Specify rotation angle or [ Reference] : 90

Tentukan nilai sudut perputaran.

Tambahkan daun pintu pada objek pintu seperti pada Gambar 4.3.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah belakang kusen
sebelah Kiri

Specify other corner point or
[ Area/Dimension/Rotation] : @80,-3

Tentukan sudut rectangle.

Pada Menu Bar pilih menu Draw > Solids > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Copeci by hedght o of extrusion or [ Path] @ 240

Pingagi pintu.

Paper for extrusion <0>:
l'ekan Enter.

Putar gambar daun pintu menggunakan perintah rotate.
Command: rotate.

Select object:

Pilih objek daun pintu.

Select object:

Tekan Enter.

Specify base point:

Tentukan titik acuan perputaran pada ujung bawah belakang kusen
sebelah Kiri.
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40.Specify rotation angle or [ Copy/Reference]

<90>: -45

Tentukan sudut perputaran.

Gambar 4.3: Menggambar Daun Pintu

MENGGAMBAR JENDELA

Selanjutnya Anda akan menambahkan objek jendela dengan ukuran
kusen 6/15, lubang jendela 180 ¢m dan lebar jendela 70 cm, tempat-
kan pada layer jendela.

Lakukan langkah-langkah berikut ini untuk menggambar jendela:

1.

Buat bentuk dasar kusen menggunakan perintah rectangle sepeitd
pada Gambar 4.4.

Pada Menu Bar pilih menu Draw > Rectangle

Specify first corner point or [ Chomfer /bevat ton/illet/
Thickness/Width] :

Tentukan sudut rectangle pertama pada sembarang titik di area
gambar

Specify other corner point or
[ Area/Dimension/Rotation] : @82,192.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Modify > Offset.
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10.

11.

12.
13.

14.

15.

Current settings: Erase source=No Layer=Source
OFFSETGAPTYPE=0

Specify offset distance or [ Through/Erase/Layer]
<Through>: 6

Tentukan jarak offset.

Select object to offset or [ Exit/Undo] <Exit>:

Pilih objek rectangle.

Specify point on side to offset or [ Exit/Multiple/Undo]
<Exit>:

Tentukan objek ditempatkan pada di sisi dalam.
Select object to offset or [ Exit/Undo] <Exit>:

Tekan Enter.

Gambar 4.4: Bentuk Dasar Kusen Jendela
Tambahkan ketebalan pada objek dasar kusen jendela dengan
perintah extrude.
Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:
Pilih kusen jendela.
Select object:
Tekan Enter
Specify height of extrusion or [ Path] : 15

Tebal kusen.
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16.

17.

18.
19.
20.

21

22.

23.

24.

25.

26.

21
28

.Select solids and regions to subtract

Specify angle of taper for extrusion <0>:
Tekan Enter

Putar objek kusen jendela berdasarkan sumbu X dengan perintah
rotate 3D.

Pada Menu Bar pilih menu Modify > 3D Operation > Rotate 3D.

Current positive angle: ANGDIR=counterclockwise ANGBASE=0
Select object:

Pilih objek kusen jendela.

.Select object:

Tekan Enter.

Specify first point on axis or define axis by [ Object/
Last/View/Xaxis/Yaxis/Zaxis/2points] : x

Pilih option x axis dengan mengetik x.

Specify a point on the X axis <0,0,0>:
Tentukan titik pusat sumbu putar.

Specify rotation angle or [ Reference] : 90
Tentukan nilai sudut perputaran.

Gunakan perintah Substract untuk mengurangi kusen luar dan
kusen dalam, sehingga didapat bentuk kusen jendela.

Pada Menu Bar pilih menu Modify > Solids Editing > Subtract

{rom

.Select object:

Pilih objek kusen jendela bagian luar.

.Select object:

Tekan Enter.

.Select solids and region to substract

.Select object:

Pilih objek kusen jendela bagian dalam

. Select object:

Tekan Enter.
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33.

34.
35.

.

39.

40.

41.
42.

/ﬁ

!
=

Gambar 4.5: Pengurangan Objek

Gandakan kusen jendela menggunakan perintah copy.

Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih objek kusen jendela.

Seelect abject

lekan Enter.

e vy base point o | Displacement] <Displacement>:

I entukan titik acuan.,

Specily scecond point or <use tirst point as
displacement>: @76,0

Tentukan titik pergeseran
Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter. Lihat Gambar 4.6.

Gabungkan kedua kusen jendela tersebut menggunakan perintah
union dan akan terlihat seperti pada Gambar 4.7.

Pada Menu Bar pilih menu Modify > Solids Editing > Union.
Select object:

Pilih semua kusen jendela.
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Gambar 4.6: Menggambar Kusen Jendela
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Gambar 4.7: Menggabungkan Kusen Jendela

-

13.Select object:
Tekan Enter.

44. Untuk menyembunyikan garis yang berada di belakang objek
gunakan perintah hide.
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45.

46.

47.

48.

49.
50.

51.

52.
53.

57.

58.

59.
60.

RN R |

‘_.'Ilu-\‘ily }Nriill O

Command: hide.

Untuk mengembalikan ke kondisi awal gunakan perintah

regenerating.
Command: regen.

Buat bentuk dasar daun jendela menggunakan perintah rectangle
seperti pada Gambar 4.8.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pertama.

Specify other corner point or
[ Area/Dimension/Rotation] : €70,180

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Modify > Offset.

Current settings: Erase source=No Layer=S5Source
OFFSETGAPTYPE=0

.Specify offset distance or [ Through/Erase/Layer]

“Through>: 15
Tentukan jarak offset.
alhject to offset or [ Exit/Undo] <Exit>:

Pilih objek tectangle.

or [ Exit/Multiple/Undo]

cidche to of faot

kit

Tentukan objek ditempatkan pada di sisi dalam.

Select object to offset or [ Exit/Undo] <Exit>:
Tekan Enter.

Tambahkan ketebalan pada objek dasar daun jendela dengan
perintah extrude.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih daun jendela.
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02

64.

65.

66 .

049,

Gambar 4.8: Bentuk Dasar Daun Jendela

.Select object:

Tekan Enter.

.Specify height of extrusion or [ Path] : 3

Tebal daun jendela.

.Specify angle of taper for extrusion <0>:

Tekan Enter.

Putar objek kusen jendela berdasarkan sumbu X dengan perintah
rotate 3D.

Pada Menu Bar pilih menu Modify > 3D Operation > Rotate 3D

Current positive angle: ANGDIR=counterclockwi:se
ANGBASE=0

.Select object:

Pilih objek daun jendela.

.Select object:

Tekan Enter.

Specify first point on axis or define axis by [ Object/
Last/View/Xaxis/Yaxis/Zaxis/2points] : x

Pilih option x axis dengan mengetik x

.5pecify a point on the X axis <0,0,0>:

Tentukan titik pusat sumbu putar.

.5pecify rotation angle or [ Reference] : 90

Tentukan nilai sudut perputaran.
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72.

73.

74.

75.

76.

77.
78.

79.

80.

81.

o 0 e

Gunakan perintah Substract untuk mengurangi daun jendela luar
dan daun jendela dalam, sehingga didapat bentuk daun jendela.

Pada Menu Bar pilih menu Modify > Solids Editing > Subtract
Select solids and regions to subtract from.
Select object:

Pilih objek daun jendela bagian luar.

Select object:

Tekan Enter.

Select solids and region to substract.
Select object:

Pilih objek daun jendela bagian dalam.

Select object:

Tekan Enter.

Tempatkan objek daun jendela pada kusen jendela menggunakan
perintah move. "

Command: move.
object:

P’ilih semua objek daun jendela. Lihat Gambar 4.9.

I

Gambar 4.9: Menggambar Daun Jendela
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H3.Select object:

“4,Specify base point or [ Displacement]

Tekan Enter.
<Displacement>:

Tentukan titik acuan.

85, Specify second point or <use first point as

86.

87.
88.

89.

90.

displacement>:

Letakkan pada sudut bawah kusen jendela.

Gambar 4.10: Menempatkan Daun Jendela
Gandakan daun jendela menggunakan perintah copy. Dapat dilihat
pada Gambar 4.11.
Pada Menu Bar pilih menu Modify > Copy.
Select object:
Pilih objek daun jendela.
Select object:
Tekan Enter.
Specify base point or [ Displacement]

<Displacement -

Tentukan titik acuan.

.Specify second point or <use first point as

displacement>: @76,0

Tentukan titik pergeseran. Gambar 4.10.

. Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.
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Gambar 4.11: Menggandakan Objek Daun Jendela

-MENEMPATKAN PINTU DAN JENDELA

Untuk menempatkan objek pintu dan jendela pada dinding bangunan,
terlebih dahulu Anda membuat lubang pintu dan jendela. Lakukan
langkah berikut ini:

1.

Untuk membuat pelubang pintu buat sebuah objek box dengan
ukuran length = 92, width = 30, height = 246.

Pada Menu Bar pilih menu Draw > Modeling > Box

e by corner of box or [ Centex] <0,0,0>:
Tentulian letak sudut dari balok pada koordinat 0,0,0.
cr | Cabe/lengt i) s L

Sl iy o e
Pilih Length.
Speclty length: 92,
Tentukan panjang box.
Specify width: 30.
Tentukan lebar box.
Specify height: 246.
Tentukan tinggi box.

Untuk membuat pelubang jendela buat sebuah objek box dengan
ukuran length = 158, width = 30, height = 192.
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Pada Menu Bar pilih menu Draw > Modeling > Box

. Specify corner of box or {Center] <0,0,0>:

Tentukan letak sudut dari balok pada koordinat 0,0,0

.Specify corner or [ Cube/Length] : L

Pilih Length.

.Specify length: 158.

Tentukan panjang box.

.Specify width: 30

Tentukan lebar box.

.Specify height: 192.

Tentukan tinggi box.

. Tempatkan kedua objek pada dinding bangunan seperti terlihat

pada Gambar 4.12.

]
Il

[
‘
g
LB
if

Gambar 4.12: Menempatkan Pelubang Pintu Dan Jendela

. Gunakan perintah Substract untuk mengurangi dinding bangunan

dengan objek pelubang.

. Pada Menu Bar pilih menu Modify > Solids Editing > Subtract
.5elect solids and regions to subtract from

.Select object:

Pilih objek dinding bangunan.
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20.

21.
22.

23.

Select object:

Tekan Enter.

Select solids and region to substract.
Select object:

Pilih objek pelubang.

Select object:

Tekan Enter.

24. Tempatkan objek pintu dan jendela pada lubang yang tersedia

menggunakan perintah move.
99 p Gambar 4.14: Menempatkan Objek Pintu Dan Jendela

OBJEK MESHES

Selain bentuk-bentuk primitive atau standar yang telah disediakan oleh
AutoCAD 2010, Anda juga dapat membentuk objek 3D permukaan
menggunakan bidang 3D, antara lain perintah objek 3D face, edge
surface, tabulated surface, ruled surface dan revolved surface.

3D FACE

Salah satu perintah yang dapat dipergunakan untuk membentuk objek
3D adalah menggunakan 3D face. Objek yang terjadi didasarkan pada
penempatan titik-titik sudut objek tersebut.

Gambar 4.13: Menggunakan Perintah Subtract

Untuk menggunakan perintah 3D face dapat dilakukan dengan cara
sebagai berikut:

o Command s move,

UL e et x\l)]('l‘[:

Pilih objek pintu atau jendela. l. Pada Menu Bar pilih menu Draw > Surfaces > 3D Face

27.Select object: 2. Specify first point or [Invisible]: 0,0. Tentukan titik pertama.

3, ' i isi T 00, -30.
Tekan Enter. Specify second point or [ Invisible] : @0

28. Specify base point or [ Displacement] <Displacement>: Tentukan titik kedua, masukkan nilai koordinat x = 0, y = -30.

1. Specify third point or [ Invisible] <exit>: @0,0,30.

Tentukan titik acuan.
Tentukan titik koordinat ketiga, masukkan nilai koordinat x=0, y=0,
z=30.

. Specify fourth point or [ Invisible] <created three-
sided face>: @0, 30.

29.8pecify second point or <use first point as
displacement>:

Letakkan lubang pintu dan jendela.

Tentukan titik keempat, masukkan nilai koordinat x = 0, y = 30.
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6. Specify third point or [ Invisible] <exit>: @30,0.

Tentukan titik koordinat kelima, masukkan nilai koordinat x = 30, y
=0

7. Specify fourth point or [ Invisible] <created three-
sided face>: @0,-30

Tentukan titik keenam, masukkan nilai koordinat x = 0, y = -30.

8. Specify third point or [ Invisible] <exit>: @0,0,30.
Tentukan letak titik koordinat ketujuh, masukkan nilai koordinat
x=0, y=0, z = -30.

9. Specify fourth point or [ Invisible] <created three-sided
face>: @0, 30

Tentukan titik kedelapan, masukkan koordinat x= 0, y= -30
10.Specify third point or [ Invisible] <exit>:

Tekan Enter untuk mengakhiri perintah 3d face.

Gambar 4.15: Objek 3D Face

EDGE SURFACE

Objek edge surface merupakan perintah untuk membentuk objek
permukaan kurva 3D yang terbentuk dari empat buah kurva yang
saling bertemu satu dengan lainnya, sehingga membentuk sebuah area
atau kurva tertutup. Objek kurva tersebut setiap ujung-ujung dari objek
kurva tersebut saling menyatu.

Untuk menggunakan perintah edge surface dapat Anda lakukan dengan
cara sebagai berikut:

1. Pada Menu Bar pilih menu Draw > Surfaces > Edge Surface
2. Current wire frame density: SURFTAB1=6 SURFTAB2=6

Gambar 4.16: Empat Kurva Edge Surface

3. Select object 1 for surface edge: Pilih kurva pertama.
4. Select object 2 for surface edge: Pilih kurva kedua.
5. Select object 3 for surface edge: Pilih kurva ketiga.

6. Select object 4 for surface edge: Pilih kurva keempat.

Gambar 4.17: Objek 3D Edge Surface

Untuk mengatur banyaknya segment yang membentuk surface dapat
digunakan perintah surftab. Surftab 1 untuk mengatur banyaknya

jaring pada posisi M dan surftab 2 untuk mengatur banyaknya segment

pada posisi N.

Untuk mengatur surftab lakukan langkah berikut

| . Command: surftabl.

. Enter new value for SURFTABL <6>: 12
Tentukan nilai M yang baru.

i, Command: surftab2.

4. Enter new value for SURFTAB2 <6>: 12

Tentukan nilai N yang baru.
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Gambar 4.18: Mengatur Surftab 1 dan Surftab 2

TABULATED SURFACE

Perintah ini digunakan untuk membentuk objek surface menggunakan
path sebagai objek bantu.

Untuk menggunakan perintah tabulated surface dapat dilakukan
dengan cara:

1. Pada Menu Bar pilih menu Draw > Surfaces > Tabulated Surface.
2. Current wire frame density: SURFTAB1=20
3. Select object for path curve:
Pilih objek kurva.
4. Delect object for direction vector:

Pilth objek bantu atau pilih garis. Lihat Gambar 4.19.

Gambar 4.19: Objek Tabulated Surface

RULED SURFACE

Ruled surface merupakan perintah untuk membuat permukaan bidang
objek 3D yaitu dengan cara menghubungkan dua buah garis sebagai
garis pembatasnya.
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Untuk menggunakan perintah ruled surface dapat dilakukan dengan
langkah sebagai berikut:

1. Pada Menu Bar pilih menu Draw > Surfaces > Ruled Surface.
2. Current wire frame density: SURFTAB1=20.

3. Select first defining curve:

Pilih garis pertama. Lihat Gambar 4.20.

—

A

Gambaf 4.20: Ruled Surface Titik Berdekatan

4. Select second defining curve:

Pilih garis kedua. Lihat Gambar 4.21.

-~

Gambar 4.21: Ruled Surface Titik Barseborangan

REVOLVED SURFACE

Revolved surface merupakan perintah untuk membuat objek 3D
dengan bentuk yang melingkar mengikuti sumbu putarnya. Untuk
menggunakan perintah revolved surface dilakukan dengan cara:

. Pada Menu Bar pilih menu Draw > Surfaces > Revolved Surface.
Current wire frame density: SURFTAR1=20 SURFTAB2=20.
i. Select object to revolve:

Pilih objek yang akan di revolve.
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4. Select object that defines the axis of revollution:

Pilih objek yang menjadi sumbu perputaran. ’
5. Specify start angle <0>:

Tentukan sudut awal rotasi.
6. Specify included angle [ +=ccw, -=cw] <360>:

Tentukan besarnya sudut rotasi.

Gambar 4.23: Objek 3D Dengan Perintah Thickness

; Selain itu Anda juga dapat membuat objek 2D terlebih dahulu
] kemudian melakukan perubahan pada ketebalan objek. Lakukan
beberapa langkah berikut:

1. Buat sebuah objek lingkaran dan pastikan lingkaran dalam keadaan
terpilih.

2. Tekan CTRL+1 untuk mengaktifkan object properties. Gambar

Gambar 4.22: Revolved Surface Dengan Sudut 360° 4.24.
! 3. Pada kelompok General tentukan nilai thickness = 20. Gambar
MENGGUNAKAN THICKNESS 4.25.
{Intuk miembentuk objek 3D dengan bidang dasar 2D secara sederhana
Atida dapat menggunakan perintah thickness, perintah ini mempunyai | @8 [Nosslecton
hingal antule emberikan ketebalan pada bagian tepi dari objek 2D
yatug terpilib, alian tetapl bagian atas dan dasar objek 3D tidak tertutup Color & 1l ayer
bidang datar sehingga apabila Anda menjalankan perintah hide maka ‘Layer n
objek yang ada akan tetlihat berlubang di bagian dalamnya. Linetype fiyt ayet
: Linetype scale 1

Untuk menggunakan perintah thickness ikuti beberapa langkah berikut ¥ Lineweight vt ayer
ini: Thirk e, 20
1. Command: thickness. the. current thickness
2. Enter new value for THICKNESS <0.0000>: 20. e /

Tentukan nilai thickness.

Buat sebuah objek 2D seperti terlihat pada Gambar 4.23.

4. Jalankan perintah Hide.
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Gambar 4.25: Mengubah Ketebalan Objek

OBJEK SOLID MODELLING TINGKAT LANJUT

Anda dapat membuat sebuah objek 3D dengan bidang dasar berasal
dari objek 2D, dan untuk mendapatkan objek 3D dilakukan dengan
cara memberikan ketebalan pada objek dasar 2D atau pun dengan cara
memutar objek 2D terhadap sumbu tertentu sehingga menghasilkan
bentuk solid.

MENGGUNAKAN PERINTAH EXTRUDE

Extrude merupakan perintah untuk membuat objek 3D dengan cara
memberikan ketebalan atau ketinggian pada suatu objek 2D yang
bersifat tertutup dan membentuk satu kesatuan objek.

EXTRUDE

(Intuk menggunakan perintah extrude terlebih dahulu Anda membuat
sebuah objek 2D kemudian jalankan perintah extrude dengan langkah
berikut ini:

1. Klik Menu Browser dan pilih menu Draw > Solids > Extrude.
2. Current wire frame density: ISOLINES=4.
3. Select object:
Pilih objek yang akan dijadikan objek 3D.
4. Select object:
Tekan Enter.
5. Specify height of extrusion or [ Path] : 30.
Tentukan tinggi objek 3D.
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6. Specify angle of taper for extrusion <0>: 0.

Tentukan besarnya sudut kemiringan objek antara -90° sampai
dengan 90°.

d \/

Gambar 4.26: Perintah Extrude Dengan Taper Angle 0°

Apabila Anda menentukan nilai sudut taper = 0 maka akan meng-
hasilkan objek yang tegak lurus, tetapi apabila nilai sudut taper
ditentukan < 0 maka akan menghasilkan objek yang miring keluar,
sebaliknya apabila nilai sudut taper ditentukan > O maka akan
menghasilkan objek yang miring ke dalam.

1. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
2. Select object:
Pilih objek 2D.
3. Select object:
Tekan Enter.
4. Specify height of extrusion or | bPath] @ 10
Tentukan tinggi objek 3D.
5. Specify angle of taper for extrusion <0>: -20

Tentukan besarnya sudut kemiringan objek.
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Gambar 4.27: Perintah Extrude Taper Angle -20°

N

Gambar 4.28: Perintah Extrude Taper Angle 10°

EXTRUDE PATH

Menggunakan bantuan garis bantu atau path, Anda dapat membuat
sebuah objelkc 3D dari objek 2D sesuai dengan bentuk garis bantu atau
path. Dalam pembuatan objek 3D dengan bantuan path, Anda harus

memperhatikan objek dasar 2D harus dalam posisi tegak lurus dengan
objek garis atau path.

Untuk menggunakan perintah extrude dengan bantuan path dapat
dilakukan dengan cara di bawah ini:

1. Pada Menu Bar pilih menu Draw > Solids > Extrude.
2. Current wire frame density: ISOLINES=4.
3. Select object:
Pilih objek yang akan dijadikan objek 3D.
4. Select object:
Tekan Enter.
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g

Gambar 4.29: Menjalankan Perintah Extrude

Specify height of extrusion or [ Path} : P
Pilih option path dengan mengetik P.
Select extrusion path:

Pilih objek bantu atau path.

i
A

e
QIS

Gambar 4.30: Extrude Dengan Path

MENGGUNAKAN PERINTAH REVOLVE

Perintah revolve digunakan untuk membuat objek 3D lengan «ata
memutar objek 2D pada sumbu putarnya. untuk menggunakan petintah
revolve dapat dilakukan dengan cara:

1.
2.
3.

Pada Menu Bar pilih menu Draw > Solids > Revolve.
Current wire frame density: ISOLINES=4.
Select object:

Pilih objek yang akan di-revolve.

Select object, lalu tekan Enter.

Specify start point for axis of revolution or define axis by [Object/
X(axis)/Y(axis)]: Klik pada titik pertama.
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Gambar 4.31: Menjalankan Perintah Revolve

6. Specify endpoint of axis:
Klik pada titik kedua.
7. Specify angle of revolution <360>: 360

Tentukan sudut perputaran objek.

Gambar 4 32 Objek 3D Solids — Revolve

MENGGUNAKAN PERINTAH 3D BOOLEAN

Perintah 3D Boolean mempunyai fungsi untuk menggabungkan,
mengurangi, mencari perpotongan objek 3D yang berfungsi untuk
mengelola objek solid modelling dan objek region. Perintah 3D Boolean
antara lain perintah Union, Substract dan Intersection.

PERINTAH UNION

Perintah union digunakan untuk menggabungkan objek-objek region
atau objek 3D solid modelling. untuk menggunakan perintah union
dapat dilakukan dengan cara:
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1. Buat dua buah silinder dengan ukuran radius = 30 dan tinggi
silinder = 70.

Gambar 4.33: Sebelum Perintah Union

2. Pada Menu Bar pilih menu Modify > Solids Editing > Union.
Select object:
Pilih semua objek silinder 3D solid.

4., Select object, lalu tekan Enter.

i

Gambar 4.34: Perintah Union

PERINTAH SUBTRACT

Perintah subtract digunakan untuk mengurangl objek objek 1egion atan
objek 3D solid modelling. untuk menggunakan perintah auldiact dapiat
dilakukan dengan cara:

1. Pada Menu Bar pilih menu Modify > Solids Editing - Subtract.

Gambar 4.35: Sebelum Perintah Subtract
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2. Select object:
Pilih objek yang akan dikurangi, pilih box.
3. Select object, lalu fekan Enter.
4. Select solids and region to substract.
5. Select object:
Pilih objek pemotong, pilih sphere.
6. Select object, lalu Enter.

Gambar 4.36: Perintah Subtract

PERINTAH INTERSECTION

Intersection digunakan untuk mencari perpotongan dua objek atau lebih
dati objek-objek region atau objek 3D solid modelling. Untuk
mengqunakan perintah intersection dapat dilakukan dengan cara:

I Pada Mena Bar pilih menu Modify > Solids Editing > Intersect.

PN

e

Gambar 4.37: Sebelum Perintah Intersection

2. Select object:
Pilih objek 3D solid, pilih box.

3. Select object:

Pilih objek 3D solid, pilih silinder.
4, Select object:

Tekan Enter.

Gambar 4.38: Perintah Intersection

MENGGUNAKAN PERINTAH FILLET

Perintah fillet digunakan untuk membuat sudut berbentuk sudut bulat
pada objek 3D solid.

Untuk menggunakan perintah fillet pada objek 3D solid modelling dapat
dilakukan dengan cara:

1. Buat sebuah silinder 3D solid dengan radius = 30 dan tinggi
silinder = 90.

Gambar 4.39: Membuat Objek Silinder
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2. Pada Menu Bar pilih menu Modify > Fillet.
Current settings: Mode=TRIM, Radius 0.0000.

4. Select first object or [ Undo/Polyline/Radius/Trim/
Multiple] :

Pilih sisi objek 3D yang akan di fillet.
5. Enter fillet radius: 10.
Tentukan radius fillet.
6. Select an edge or [ Chain/Radius] :
Pilih sisi lainnya yang akan di fillet lalu tekan Enter.
7. 2 edge(s) selected for fillet. Lihat Gambar 4.40.

™

Gambar 4.40: Perintah Fillet

MENGGUNAKAN PERINTAH CHAMFER

Seperti halnya pada pembuatan objek 2D, perintah chamfer digunakan
untuk membuat sudut berbentuk bevel pada objek 3D solid modelling.
Untuk menggunakan perintah chamfer pada objek 3D solid dapat
dilakukan dengan cara: ’

1. Buat sebuah objek box kubus dengan panjang sisi = 60.

2. Buat sebuah objek silinder degan radius = 10 dan letakkan tepat di
tengah-tengah objek box seperti terlihat pada Gambar 4.44.

Gunakan perintah subtract untuk melubangi objek box.

Pada Menu Bar pilih menu Modify > Chamfer.
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10.

11

Gambar 4.41: Menggambar Box dan Silinder

(TRIM mode) Current chamfer Distl1=0.0000, Dist2=0.0000

Select first line or
[ Undo/Polyline/Distance/Angle/Trim/ mEthod/Multiple] :
Pilih sisi objek 3D yang akan di fillet.

Base surface selection.

Enter surface selection option [ (Next/OK(current)] :
Tekan Enter.

Specify base surface chamfer distance: 10.

Tentukan ukuran chamfer.

Specify other surface chamfer distance <10.0000>: 10

Tentukan ukuran chamfer berikutnya

.Select an edge or [ Loop] :

Pilih sisi yang akan di chamfer lalu tekan Enter.

/A .
S~

Gambar 4.42: Menggunakan Perintah Chamfer
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MENGGAMBAR ATAP

Bagian selanjutnya yang Anda kerjakan adalah melengkapi atap
bangunan, tetapkan pada layer Atap.

Untuk menggambar atap bangunan lakukan langkah-langkah berikut:

1. Ubah UCS terhadap sumbu Y untuk membuat garis bantu atap
bangunan.

2. Pada Menu Bar pilih menu Tools > New UCS > Y
Current ucs name: *NO NAME*

4. Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Rpply/? /World] <World>: y

5. Specify rotation angle about Y axis <90>: -90
Tentukan sudut perputaran terhadap sumbu Y

6. Pada Menu Bar pilih menu Tools > New UCS > Origin
Current ucs name: *NO NAME*

8. Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Apply/? /World] <World>: o

Y. Specitly new origin point <0,0,0>:

I entukan titik origin UCS seperti pada Gambar 4.43.

Gambar 4.43: Mengubah Orientasi UCS

10. Buat garis bantu dengan perintah polyline seperti pada Gambar
4.44.

11.Command: polyline.

12.

13.

14.

15.

16.

17.
18.

19.

20.

Gambar 4.44: Membuat Garis Bantu

Specify start point: 0,0.
Tentukan titik pertama.

Specify next point or
[ Arc/Halfwidth/Length/Undo/Width] : @0,-100

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @-50,0.

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] :

Tekan Enter.

Buat garis atap bangunan menggunakan perintah polyline sepeiti
pada Gambar 4.45.

Command: polyline.
Specify start point:
Tentukan titik awal pada ujung bawah garis bantu.

Specify next point or
[ Arc/Halfwidth/Length/Undo/Width] : @278.75,557.5.

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @-278.75,557.5.

Tentukan titik berikutnya.
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21.

22.

23.

24.

25.

26.

27.

28.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @15,0

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @278.75,-557.5.

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @-278.75,-557.5

Tentukan titik berikutnya.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : ¢ .

Ketik C untuk memilih option close.

Tambahkan ketebalan pada objek atap bangunan dengan perintah
extrude.

Pada Menu Bar pilih menu Draw > Solids > Extrude.

Gambar 4.45: Membuat Garis Atap

Select object:
Pilih garis atap.
Select object:
Tekan Enter.

29.Specify height of extrusion or [ Path] : 615

Lebar atap.

30. Specify angle of taper for extrusion <0>:

Tekan Enter. Hasilnya akan terlihat seperti gambar berikut.

ST

Gambar 4.46: Menggambar Atap Bangunan

FINISHING BANGUNAN
Langkah terakhir adalah menambahkan pagar bangunan, menambah
kan dinding bangunan dan merapikan atap bangunan | akukan

langkah berikut ini:

3.

Tambahkan dinding bangunan di bawah garis atap menggunakan
perintah polyline dan extrusi. Lihat Gambar 4.27.

Lakukan pada sisi bangunan yang lain dan Anda dapat mengubah
sudut pandang isometri untuk membantu Anda melihat sisi
bangunan yang lain. Lihat Gambar 4.28.

Tambahkan teras pada bangunan Anda dengan ukuran lebar teras
100 cm.
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Gambar 4.28: Mengubah Sudut Pandang Isometri
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VAN

Gambar 4.29: Menambahkan Teras Bangunan

4. Anda dapat menambahkan objek dinding pagar yang mengelilingi

teras bagian depan seperti terlihat pada Gambar 4.30.

Gambar 4.30: Menambahkan Dinding Pagar Bangunan
Untuk merapikan atap bangunan terlebih dahulu Anda memindah-
kan UCS origin.
Pada Menu Bar pilih menu Tools > New UCS > Origin.
Current ucs name: *NO NAME*

Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Apply/? /World] <World>: o

Specify new origin point <0,0,0>:

Tentukan titik origin UCS seperti pada Gambar 4.31.




10.
11.
12.

13.

17.
18.
19.

20.

&

%/
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Gambar 4.31: Mengubah UCS Origin

Buat garis bantu menggunakan perintah polyline.
Command: polyline.
Specify start point: 0,0

Tentukan titik awal pada ujung bawah garis bantu.

Specify next point or

[ Arc/Halfwidth/Length/Undo/Width] : @0,200

Tentukan titik berikutnya.

.Upecify next point or [ Arc/Close/Halfwidth/Length/Undo/

Widt ]+ @H0,0

Tentukan titik berikutnya.

Qe et peant or | Are/Close/Hal fwidth/Length/Undo/
Wit oot an

Tentukan titik berikutnya,
SOpecity next o point o oor | Are/Close/Hal fwidth/Length/Undo/
Width] : ¢

Ketik C untuk memilih option close.

Tambahkan ketebalan dengan perintah extrude.
Pada Menu Bar pilih menu Draw > Solids > Extrude.
Select object:

Pilih polyline.

Select object:

Tekan Enter.
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21.
22.

23.

24.
25.

26

27.

28
29

30.

Specify height of extrusion or [ Path] : 200
Specify angle of taper for extrusion <0>:

Tekan Enter.

Gunakan perintah Substract untuk mengurangi atap bangunan .
dengan objek pelubang.

Pada Menu Bar pilih menu Modify > Solids Editing > Subtract

Select solids and regions to subtract from.

.Select object:

Pilih objek atap bangunan.
Select object:
Tekan Enter.

.Select solids and region to substract

.Select object:

Pilih objek pelubang.
Select object:
Tekan Enter.

Langkah terakhir adalah menambahkan kanopi pada teras bangunan
dengan membuat objek kolom teras seperti terlihat pada Gambar 4.33.

Gambar 4.32: Mengurangi Objek Atap Bangunan
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Tambahkan atap kanopi yang merupakan dak beton untuk menutupi
teras rumah tinggal seperti yang terlihat pada Gambar 4.34.

Gambar 4.34: Menambahkan Atap Kanopi Teras Rumah Tinggal

Tambahkan Dinding ornamen pada kamar depan untuk memnambah-
kan kesan minimalis pada rumah tinggal seperti yang terlihat pada
Gambar 4.35.

Tambahkan objek lampu taman yang Anda buat pada bab sebelumnya
dan letakkan di depan teras rumah tingal untuk menambahkan kesan
pada rumah tinggal seperti yang terlihat pada Gambar 4.36.
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Gambar 4.36: Menambahkan Lampu Taman

Untuk menggunakan perspektif, Pada Menu Bar pilih menu View >
Orbit > Free Orbit, lalu klik kanan, pada menu shortcut pilih Projection
> Perspective. Lihat Gambar 4.37.
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Gambar 4.37: Hasil Akhir Rumah Tinggal
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bangunan yang diawali dengan perencanaan denah bangunan

dan kemudian diselesaikan dengan gambar 3D. Sebelum
mengerjakan bangunan 3D, persiapkan gambar denah yang menunjuk-
kan ukuran dari masing-masing ruang. Gambar rencana denah dapat
dilihat pada Gambar 5.2.

Pada bab berikut ini Anda akan mempelajari cara pembuatan

Gambar 5.1: Gambar Bangunan Kantor
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Gambar 5.2: Gambar Rencana Denah
MEMBUAT BANGUNAN

Dengan berpedoman pada gambar denah yang telah Anda buat
scelanjutnya Anda dapat menggambar bangunan 3D.

MENGGAMBAR LANTAI

Huat terdebib dahnlu layer baru dengan nama Lantai dan tentukan Layer
L antal sebagal carrent layer ataua layer aktif. Buat Lantai dengan ukuran
19500 x 900 menggunakan rectangle, kemudian beri ketebalan 50 cm
dengan petintaly ekstrasd,

Lakukan langkah-langkah berikut ini:
1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/FEevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @1500, 900

Tentukan koordinat sudut rectangle kedua.

4. Pada Menu Bar pilih menu Draw > Solids > Extrude.

T R e T T B e T ————————

5. Select object:
Pilih objek yang akan dijadikan objek 3D.
6. Select object:
Tekan Enter.
7. Specify height of extrusion or [Path]: -50
Tinggi lantai.
8. Specify angle of taper for extrusion <0>:
Tekan Enter.

9. Untuk melihat hasil pembuatan lantai, ubah sudut pandang menjadi
SW Isometric seperti yang terlihat pada Gambar 5.3.

10. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

Gambar 5.3: Gambar Lantai

MENGGAMBAR KOLOM
Buat layer baru dengan nama Kolom 3D dan tentukan sebagal layer
aktif. Buat kolom dengan ukuran 25x25H menggunakan tectangle, hati

ketebalan 350 cm dengan perintah ckstrusi.
Lakukan langkah-langkah berikut ini:
1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @25,25

Tentukan koordinat sudut rectangle kedua.
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4. Pada Menu Bar pilih menu Draw > Solids > Extrude
Select object:
Pilih rectangle.

6. Select object:
Tekan Enter.

7. Specify height of extrusion or [ Path] : 350
Tinggi lantai.

8. Specify angle of taper for extrusion <0>:
Tekan Enter.

Tempatkan kolom sesuai denah dengan jarak dari tepi adalah 50 cm
menggunakan osnap form endpoint. Gunakan perintah move dan
tentukan base point pada tengah-tengah kolom menggunakan osnap
mid between 2 points. Gandakan kolom menggunakan perintah
rectangular array dengan jarak horizontal 350 cm dan jarak vertikal 400
cm.

25
=

| Ll

|

- 50 -l

Gambar 5.4: Penempatan Kolom.

Lakukan langkah-langkah berikut ini:
1. Pada Menu Bar dan pilih menu Modify > Move.
2. Select object:
Pilih kolom.
3. Select object:
Tekan Enter.
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11.
12.
13.
4.

0.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada tengah-tengah kolom, gunakan object
snap mid between 2 points.

Specify second point or <use first point as
displacement>:

Letakkan pada jarak 50 cm dari ujung lantai, gunakan object snap
from endpoint.

Pada Menu Bar pilih menu Modify > Array.

Pada kotak dialog Array pilih tombol radio Rectangular Array.
Klik ikon Select Objects dan pilih objek kolom.

Pada kotak masukan Rows, ketik 3.

Pada kotak masukan Columns, ketik 5.

By defak, € the row offset is negative,
rows ame added downward, ¥ the
cokynn offeet is negative, columna sre
added to the left

Gambar 5.5: Pengaturan Rectangular Array

Pada kotak Masukan Rows offset, ketik 400.
Pada kotak masukan Columns offset, ketik 350.
Tekan Preview untuk melihat hasil sementara.

Tekan Modify untuk kembali ke kotak dialog, atau tekan Accept
apabila sudah sesuai dengan denah.

. Tekan OK untuk menutup kotak dialog.
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Select faces or [ Undo/Remove] :

(@)
.

Pilih permukaan objek 3D.

4. Pada Menu Bar pilih menu Modify > Solids Editing > Extrude Faces
6. Select faces or [ Undo/Remove/ALl] : r . |

Pilih option remove dengan mengetik R untuk membatalkan
permukaan 3D yang terpilih.

7. Remove faces or [ Undo/Add/ALIL] :

Pilih permukaan objek 3D yang tidak Anda edit.

Gambar 5.6: Penggandaan Kolom -

MENGEDIT 3D SOLID MODELLING

Anda dapat melakukan modifikasi pada objek 3D solid modelling
menggunakan toolbar Solids Editing, yang mempunyai fasilitas untuk
memodifikasi objek solid antara lain:

% Faces, terdapat beberapa perintah yang digunakan untuk memo-

7 ilih P k li
difikasi permukaan dari objek 3D solid. Gambar 5.7: Memilih Permukaan Solid

< Edge, perintah ini digunakan untuk melakukan editing pada garis 8. Remove faces or [ Undo/Add/ALI] : Tekan Enter.
tepi dari objek 3D solid. 9. Specify height of extrusion or [ path] : 30
€ HBodies, meliputi beberapa perintah yang digunakan untuk menam- Tentukan besarnya penambahan tinggi permukaan objek.
bahlan, memisahkan dan membersihkan objek 3D solid. ,
' 10.Specify angle of taper for extrusion -0-:
EXTRUDE FACES Tentukan nilai sudut kemiringan atau tekan Enter.
Perintah extrude faces digunakan untuk menambahkan ketebalan pada 11.80lid validation started.
permukaan objek solid yang Anda pilih. Lihat Gambar 5.7. | 12.S0lid validation complete.
Apabila Anda menggunakan perintah ini maka bentuk permukaan dari 13.Enter a face editing option
objek solid akan bertambah atau berkurang sesuai dengan nilai yang [ Extrude/Move/Rotate/Offset/
Anda masukkan. Taper/Delete/Copy/coLor/Undo/eXit] : x.
Untuk menggunakan perintah extrude faces dapat dilakukan dengan | Pilih Exit dengan mengetik X untuk keluar dari option Face.
cara:

14.S0lids editing automatic checking: SOLIDCHECK=1.
1. Buat sebuah objek box kubus dengan panjang sisi = 60. I5.Enter a solids editing option

2. Buat sebuah objek silinder degan radius = 10 dan letakkan tepat di [ Face/Edge/Body/Undo/eXit] <eXit>: x.

tengah-tengah objek box. Pilih Exit dengan mengetik X untuk mengakhiri perintah.

3. Gunakan perintah subtract untuk melubangi objek box.
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$Sesudah Extrude Faces

Sehelum Extrude Faces

Gambar 5.8: Menggunakan Extrude Faces

MOVE FACES

Perintah move faces adalah perintah yang mempunyai fungsi untuk
memindahkan permukaan objek 3D solid modelling.

Untuk menggunakan perintah move faces dapat dilakukan dengan cara
sebagai berikut:

1.

Buat sebuah objek rectangle dan polygon 6 sisi dan gunakan
perintah extrude untuk memberikan ketebalan pada objek tersebut.

Pada Menu Bar pilih menu Modify > Solids Editing > Move Faces.
Soelect faces or [ Undo/Remove] :

Pilih permukaan objek 3D.

et o o [ Undo/Remove/ALL) 1o

Pilih option temove  dengan mengetik R untuk  membatalkan
permukaan 3D yang terpilih,

Fomove taces or | Undo/Add/ALL ¢

Pilih permukaan objek 3D yang tidak Anda edit.
Remove faces or [ Undo/Add/ALL] :

Tekan Enter.

Specify a base point or displacement:

Tentukan titik acuan pada titik pertama.
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8.

10.
11.

12
I3

Gambar 5.9: Memilih Permukaan Objek Solid

Specify a second point of displacement:

Tentukan titik kedua.

Gambar 5.10: Arah Perpindahan Permukaan Objek

Solid validation complate.

Enter a face editing option
[ Extrude/Move/Rotate/Offset/
Taper/Delete/Copy/coLlor/Undo/eXit] : x.

Pilih Exit dengan mengetik X untuk keluar dari option Face.

.Solids editing automatic checking: SOLIDCHECK=1.

.Enter a solids editing option

[ Face/Edge/Body/Undo/eXit] <eXit>: x.

Pilih Exit dengan mengetik X untuk mengakhiri perintah.
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Gambar 5.11: Menggunakan Move Faces

OFFSET FACES

Adalah perintah yang digunakan untuk memperbesar atau memperkecil
permukaan objek solid, dengan cara:

1. Pada Menu Bar pilih menu Modify > Solids Editing > Offset Faces.
2. Select faces or [ Undo/Remove] :

Pilih permukaan objek 3D.
i, Solect faces or [ Undo/Remove/ALL] :

lekan Enter.

Gambar 5.12: Menentukan Permukaan Solid

4. Specify the offset of distance:

Masukkan nilai offset, atau tentukan titik acuan pada titik pertama.

5. Specify second point: Tentukan titik kedua.

10.

Gambar 5.13: Menentukan Arah Offset

Solid validation started.
Solid validation complete.

Enter a face editing option
[ Extrude/Move/Rotate/Offset/
Taper/Delete/Copy/color/Undo/eXit] : x.

Pilih Exit dengan mengetik X untuk keluar dari option Face.
Solids editing automatic checking: SOLIDCHECK=1.

Enter a solids editing option
[ Face/Edge/Body/Undo/eXit] <eXit>: x.

Pilih Exit dengan mengetik X untuk mengakhiri perintah.

T T
PEezast

S
e

Gambar 5.14: Menggunakan Offset Faces
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ROTATE FACES

Rotate faces adalah perintah yang digunakan untuk memutar per-
mukaan objek 3D solid. Untuk menggunakan perintah rotate faces
dapat dilakukan dengan cara:

1
2.

Pada Menu Bar pilih menu Modify > Solids Editing > Rotate Faces.
Select faces or [ Undo/Remove] :

Pilih permukaan objek 3D.

Select faces or [ Undo/Remove/ALL] : r.

Pilih option remove dengan mengetik R untuk membatalkan
permukaan 3D yang terpilih.

Remove faces or [ Undo/Add/ALIL] :

Pilih permukaan objek 3D yang tidak Anda edit.
Remove faces or [ Undo/Add/ALIL] :

Tekan Enter.

Gambar 5.15: Memilih Permukaan Solid Yang Dirotasi

Specify an axis point or [ Axis by object/View/Xaxis/
Yaxis/Zaxis] <2points>:

Tentukan titik pertama dari sumbu perputaran.

Specify the second point on the rotation axis: Tentukan
titik kedua.

Specify a rotation angle or [ Reference] : 30

Tentukan sudut perputaran.
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10
11

12.
13.

Gambar 5.16: Menentukan Sumbu Putar

Solid validation started.

.S0lid validation complete.

.Enter a face editing option

{ Extrude/Move/Rotate/Offset/ Taper/Delete/Copy/
coLor/Undo/eXit] : x

Pilih Exit dengan mengetik X untuk keluar dari option Face.
Solids editing automatic checking: SOLIDCHECK=1.

Enter a solids editing option
[ Face/Edge/Body/Undo/eXit] <eXit>: x.

Pilih Exit dengan mengetik X untuk mengakhiri perintah.

—

Gambar 5.17: Menggunakan Rotate Faces
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COPY FACES

Merupakan perintah yang digunakan untuk menggandakan atau
multiplikasi dari permukaan objek 3D solid modelling. Untuk meng-
gunakan perintah copy faces dapat dilakukan dengan cara:

1. Pada Menu Bar pilih menu Modify > Solids Editing > Copy Faces.
2. Select faces or [ Undo/Remove] :

Pilih permukaan objek 3D.
3. Select faces or [ Undo/Remove/ALL] : r.

Pilih option remove dengan mengetik R untuk membatalkan
permukaan 3D yang terpilih

4. Remove faces or [ Undo/Add/ALIL] :
Pilih permukaan objek 3D yang tidak Anda edit.
5. Remove faces or [ Undo/Add/ALI] :
Tekan Enter.
6. Specify a base point or displacement:
Tentukan base point pada titik pertama.
1, Upecify a second point of displacement:

lentukan titik kedua.

8. Solid validation started.
9. Solid validation complete.

10.Enter a face editing option
[ Extrude/Move/Rotate/Offset/
Taper/Delete/Copy/colLor/Undo/eXit] : x.

Pilih Exit dengan mengetik X untuk keluar dari option Face.
11.S0lids editing automatic checking: SOLIDCHECK=1.

12 .Enter a solids editing option
[ Face/Edge/Body/Undo/eXit] <eXit>: x

Pilih Exit dengan mengetik X untuk mengakhiri perintah.

Gambar 5.19: Menggunaan Copy Faces

TAPER FACES

Perintah taper faces digpergunakan untuk mengubah sudut kemiringan
dari permukaan objek 3D solid. Untuk menggunakan perintah taper
faces dapat dilakukan dengan cara sebagai berikut:

1. Pada Menu Bar pilih menu Modify > Solids Editing > Taper Faces.
2. Select faces or [ Undo/Remove] :

Pilih permukaan objek 3D.
3. Select faces or [ Undo/Remove/ALL] : r .

Pilih option remove dengan mengetik R untuk membatalkan permu-
kaan 3D yang terpilih.
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10,

11

12.
13.

Remove faces or [ Undo/Add/ALIL] :

Pilih permukaan objek 3D yang tidak Anda pergunakan.
Remove faces or [ Undo/Add/ALIL] :

Tekan Enter.

Specify the base point:

Tentukan titik pertama untuk menentukan sumbu taper.

Specify another point along the axis of tapering:

Tentukan titik kedua dari sumbu taper. Lihat Gambar 5.20.
Specify the taper angle: 30

Tentukan besar sudut kemiringan.

Gambar 5 20: Menentukan Sumbu Taper

Sobadd val it o sttt

Solid validation complete.

.Enter a face editing option

[ Extrude/Move/Rotate/Offset/
Taper/Delete/Copy/coLor/Undo/eXit] : x.

Pilih Exit dengan mengetik X untuk keluar dari option Face.

Solids editing automatic checking: SOLIDCHECK=1.

Enter a solids editing option
[ Face/Edge/Body/Undo/eXit] <eXit>: x

Pilih Exit dengan mengetik X untuk mengakhiri perintah.
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Gambar 5.21: Menggunakan Taper Faces

DELETE FACES

Delete faces adalah perintah yang digunakan untuk menghapus permu-
kaan objek 3D solid modelling.

Untuk menggunakan perintah delete faces dapat dilakukan dengan cara:

1.
2.

Pada Menu Bar pilih menu Modify > Solids Editing > Delete Faces.
Select faces or [ Undo/Remove] :

Pilih permukaan objek 3D.

Select faces or [ Undo/Remove/ALL] : r.

Pilih option remove dengan mengetik R untuk membatalkan permu-
kaan 3D yang terpilih.

Remove faces or [ Undo/Add/ALL] :

Pilih permukaan objek 3D yang tidak Anda edit.

Gambar 5.22: Memilih Permukaan Objek 3D Solid Modelling
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5. Remove faces or [ Undo/Add/ALIL] : 3. Specify other corner point or

Tekan Enter. [ Area/Dimension/Rotation] : @350, 400
6. Solid validation complete. Tentukan koordinat sudut rectangle kedua.

7. Enter a face editing option
[ Extrude/Move/Rotate/Offset/ RUANG KERJA 2
Taper/Delete/Copy/coLor/Undo/eXit] : x.

Buat sumbu dinding ruang kerja 2 menggunakan rectangle dengan

Pilih Exit dengan mengetik X untuk keluar dari option Face. langkah-langkah sebagai berikut:

8. Solids editing automatic checking: SOLIDCHECK=1. 1. Pada Menu Bar pilih menu Draw > Rectangle

9. Enter a solids editing option ‘ 2. Specify first corner point or [ Chamfer/Eevation/Fillet/
[ Face/Edge/Body/Undo/eXit] <eXit>: x Thickness/Width] :
Pilih Exit dengan mengetik X untuk mengakhiri perintah. Letakkan sudut rectangle pada ujung kanan bawah dari R.Tidur I,

gunakan endpoint.

Specify other corner point or
[ Area/Dimension/Rotation] : @350,400

ST\

/

Gambar 5.23: Menggunakan Delete Faces ‘ 400
f
50
MENGGAMBAR SUMBU DINDING I R
Buat layer baru dengan nama Sumbu Dinding dan tentukan sebagai -

layer aktif. Buat objek sumbu dinding menggunakan rectangle. Gambar 5.24: Penggambaran As Dinding R. Kerja

RUANG KERJA 1 KAMAR MANDI 1

Buat sumbu dinding ruang kerja 1 menggunakan rectangle dengan Buat sumbu dinding kamar mandi 1 menggunakan rectangle dengan
langkah-langkah sebagai berikut: langkah-langkah sebagai berikut:

1. Pada Menu Bar pilih menu Draw > Rectangle. 1. Pada Menu Bar pilih menu Draw > Rectangle
2. Specify first corner point or [ Chamfer/Eevation/Fillet/ 2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Thickness/Width] :

Tentukan sudut rectangle dengan jarak 50 cm dari ujung lantai,
gunakan osnap from endpoint.

Letakkan sudut rectangle pada ujung kiri atas dari R.Tidur 1,
gunakan endpoint.
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k.

Letakkan sudut rectangle pada ujung kanan atas dari R.Tidur 2,

. i i t i
3. Specify other corner point or gunakan endpoint.

[ Area/Dimension/Rotation] : @200,200
3. Specify other corner point or

Tentukan koordinat sudut rectangle kedua. [ Area/Dimension/Rotation] : @350,-200.

KAMAR MANDI 2 RUANG TAMU

Buat sumbu dinding Kamar Mandi 2 menggunakan rectangle dengan

Buat sumbu dinding ruang tamu menggunakan rectangle d
langkah-langkah sebagai berikut: g g gd g engan

langkah-langkah sebagai berikut:

1. Pada Menu Bar pilih menu Draw > Rectangle ' 1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/

2. Specify first corner point or [ Chamfer/Eevation/Fillet
Thickness/Width] : p y p [ / / /

Thickness/Width] :
Letakkan sudut rectangle pada ujung kiri atas dari kamar mandi 1,

N dpoint Letakkan sudut rectangle pada ujung kanan bawah dari R.
gunakan endpoint.

Penerima, gunakan endpoint.
3. Specify other corner point or 3

Specif th int
[ Area/Dimension/Rotation] : @200,200 becily other corner point or

[ Area/Dimension/Rotation] : @350, 200

Tentukan koordinat sudut rectangle kedua. Tentukan koordinat sudut rectangle kedua.

r-ZDD "'I rzun "I

_..._
™3
=
Io
-3
(o)
o

400
tl 4
J ) 50

ﬁgJ-,, '79 Ao B R R 354 V-L T N

50

Gambar 5.25: Penggambaran As Dinding Kamar Mandi Gambar 5.26: Penggambaran As Dinding R. Penerima dan R Tamu

Buat sumbu dinding ruang penerima menggunakan rectangle dengan

Buat sumbu dinding ruang tidur 3 menggunakan rectangle dengan
langkah-langkah sebagai berikut:

langkah-langkah sebagai berikut:

1. Pada Menu Bar pilih menu Draw > Rectangle. 1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/ 5

, X Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Thickness/Width] :
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Letakkan sudut rectangle pada ujung kiri atas dari R.Tamu,
gunakan endpoint.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @350,400.

Tentukan koordinat sudut rectangle kedua.

AREA KERJA

Buat sumbu dinding area kerja menggunakan rectangle dengan langkah-
langkah sebagai berikut:
1. Pada Menu Bar pilih menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Letakkan sudut rectangle pada ujung kanan atas dari kamar mandi
2, gunakan endpoint.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @850,-400.

Tentukan koordinat sudut rectangle kedua.
200 850 t=—350
[ =1

400

200

50]

l ! 350 I 350 ! 350 ! SEUﬁl

Gambar 5.27: Penggambaran As Dinding Area Kerja

MENGGAMBAR DINDING

Buat layer baru dengan nama Dinding-3D dan tentukan sebagai layer
aktif. Buat gambar dinding menggunakan perintah offset, Lakukan
langkah berikut untuk mendapatkan gambar dinding:
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1. Pada Menu Bar pilih menu Modify > Offset.

2. Specify offset distance or [ Through/Erase/Layer]
<Through>: 7.5

Tentukan jarak offset.
3. Select object to offset or [ Exit/Undo] <Exit>:
Pilih objek yang akan Anda offset.

4. Specify point on side to offset or [ Exit/Multiple/Undo]
<Exit>: m

Ketik M untuk memilih option multiple.
5. Select object to offset or [ Exit/Undo] <Exit>:

Offset rectangle dan letakkan pada di sisi dalam rectangle.
6. Select object to offset or [ Exit/Undo] <Exit>:

Offset rectangle dan letakkan pada di sisi luar rectangie.

7. Select object to offset or [ Exit/Undo] <Exit>: E

Ketik E untuk memilih option Exit.

Gambar 5.28: Penggambaran Dinding Dangan Offaet

Langkah selanjutnya, Anda akan memberikan hetinggian seboaar 190
cm. Gunakan perintah Extrude dan pilih objek hasil oftset L akukan
pada semua garis dinding dari tiap-tiap ruang, (Untuk mendapathan
hasil maksimal ubah sudut pandang SW Isometric.

1. Pada Menu Bar pilih menu Draw > Modeling > Extrude
2. Select object:

Pilih rectangle.
3. Select object:

Tekan Enter.

Membuat Bangunan Kantor Minimalis | 177




Gambar 5.29: Hasil Extrﬁde R. Tidur Dan Kamar Mandi

4. Specify height of extrusion or [ Path] : 350.
Tinggi dinding.
5. Specify angle of taper for extrusion <0>:

Tekan Enter.

Gambar b 30 Penggambaran Dinding Perintah Extrude
Mengagunakan perintah Fxtrude, Anda akan mendapatkan gambar
tuang  yang solid, untuk  menyelesaikan gambar dinding gunakan

perintah Substract dengan cara mengurangi dinding luar dan dinding
dalam, sehingga didapat bentuk ruang yang kosong.

1. Pada Menu Bar pilih menu Modify > Solids Editing > Subtract.
2. Select object:
Pilih objek 3D solid bagian luar.
3. Select object:
Tekan Enter.
4. Select object:
Pilih objek 3D solid bagian dalam.
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5. Select object:

Tekan Enter.

Gambar 5.31: Pengurangan Dinding

Anda dapat melakukannya pada tiap-tiap ruang yang ada sehingga
menghasilkan gambar dinding seperti terlihat pada Gambar 5.32.

Gambar 5.32: Dinding Dengan Perintah Subtract

MENGGAMBAR PINTU JENDELA

Buat layer baru dengan nama Pintu dan tentukan sebagai layer aktif.
Selanjutnya Anda akan menambahkan objek pintu jendela sebagai
pintu masuk.
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MENGGAMBAR PINTU 14. Specify second point or [ Exit/Undo] <Exit>:

Kusen menggunakan kayu 6/15 dengan tinggi pintu 246 cm, lebar Tekan Enter.

daun pintu 80 cm, lebar jendela 70 cm dan tinggi jendela 180 cm. 15. Untuk membuat kusen mendatar bagian atas Pada Menu Bar pilih

Untuk menggambar pintu Anda dapat mengikuti langkah-langkah menu Draw > Rectangle.

berikut ini: 16.Specify first corner point or [ Chamfer/Eevation/Fillet/

1. Untuk membuat kusen tegak bagian kiri Pada Menu Bar pilih menu Thickness/Width] :

Draw > Rectangle. Tentukan sudut rectangle pada ujung kiri depan kusen tegak bagian

2. Specify first corner point or [ Chamfer/Eevation/Fillet/ atas.

Thickness/Width] : 17.8pecify other corner point or

Area/Di i Rotati T @92
Tentukan sudut rectangle. [ Area/Dimension/Rotation] : @92,15

3. Specify other corner point or Tentukan koordinat sudut rectangle kedua.

[ Area/Dimension/Rotation] : €6,15. l 18. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Tentukan koordinat sudut rectangle kedua. 19.8elect object: Pilih rectangle.

4. Pada Menu Bar pilih menu Draw > Modeling > Extrude 20.Select object, lalu tekan Enter.

5. Select object: 21.8pecify height of extrusion or [ Path] : -6
Pilih rectangle. v Tinggi pintu.

6. Select object: 22.8pecify angle of taper for extrusion <0>:
Tekan Enter. Tekan Enter.

I. Specity height of extrusion or [ Path] : 246

Linggl pintu, %Eﬁ
He o oDpeaadly angle o taper for extrusion <0>: i

Tekan Enter.

riel)

9. Pada Menu Bar pilih menu Modify > Copy
10.Select object:

Pilih gambar kusen tegak.

11.Select object:

=

Tekan Enter.

=

12.8pecify base point or [ Displacement] <Displacement>:

Tentukan titik acuan. Gambar 5.33: Pembuatan Kusen Pintu

13.8pecify second point or <use first point as Selanjutnya Anda akan menambahkan kusen jendela pada kusen pintu
displacement>: @86,0 dengan langkah-langkah berikut ini:
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1. Untuk membuat kusen mendatar bagian atas Pada Menu Bar pilih
menu Draw > Rectangle.

2. Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung atas depan kusen tegak
sebelah kanan.

3. Specify other corner point or
[ Area/Dimension/Rotation] : @152,15

Tentukan koordinat sudut rectangle kedua.
4. Pada Menu Bar pilih menu Draw > Solids > Extrude.
5. Select object:
Pilih rectangle.
6. Select object:
Tekan Enter.
7. Specify height of extrusion or [ Path] : -6
Tinggi pintu.
8. Specify angle of taper for extrusion <0>:
Tekan Enter.

9. Gandakan kusen mendatar untuk membuat kusen bagian bawah,
Pada Menu Bar pilih menu Modify > Copy

Lo Select object:
Pilih gambar kusen mendatar.

11. Select object, lalu tekan Enter.

12.Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

13.Specify second point or <use first point as
displacement>: Q0,0,-186

14.Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

15. Untuk membuat kusen tegak Pada Menu Bar pilih menu Draw >
Rectangle.

=

Gambar 5.34: Pembuatan Kusen Jendela pada Pintu

16.Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kanan depan kusen mendatar
bagian atas.

17.8pecify other corner point or
[ Area/Dimension/Rotation] : @-6,15.

Tentukan koordinat sudut rectangle kedua.
18. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
19.Select object:
Pilih rectangle.
2QjSelect object:
Tekan Enter.
21.8pecify height of extrusion or [ Path| :~19)
Tinggi jendela.
22.8pecify angle of taper for exlrnnion <0
Tekan Enter.
23. Gandakan kusen tegak untuk membuat kusen tegak bagian kanan,
23. Pada Menu Bar pilih menu Modify > Copy.
24 . Select object:
Pilih gambar kusen tegak.
2H.Select object:
Tekan Enter.

4809 Aiknan 9818 untiitk Baaaln
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26.

27.

28.

Untuk menggabungkan kusen pintu

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @-76,0.

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

jendela gunakan perintah

penggabungan atau union.

1.
2.

Pada Menu Bar pilih menu Modify > Solids Editing > Union
Select object:

Pilih semua kusen pintu jendela.

Select object:

Tekan Enter.

\

Gambar 5.35: Penggabungan kusen dengan perintah Union

Untuk menggambar daun pintu Anda dapat mengikuti langkah-langkah
berikut ini:

1.
2.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah belakang kusen tegak
sebelah kiri.
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Specify other corner point or
[ Area/Dimension/Rotation] : @80, -3

Tentukan koordinat sudut rectangle kedua.

4. Pada Menu Bar pilih menu Draw > Solids > Extrude.
Select object:
Pilih rectangle.
6. Select object, lalu tekan Enter.
Specify height of extrusion or [ Path] : 240
Tinggi pintu.
8. Specify angle of taper for extrusion <0>:
Tekan Enter.
i
e
/
%
=
=
-
|
Gambar 5.36: Menggambar Daun Pintu
MENGGAMBAR JENDELA
Selanjutnya Anda akan menambahkan objek jendela pada 1uang tidur,

ruang tamu dan ruang keluarga. Kusen menggunakan kayu 6/15
dengan lubang jendela 180 cm dan lebar jendela 70 ¢cm.

Untuk menggambar kusen jendela Anda dapat mengikuti langkah-
langkah berikut ini:

1.

Untuk membuat kusen mendatar bagian bawah Pada Menu Bar
pilih menu Draw > Rectangle.
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13.

14.

15.

16.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

Specify other corner point or
[ Area/Dimension/Rotation] : Q158,15

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 6
Tinggi pintu.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan kusen mendatar untuk membuat kusen bagian atas,
Pada Menu Bar pilih menu Modify > Copy

Seelect object:
Pilih gambar kusen mendatar.
EYRN RYI IR R FRYIN

lekan Enter.

Lopecity base point oor [ bisplacement] <Displacement>:

Tentukan titik acuan.

Specify second point or <use first point as
displacement>: ©@0,0,186

Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

Untuk membuat kusen tegak Pada Menu Bar pilih menu Draw >

Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :
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17.

18.
19.

20.

21.

22.

23.

24.

25.

26.

27

28.
29.

. Specify second point o1

Tentukan sudut rectangle pada ujung kiri depan kusen mendatar
bagian atas.

Specify other corner point or
[ Area/Dimension/Rotation] : @6, 15

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] :-192
Tinggi jendela.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan kusen tegak untuk membuat kusen tegak bagian kanan
dan tengah, Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih gambar kusen tegak.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement «:
Tentukan titik acuan.

D ETRU B A I | provint an

displacement>: @-'76,0
Specify second point or [ Exil /Undo]- Fxit <0 o], 0

Specify second point or [ Exit/Undo)«Exit -, lalu Entenr .
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Gambar 5.37; Menggambar Kusen Jendela
Untuk menggabungkan kusen jendela Anda dapat mengikuti langkah-
langkah berikut ini:
1. Pada Menu Bar pilih menu Modify > Solids Editing > Union.
2. Select object: Pilih semua kusen jendela.

3. Select object, lalu tekan Enter.

%\“

"

Gambar 5.38: Penggabungan kusen jendela
Untuk menambahkan daun jendela Anda dapat mengikuti langkah-
langkah berikut ini:

1. dntuk membuat daun jendela tegak sebelah kiri, Pada Menu Bar
pilih menu Draw > Rectangle.
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12.

13.

14.

15.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah depan dari kusen
jendela sebelah Kiri.

Specify other corner point or
[ Area/Dimension/Rotation] : @15, 3.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 180
Tinggi jendela.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan daun jendela tegak untuk membuat daun jendela tegak
bagian kanan, Pada Menu Bar pilih menu Modify > Copy.

.Select object:

Pilih daun jendela tegak.

.Select object:

Tekan Enter.
Specify base point or [ Displacement] - bisplacement -
Tentukan titik acuan.

Specify second point or <usc fitsb poinl oan
displacement>: @55,0.

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

Untuk membuat daun jendela mendatar bagian bawah, Pada Menu
Bar pilih menu Draw > Rectangle
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le.

17.

18.
19.

20.

21.
22.

23.

27.

28.

e beet

LOpecity bane

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah depan dari kusen
tegak sebelah Kkiri.

Specify other corner point or
[ Area/Dimension/Rotation] : @40,3

Tentukan koordinat sudut rectangle kedua.

Pada Menu.Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 15
Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan daun jendela mendatar untuk membuat daun jendela
mendatar bagian atas, Pada Menu Bar pilih menu Modify > Copy
object:

Piibv daun jendela mendatar.

e lec b b et

lelkan Enter.

point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @0,0,165

Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.
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Gambar 5.39: Membuat Daun Jendela

Untuk menggabungkan daun jendela Anda dapat mengikuti langkah-
langkah berikut ini:

1. Pada Menu Bar pilih menu Modify > Solids Editing > Union.
2. Select object:

Pilih semua daun jendela.
3. Select object:

Tekan Enter.

Untuk menggandakan daun jendela Anda dapat mengikuti langkah-
lal;lgkah berikut ini:

1. Gandakan daun jendela untuk membuat jendela sebelah kanan,
Pada Menu Bar pilih menu Modify > Copy

2. Select object:
Pilih daun jendela sebelah kiri.
3. Select object:
Tekan Enter.
4. Specify base point or [ Displacement] <Displacoment -:
Tentukan titik acuan.

5. Specify second point or <use first point as
displacement>: @76,0

6. Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.
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8. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
/ Width] : @0,-192.
e % 9. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : @-152,0.
10. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
j width] : @0, -54.

11. Specify next point or [Arc/Close/Halfwidth/Length/Undo/ Width]: ¢
Ketik C untuk memilih option close.
L]

12. Pada Menu Bar pilih menu Draw > Modeling > Extrude.

Gambar 5.40: Hasil akhir penggambaran Jendela 13. select object:
Pilih polyline.
MENEMPATKAN PINTU DAN JENDELA 14.Select object, lalu tekan Enter.
Untuk menempatkan objek pintu dan jendela pada bangunan, Anda 15. Specify height of extrusion or [ Path] : -30

harus membuat lubang terlebih dahulu pada dinding, untuk kemudian . ‘
diletakkan objek pintu dan jendela. 16.Specify angle of taper for extrusion <0>:

Tekan Enter.
MEMBUAT OUTLINE PELUBANG DINDING

Untuk dapat melubangi dinding, Anda membuat objek pelubang
dengan cara membuat outline dari pintu jendela dengan perintah
polyline kemudian beri ketebalan lebih besar dari tebal dinding. Lihat
Ciambar H.42.

I (ntuk membuat outline pelubang, ubah UCS menjadi tampak -
depan, Pada Menu Bar pilih menu Tools > Named UCS.

Pada kotak dialog UCS, pilih tab Orthographic UCS'’s.

Pada daftar pilih Front dan tekan Set Current. 4

-

-~

v

Klik Menu Browser dan pilih menu Draw > Polyline. //[/51/ i~

s W N

Specify start point:
) Gambar 5.41: Pengaturan UCS
Tentukan titik pertama pada ujung kiri bawah dari objek pintu

jendela.

6. Specify next point or :
[ Arc/Halfwidth/Length/Undo/Width] : Q0,246. ,

Tentukan titik berikutnya.

7. Specify next point or [ Arc/Close/Halfwidth/Length/Undo/ '
Width] : @244,0.
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Gambar 5.42: Membuat Pelubang Pintu Jendela

.

Gambar 5.43: Membuat Pelubang Jendela

MENEMPATKAN PELUBANG DINDING
Selain pada pintu jendela, Anda juga membuat outline pelubang untuk

objek jendela. Sebelum menempatkan pelubang dinding, ubah UCS menjadi UCS

. World dan gabungkan semua dinding dengan perintah Union.
1. Pada Menu Bar pilih menu Draw > Polyline.
1. Command: UCS.
2. Specify start point:
2. Current ucs name: * FRONT*
Tentukan titik pertama pada ujung kiri bawah dari objek jendela. . _
3. Enter an option [ New/Move/orthoGraphic/Prev/Restore/
i, Specify next poilnt or Save/Del/Rpply/? /World] <World>:
| Aeo/Haltwidth/Length/Undo/Width] ¢ @0,192
Tekan Enter.

Fentukan titik berikutnya. A .. . .
4. Pada Menu Bar pilih menu Modify > Solids Editing > Union
Aoty et perint or [ Arce/Close/Halfwidth/Length/Undo/ .
Width] @ e, o 5. Select object:
Y.otpecity next point or [ Arce/Close/Hal fwidth/Length/Undo/ Pilih semua dinding.

Width] : @0, -192 6. Select object:

6. Spec1fy next point or [ Arc/Close/Halfwidth/Length/Undo/ Tekan Enter.
Width] : ¢

Ketik C untuk memilih option close. Ter:npatkan pelubang dinding sesuai pada gambar denah menggunakan

perintah move.

7. Pada Menu Bar pilih menu Draw > Modeling > Extrude.

1. Command: move.

Select object: 2. Select object:

Pilih polyline lalu tekan Enter. Pilih semua objek pintu jendela.

9. Specify height of extrusion or [ Path] : -30 3. Select object:

10.8pecify angle of ta for extrusion <0>: Tekan Enter.
be y g-€ ber 1o usion Tekan Enter.
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4. Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada ujung kiri bawah.

5. Specify second point or <use first point as
displacement>:

Letakkan pada dinding R. Penerima. ;
Gunakan perintah subtract untuk mengurangi dinding dengan pelubang
dinding.
1. Pada Menu Bar pilih menu Modify > Solids Editing > Subtract
2. Select object:

Pilih objek dinding.
3. Select object:

Lalu tekan Enter. \

4. Select solids and region to substract
5. Select object:

Pilih pelubang dinding.
6. Select object, lalu tekan Enter.

—

<
///////// Mﬁ%ﬁ

Gambar 5.44; Menempatkan Pintu Jendela

MENEMPATKAN PELUBANG JENDELA

Tempatkan pelubang jendela sesuai pada gambar denah menggunakan
perintah move.

A6R 1 Aitalad 2040 untik Dasain AanAUnER m‘- .

10.

11.

12.

13.

14.

Command: move.

Select object:

Pilih semua objek jendela.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada tengah-tengah kusen mendatar bagian
bawah.

Specify second point or <use first point as
displacement>:

Letakkan di tengah-tengah dinding R.Tamu. Lihat Gambar 5.45.
Command: move.

Select object:

Pilih semua objek jendela.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan dari objek jendela.

Specify second point or <use first point as
displacement>: @0,0,54

Gandakan jendela dan tempatkan pada ruang kerja dan arca kerja
seperti pada gambar denah, Pada Menu Bar pilih menu Modlfy -

Copy
Select object:

Pilih objek jendela.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada tengah-tengah dinding bagian bawah
sebelah dalam.
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15.8pecify second point or <use first point as “\\K\//L//
displacement>:

Tempatkan pada tengah-tengah dinding bagian bawah sebelah
dalam dari ruang kerja. Seperti terlihat pada Gambar 5.46.

16.Specify second point or [ Exit/Undo] <Exit>: //;;
Tekan Enter.

Gunakan perintah subtract untuk mengurangi dinding dengan pelubang
dinding.

1. Pada Menu Bar pilih menu Modify > Solids Editing > Subtract
2. Select cbject:
Pilih objek dinding.

3. Select object: Gambar 5.46: Menempatkan Jendela pada R. Kerja
Lalu tekan Enter.
4. Select solids and region to substract MENGGAMBAR ATAP BANGUNAN
5. Select object: Buat layer baru dengan nama Atap-3D dan tentukan sebagai layer
Pilih pelubang dinding. aktif, matikan layer yang lainnya kecuali layer Lantai-3D.
6. Select object: Untuk menggambar atap bangunan lakukan langkah-langkah berikut
ini:
[.olu tekan Enter.
1. Ubah UCS terhadap sumbu Y untuk membuat garis bantu atap
bangunan.
\\\/ 2. Pada Menu Bar pilih menu Tools > New UCS > Y
\i\\ ™~ 3. Current ucs name: *NO NAME*
qgtw \\\\w*\\ 4. Enter an option
\¥QL N [ New/Move/orthoGraphic/Prov/Rest are/ v/
Del/Apply/? /World] <World-: vy
5. Specify rotation angle aboul Y axis -0 0
\ Tentukan sudut perputaran terhadap sumbu Y.
\ 6. Pada Menu Bar pilih menu Tools > New UCS > Origin.
Current ucs name: *NO NAME*
8. Enter an option
e [ New/Move/orthoGraphic/Prev/Restore/Save/

Del/Apply/? /World] <World>: o
Gambar 5.45: Menempatkan Jendela pada R. Tamu -
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9. Specify new origin point <0,0,0>:

Tentukan titik origin UCS seperti pada gambar berikut.

Gambar 5.47: Mengubah Orientasi UCS

10. Buat garis atap dengan perintah polyline seperti pada gambar 5.48.

11. Tambahkan ketebalan pada objek atap bangunan dengan perintah
extrude.

12. Pada Menu Bar pilih menu Draw > Solids > Extrude.

Gambar 5.48: Membuat Garis Atap

13.Select object: Pilih garis atap.

14.5elect object: Tekan Enter.

15.Specify height of extrusion or [ Path] : 685.
Lebar atap.
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16.Specify angle of taper for extrusion <0>:

Tekan Enter.

Gambar 5.49: Menggambar Atap Bangunan

17. Buat garis atap pada sisi yang berlawanan arah yang mempunyai
ukuran yang berbeda dari atap pada sisi yang telah Anda buat
sebelumnya seperti yang terlihat pada Gambar 5.50.

Gambar 5.50: Menggambar Atap

18. Tambahkan dinding bangunan di bawah garis atap menggunakan
perintah polyline dan extrusi.

Aktifkan semua layer untuk melihat hasil akhir penggambaran
bangunan dan gunakan sudut pandang SE Isometric. Untuk
menyembunyikan garis yang berada di belakang objek gunakan
perintah hide, command: hide.
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Gambar 5.51: Hasil akhir yang didapat

MENGGAMBAR GAMBAR PERSPEKTIF

Untuk melihat sudut pandang objek 3D, Anda dapat juga menggunakan
sudut pandang perspektif yang mempunyai titik lenyap dengan cara
Pada Menu Bar pilih menu View > Orbit > Free Orbit. Ada empat
pengaturan dasar yang dapat kita lakukan dengan menempatkan
pointer pada area tertentu Archball, yaitu:

7

%+ Perputaran terhadap Sumbu Z @'; Gerakkan pointer yang berada
di luar Archball.
|
< Perputaran terhadap Sumbu Y @; Metode ini dapat dilakukan bila
pointer berada pada salah satu lingkaran kecil dan digerakkan
menurut garis horizontal.

< Perputaran terhadap Sumbu X _@_; Metode ini dapat dilakukan bila
pointer berada pada salah satu lingkaran kecil dan digerakkan
menurut garis vertikal.

< Perputaran ke Segala Arah l"‘1‘?"; Gerakkan pointer yang berada di
dalam Archball.
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Gambar 5.52: Perintah 3D Orbit

Untuk menggunakan perspektif, Pada Menu Bar pilih menu View >
Orbit > Free Orbit, lalu klik kanan, pada menu shortcut pilih Projection
> Perspective. Lihat Gambar 5.53.

Gambar 5.53: Tampilan Perspektif

Langkah terakhir adalah menambahkan kanopi pada teras bangunan

dengan membuat objek kolom teras seperti yang terlihat pada Gambar
5.54.
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Gambar 5.54: Menambahkan Kolom Teras Kantor

Tambahkan juga atap kanopi yang merupakan dak beton untuk
menutupi teras kantor seperti yang terlihat pada Gambar 5.55.

Gambar 5.55: Menambahkan Atap Kanopi Teras Kantor

Tambahkan Dinding ormamen pada ruang kerja untuk memnambahkan
kesan minimalis pada bangunan kantor seperti yang terlihat pada
Gambar 5.56.

Gambar 5.56: Menambahkan Dinding Ornamen

Gambar 5.57: Hasil Akhir Rumah Kantor Minimalis
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MEMBUAT DESAIN
RUKO MINIMALIS

bertingkat yang diawali dengan perencanaan denah bangunan

dan kemudian diselesaikan dengan gambar 3D. Sebelum
mengerjakan bangunan 3D, persiapkan gambar denah yang menunjuk-
kan ukuran dari masing-masing ruang.

atihan selanjutnya adalah menggambar objek desain sebuah ruko
LQ

I

|

1

I

7

!
|

l

Gambar 6.1: Menggambar Desain Ruko




MENGGAMBAR DINDING

Buat objek dinding menggunakan gambar denah dan dinding tersebut
mempunyai ketinggian 3m dengan langkah-langkah sebagai berikut:

1. Pada toolbar Layer buat layer dinding dan tentukan sebagai layer
aktif.

2. Buat gambar outline dinding menggunakan perintah line dengan
berpedoman pada denah 2D. Lihat Gambar 6.2 dan 6.3.

r‘————4500"—"‘_2500"—‘1
1500 =00
| _ t 4! t 500‘—“1
=
T
3000 3000 2000
—— — e
sa0o aso0 2500 2500
2500
7 35060 3500
i
i |
2000 — -
g o
00 } 4000 ——r] }o—3000 —e——— 4000——}
DEN&H LANTAI 1 DENAH LANTAL 2

‘Gambar 6.2: Gambar denah lantai 2

I————4500 -———-1-—250 0—-1

2500 2500

| 3000—=b——— s000———

TENAH LANTAI 3

z

Gambar 6.3: Gambar denah lantai 3
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Rapikan garis-garis outline dinding yang saling berpotongan
menggunakan perintah trim.

Pada Menu Bar pilih menu Draw > Region.

Select Object:

Pilih semua objek objek dinding lalu tekan Enter. Seperti terlihat
pada Gambar 6.4 dan Gambar 6.5.

=

[ e

Gambar 6.4: Membuat Bidang Tertutup

Gambar 6.5: Membuat Bidang Tertutup Lt.3

. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
7. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
. Select ocbject: All

Ketik All untuk memilih semua objek dinding, lalu tekan Enter.
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9.

10.

11.
12.

13.

14.
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Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: 3000.

Ketik 3000 untuk menentukan tinggi dinding. Lihat Gambar 6.6.

Gambar 6.6: Menentukan Tinggi Dinding

Objek dinding yang ada masih belum berlubang dan masih
menyatu, untuk itu kurangi dinding bagian luar dengan dinding
bagian dalam.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bagian luar, lalu tekan Enter.

Select object:

Pilih semua objek dinding bagian dalam lalu tekan Enter.

Ulangi perintah untuk mengurangi objek dinding lantai 2 dan lantai
3.

Gambar 6.7: Menentukan Tinggi Dinding Lt 3

15.
16.

17.

18.

19.
20.

21.

22.

23.

24.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bagian luar, lalu tekan Enter.

Select object:

Pilih semua objek dinding bagian dalam, lalu tekan Enter.

Pindahkan objek dinding lantai 3 di atas objek dinding lantai 2.
Lihat Gambar 6.8.

Gambar 6.8: Memindahkan Dinding Lantai 3

Pada Menu Bar pilih menu Modify > Move.
Select object:

Pilih objek dinding lantai 2 yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
END

Tentukan titik acuan menggunakan object snap endpoint.

Specify second point or <use first point displacement>:
END

Gunakan object snap endpoint.

Pindahkan objek dinding lantai 2 dan 3 di atas objek dinding lantai
1.

Pada Menu Bar pilih menu Modify > Move.
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25.

26.

27

Select object:

Pilih objek dinding lantai 2 dan 3 yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:

END

Tentukan titik acuan menggunakan object snap endpoint.

. Specify second point or <use first point displacement>:

END

Gunakan object snap endpoint.

/

w7y

JAVAN
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Gambar 6.9: Memindahkan Dinding Lantai 2 dan 3

28. Pada Menu Bar pilih menu Modify > Solid Editing > Union.

29.S8elect object:

Pilih semua objek dinding bangunan, lalu tekan Enter. Seperti
terlihat pada Gambar 6.10.

30. Pada Menu Bar pilih menu View > Visual Styles > 3D Hidden.
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Gambar 6.10: Hasil Pembuatan Objek Dinding

MENGGAMBAR LANTAI

Buat objek lantai ketebalan lantai 10 cm dengan langkah-langkah

berikut:

1. Pada toolbar Layer buat layer lantai dan tentukan sebagai layer
aktif.

2. Pada Menu Bar pilih menu View > 3D Views > Top.

3. Buat bidang dasar objek lantai 1.

4. Pada Menu Bar pilih menu Draw > Polyline.

5. Specify first point: END.
Tentukan titik pertama menggunakan object snap endpoint.

6. Specify next point or

[ Arc/Halfwidth/Length/Undo/Width] : END.
Tentukan titik berikutnya menggunakan object snap endpoint.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width] : END.

Tentukan titik berikutnya menggunakan object snap endpoint.

Specify next point or [ Arc/Close/Halfwidth/Length/Undo/
Width) : C.
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10.

11.

12.
13.

14.

15.

16.

Gambar 6.11: Menentukan Penempatan Titik Lantai

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object: L.
Ketik L untuk memilih objek terakhir yang Anda buat, tekan Enter.

Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: -100.

Ketik -100 untuk menentukan ketebalan objek lantai.
Pada Menu Bar pilih menu Modify > Copy.
Select object: P.

Ketik P untuk memilih objek sebelumnya yang Anda pilih, tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
Klik pada sembarang tempat untuk menentukan titik acuan.

Specify second point or <use first point displacement>:
@0, 0,3000

Ketik @0,0,300 untuk menggandakan objek ke atas.

Specify second point or <use first point displacement>:
@0, 0,6000

Ketik @0,0,600 untuk menggandakan objek ke atas.
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Gambar 6.12: Memindahkan Objek Lantai 2

17.Specify second point or <use first point displacement>:
Tekan Enter.

18. Pada Menu Bar pilih menu View > 3D Views > SW Isometric.

Gambar 6.13: Memindahkan Objek Lantai 3
Lanjutkan pembuatan objek lantai dengan menambahkan objek lantai
teras depan dan belakang dengan langkah-langkah sebagai berikut:

1. Pada toolbar Layer buat layer lantai teras dan tentukan sebagai
layer aktif.

2. Pada Menu Bar pilih menu View > 3D Views > Top.
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3. Pada Menu Bar pilih menu Draw > Rectangle.

4. Specify first corner point or
[ Chamfer/Elevation/Fillet/ Thickness/Width] : END.

Tentukan sudut rectangle menggunakan object snap endpoint.

5. Specify other corner point or
[ Area/Dimensions/Rotation] :

Ketik @3000,-1000 untuk menentukan sudut kedua.

@3000,-1000

I

Gambar 6.14: Penempatan Lantai Teras

6. Pada Menu Bar pilih menu Draw > Rectangle.

7. Specify first corner point or
[ Chamfer/Elevation/Fillet/ Thickness/Width] : END

Tentukan sudut rectangle menggunakan object snap endpoint.

8. Specify other corner point or
[ Area/Dimensions/Rotation] : ©@3500,2000

Ketik @3500,2000 untuk menentukan sudut kedua.
9. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
10.Select object:

Anda pilih semua objek lantai teras, lalu tekan Enter.

11.Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: -100.

Ketik -100 untuk menentukan ketebalan objek lantai.

Gambar 6.15: Menentukan Tebal Lantai Teras

MENGGAMBAR PINTU

Kusen menggunakan kayu 6/12 c¢m, Untuk menggambar pintu Anda
dapat mengikuti langkah-langkah berikut ini:

1.
2.

Pada Menu Bar pilih menu Draw > Rectangle

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

Specify other corner point or

[ Area/Dimension/Rotation] : @60,120.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 2360
Tinggi pintu.
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10.

11.

12.

13.

14.

15.
16.

17.

18,
19.

20.

21.

22.

Specify angle of taper for extrusion <0>:

Tekan Enter.

Pada Menu Bar pilih menu Modify > Copy.

Select object:

Pilih gambar kusen tegak.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @960,0

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.
Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kiri depan kusen tegak bagian
atas.

Specify other corner point or
[ Area/Dimension/Rotation] : @1020,120

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : -60
Tinggi pintu.

Specify angle of taper for extrusion <0>:

Tekan Enter.
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23.

24

25.

26.
27.

28.

29.

30

31.

32.

Gambar 6.16: Pembuatan Kusen Pintu

Pada Menu Bar pilih menu Draw > Rectangle

.Specify first corner point or [ Chamfer/Eevation/Fillet/

Thickness/Width] :

Tentukan sudut rectangle pada ujung atas depan kusen tegak
sebelah kanan.

Specify other corner point or
[ Area/Dimension/Rotation] : @1520,120

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Solids > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : -60.
Tinggi pintu.
.Specify angle of taper for extrusion <0>:

Tekan Enter.

Gandakan kusen mendatar untuk membuat kusen bagian bawah,
Pada Menu Bar pilih menu Modify > Copy.

Select object:

Pilih gambar kusen mendatar.
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33.

34.

35.

36.

37.
38.

39.

Select object:
Tekan Enter.
Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @0,0,-1960.

Specify second point or [ Exit/Undo] <Exit>:

7

Tekan Enter.

)

“

%L%

J

Gambar 6.17; Pembuatan Kusen Jendela pada Pintu

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung kanan depan kusen mendatar
bagian atas.

Specify other corner point or
[ Area/Dimension/Rotation] : @-60,120

Tentukan koordinat sudut rectangle kedua.

40. Pada Menu Bar pilih menu Draw > Modeling > Extrude.

41.

Select object:

Pilih rectangle.

42.

43

44,

45.

46.

47.

48.

49.

50.

51.

52.

Select object:
Tekan Enter.

.Specify height of extrusion or [ Path] :-1920

Tinggi jendela.

Specify angle of taper for extrusion <0>:

Tekan Enter.

Gandakan kusen tegak untuk membuat kusen tegak bagian kanan.
Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih gambar kusen tegak.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @-760,0

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.
Pada Menu Bar pilih menu Modify > Solids Editing > Union.
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Gambar 6.18: Penggabungan kusen dengan perintah Union
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53.

54.

55.
56.

57.

58.
59.

60.

61.

62.

Select object:

Pilih semua kusen pintu jendela.

Select object:

Tekan Enter.

Pada Menu Bar pilih menu Draw > Rectangle.

Specify first corner point or [Chamfer/Eevation/Fillet/
Thickness/Width}] :

Tentukan sudut rectangle pada ujung bawah belakang kusen tegak
sebelah kiri.

Specify other corner point or
[Area/Dimension/Rotation]: @900, -30.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Solids > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 2300.
Tinggi pintu.

Specify angle of taper for extrusion <0>:

Tekan Enter.

Gambar 6.19: Menggambar Daun Pintu
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Untuk menempatkan pintu dapat Anda lakukan dengan langkah-
langkah sebagai berikut:

1. Buat objek pelubang dinding sesuai dengan bentuk pintu jendela.
2. Pada Menu Bar pilih menu Modify > Move.
3. Select object:
Pilih objek pelubang dinding, lalu tekan Enter.
4. Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada objek pelubang dinding.

5. Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

6. Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter.

Gambar 6.20: Titik Peletakan Objek Pelubang Dinding

8. Select object:
Pilih objek pelubang dinding, lalu tekan Enter.
9. Tempatkan objek pintu depan. Lihat Gambar 6.21.
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10.

11.
12.

13.

14.

15.
16.

17.

18.

I

~.

S

Gambar 6.21: Menempatkan Pintu Depan
Buat objek pelubang dinding lalu pindahkan objek pelubang dinding
pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
Select object:
Pilih objek pelubang dinding, lalu tekan Enter.
Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada objek pelubang dinding.

Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

Pada Menu Bar pilih Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan.

Lalu tekan Enter.

Select object: Pilih objek pelubang dinding, lalu tekan
Enter.

Tempatkan objek pintu belakang dengan perintah move.
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Gambar 6.22: Menempatkan Pintu Belakang

19. Tambahkan objek pintu balkon lantai 2.

%J

Gambar 6.23: Objek Pintu Balkon

20. Buat objek pelubang dengan cara membuat outline dari pintu

21.
22.
23.

jendela dengan perintah polyline kemudian beri ketebalan lebih
besar dari tebal dinding.

Pindahkan objek pelubang dinding pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
Select object:

ll;ilih objek pelubang dinding yang akan dipindahkan, lalu tekan
nter.
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24.

25.

26.
27.

28.

29.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan pada objek pelubang dinding.

Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter.

Select object:

Pilih objek pelubang dinding, lalu tekan Enter.

Tempatkan objek pintu balkon dengan perintah move.

Gambar 6.24: Menempatkan Pintu Lt 2

30. Tambahkan objek pintu balkon lantai 3.

31. Buat objek pelubang dengan cara membuat outline dari pintu

jendela dengan perintah polyline kemudian beri ketebalan lebih
besar dari tebal dinding.
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32.

33.
34.

35.

36.

37.
38.

39.

40.

Pindahkan objek pelubang dinding pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada objek pelubang dinding.

Specify second point or <use first point as
displacement>:

Letakkan pada dinding bangunan.

Pada Menu Bar pilih Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter.
Select object:

Pilih objek pelubang dinding, lalu tekan Enter.

Tempatkan objek pintu balkon dengan perintah move.

Gambar 6.25: Menempatkan Pintu Lt 3
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MENGGAMBAR JENDELA

Selanjutnya Anda akan menambahkan objek jendela. Kusen meng-
gunakan kayu 6/12 cm. Untuk menggambar kusen jendela Anda dapat
mengikuti langkah-langkah berikut ini:

1.
2.

10.

11.

12.

13.

Pada Menu Bar pilih menu Draw > Rectangle

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle.

Specify other corner point or
[ Area/Dimension/Rotation] : @1580,120

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 60
Tinggi pintu.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan kusen mendatar untuk membuat kusen bagian atas,
Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih gambar kusen mendatar.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @0,0,1860

14.

15.

16.

17.

18.
19.

20.

21.

22.

23.

24.

25.

26.

27.

28.

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

Untuk membuat kusen tegak Pada Menu Bar pilih menu Draw >
Rectangle

Specify first corner point or [Chamfer/Eevation/Fillet/
Thickness/Width]:

Tentukan sudut rectangle pada ujung kiri depan kusen mendatar
bagian atas.

Specify other corner point or
[ Area/Dimension/Rotation] : @60,120

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] :-1920
Tinggi jendela.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan kusen tegak untuk membuat kusen tegak bagian kanan
dan tengah, Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih gambar kusen tegak.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @-760,0

Specify second point or [ Exit/Undo] <Exit>: @1520,0.
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29.Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

\
A\

Lz

Gambar 6.26: Menggambar Kusen Jendela

30. Pada Menu Bar pilih menu Modify > Solids Editing > Union.
31.Select object:

Pilih semua kusen jendela.
32.S8elect object:

Tekan Enter.

///;

<]

1=
=

Gambar 6.27: Penggabungan kusen jendela

33. Untuk membuat daun jendela tegak sebelah kiri, Pada Menu Bar
pilih menu Draw > Rectangle.
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34.

35.

36.
37.

38.

39.

40.

41.

42.

43.

44,

45

46.

47.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah depan dari kusen
jendela sebelah kiri.

Specify other corner point or
[ Area/Dimension/Rotation] : @150, 30.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude.
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 1800
Tinggi jendela.

Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan daun jendela tegak untuk membuat daun jendela tegak
bagian kanan, Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih daun jendela tegak.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan.

.Specify second point or <use first point as

displacement>: @550,0
Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

Pada Menu Bar pilih menu Draw > Rectangle
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48.

49.

50.
51.

52.

53.
54.

55.

56.

57.

58.

59.

60.

61.
62.

Specify first corner point or [ Chamfer/Eevation/Fillet/
Thickness/Width] :

Tentukan sudut rectangle pada ujung bawah depan dari kusen
tegak sebelah kiri.

Specify other corner point or
[ Area/Dimension/Rotation] : @40, 3.

Tentukan koordinat sudut rectangle kedua.

Pada Menu Bar pilih menu Draw > Modeling > Extrude
Select object:

Pilih rectangle.

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 150
Specify angle of taper for extrusion <0>:
Tekan Enter.

Gandakan daun jendela mendatar untuk membuat daun jendela
mendatar bagian atas, Pada Menu Bar pilih menu Modify > Copy

Select object:

Pilih daun jendela mendatar.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:

Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @0,0,1650

Specify second point or [ Exit/Undo] <Exit>:

Tekan Enter.

Pada Menu Bar pilih menu Modify > Solids Editing > Union.
Select object:

Pilih semua daun jendela.
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63.

64.
65.

66.

67.

68.

69.

70.

Select object:

Tekan Enter.

Pada Menu Bar pilih menu Modify > Copy.

Select object:

Pilih daun jendela sebelah kiri.

Select object:

Tekan Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan.

Specify second point or <use first point as
displacement>: @760,0

Specify second point or [ Exit/Undo] <Exit>:
Tekan Enter.

Buat variasi dari objek jendela seperti yang terlihat pada Gambar
6.28 dan tambahkan objek pelubang dinding.

Gambar 6.28: Objek Jendela Depan

Untuk menempatkan jendela dapat Anda lakukan dengan langkah-
langkah sebagai berikut:

1.
2.
3.

Buat objek pelubang dinding sesuai dengan bentuk jendela.
Pindahkan objek pelubang dinding pada dinding bangunan.
Pada Menu Bar pilih menu Modify > Move.
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Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

. Specify base point or [ Displacement] <Displacement>:
MID

Tentukan titik acuan menggunakan object snap midpoint.

. Specify second point or <use first point displacement>:
MID

Letakkan pada tengah-tengah objek menggunakan object snap
midpoint.

Pada Menu Bar pilih menu Modify > Move.
Select object:

Pilih objek pelubang dinding yang akan dipindahkan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada sembarang tempat.

Specify second point or <use first point as
displacement>: @0,0,300

Ketik @0,0,300 untuk memindahkan objek ke atas.

A
N
-
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-

Gambar 6.29: Titik Peletakan Objek Pelubang Dinding
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10.
11.

12.

13.

14.

15.

16.
17.

18.

Pada Menu Bar pilih menu Modify > Copy.
Select object:

Pilih objek pelubang dinding yang akan digandakan, lalu tekan
Enter.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada sembarang tempat.

Specify second point or <use first point as
displacement>: @0,0,3000

Ketik @0,0,3000 untuk memindahkan objek ke atas.

Specify second point or <use first point as
displacement>: @0,0,6000

Ketik @0,0,6000 untuk memindahkan objek ke atas.

Specify second point or <use first point as
displacement>, lalu Enter.

Pada Menu Bar pilih menu Modify > Solid Editing > Substract.
Select object:

Pilih objek dinding bangunan, lalu tekan Enter.

Select object:

Pilih semua objek pelubang dinding, lalu tekan Enter.

i

Gambar 6.30: Pelubang Dinding
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19.

20.
21.

22.

23.

24.
25.

Tempatkan objek jendela depan pada lubang yang telah tersedia
seperti yang terlihat pada Gambar 6.31.

Pada Menu Bar pilih menu Modify > Move.
Select object:
Pilih objek jendela yang akan dipindahkan, lalu tekan Enter.

Specify base point or [ Displacement] <Displacement>:
END

Tentukan titik acuan menggunakan object snap endpoint.

Specify second point or <use first point displacement>:
END '

Letakkan pada di ujung lubang dinding.
Pada Menu Bar pilih menu Modify > Copy.
Select object:

Pilih objek jendela yang akan digandakan, lalu tekan Enter.

i

~

Gambar 6.31: Menempatkan Objek Jendela Depan
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26.

27.

28.

29.

30.

Specify base point or [ Displacement] <Displacement>:
Tentukan titik acuan pada sembarang tempat.

Specify second point or <use first point as
displacement>: @0,0,3000

Ketik @0,0,3000 untuk memindahkan objek ke atas.

Specify second point or <use first point as
displacement>: @0, 0, 6000

Ketik @0,0,6000 untuk memindahkan objek ke atas.

Specify second point or <use first point as
displacement>:

Tekan Enter.

Tambahkan objek jendela pada dinding belakang dan tempatkan
seperti yang terlihat pada Gambar 6.32.

Gambar 6.32: Menambahkan Jendela Belakang
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MENGGAMBAR ATAP

Untuk menggambar atap bangunan lakukan langkah-langkah berikut:

1. Ubah UCS terhadap sumbu Y untuk membuat garis bantu atap
bangunan.

2. Pada Menu Bar pilih menu Tools > New UCS > Y.
3. Current ucs name: *NO NAME*

4. Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Apply/? /World] <World>: vy

5. Specify rotation angle about Y axis <90>: -90
Tentukan sudut perputaran terhadap sumbu Y

6. Pada Menu Bar pilih menu Tools > New UCS > Origin.

7. Current ucs name: *NO NAME*

8. Enter an option
[ New/Move/orthoGraphic/Prev/Restore/Save/
Del/Apply/? /World] <World>: o

9. Specify new origin point <0,0,0>:

Tentukan titik origin UCS seperti pada Gambar 6.33

Gambar 6.33: Mengubah Orientasi UCS

10. Buat garis atap dengan perintah polyline seperti pada Gambar 6.34.

11. Tambahkan ketebalan pada objek atap bangunan dengan perintah
extrude.

-12. Pada Menu Bar pilih menu Draw > Solids > Extrude.

13.

14.

15.

16.

Gambar 6.34: Membuat Garis Atap

Select object:

Pilih garis atap.

Gambar 6.35; Menggambar Atap Bangunan

Select object:

Tekan Enter.

Specify height of extrusion or [ Path] : 4200.
Lebar atap.

Specify angle of taper for extrusion <0>:

Tekan Enter.
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17. Buat garis atap pada sisi yang berlawanan arah yang mempunyai
ukuran yang berbeda dari atap pada sisi yang telah Anda buat
sebelumnya seperti yang terlihat pada Gambar 6.36.

18. Tambahkan dinding bangunan di bawah garis atap menggunakan
perintah polyline dan extrusi.

19. Aktifkan semua layer untuk melihat hasil akhir penggambaran
bangunan dan gunakan sudut pandang SE Isometric.

20. Untuk menyembunyikan garis yang berada dibelakang objek
gunakan perintah hide, command: hide.

\"’v\’

N

Gambar 6.37: Menggambar Atap

MENGGAMBAR CARPORT

Langkah selanjutnya adalah membuat objek carport yang dapat Anda
lakukan dengan langkah-langkah sebagai berikut:

1. Pada toolbar Layer buat layer Carport dan jadikan sebagai layer

aktif.
Pada Menu Bar pilih menu View > 3D Views > Top.
Gambar 6.36: Menggambar Atap 3. Pada Menu Bar pilih menu Draw > Rectangle.
. .. . ] ’ . . Specify first corner point or
Tambahkan objek dinding samping yang berfungsi untuk memberikan [ Chamfer/Elevation/Fillet/ Thickness/Width] :
penutup pada atap dan sebagai batas dari masing-masing ruko yang
akan kita buat. Tentukan sudut rectangle pertama.

5. Specify other corner point or

Buat dinding samping menggunakan perintah polyline dan berikan
g ping 99 P poy [ Area/Dimensions/Rotation] : @7000,-5000

ketebalan dinding 15 ¢cm, tambahkan pada sisi kanan dan Kkiri ruko.

Hasil akhir tambahan dinding samping akan terlihat seperti pada Pada Menu Bar pilih menu View > 3D Views > SW Isometric.
Gambar 6.37. 8. Pada Menu Bar pilih menu Draw > Modeling > Extrude.
9. Select object:

Anda pilih bidang dasar objek carport, lalu tekan Enter.
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10.Specify height of extrusion or [ Direction/Path/Taper
angle] <0.0000>: -100

Ketik -100 untuk menentukan ketebalan objek carport.

Gambar 6.38: Membuat Objek Carport

FINISHING DESAIN RUKO

Tambahkan atap kanopi yang merupakan dak beton untuk menutupi
teras ruko seperti yang terlihat pada Gambar 6.39.

v

Gambar 6.39: Menambahkan Atap Kanopi Teras
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Tambahkan penebalan dinding pada jendela ruko untuk menambahkan
kesan minimalis seperti yang terlihat pada Gambar 6.40.

—~

/

Gambar 6.40: Menambahkan Penebalan Dinding

Tambahkan objek balkon dan atap balkon pada teras lantai 2 dan lantai
3 seperti yang terlihat pada Gambar 6.41.

7
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Gambar 6.41: Menambahkan Balkon Lantai 2 dan Lantai 3




Tambahkan variasi dinding pada ornamen jendela seperti yang terlihat
pada Gambar 6.42.

MR A
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Gambar 6.42: Menambahkan Variasi Dinding

Gandakan unit Ruko menjadi beberapa unit dan untuk hasil akhir
gunakan perspektif, Pada Menu Bar pilih menu View > Orbit > Free
Orbit, lalu klik kanan, pada menu shortcut pilih Projection >
Perspective.

W

Gambar 6.43: Hasil Akhir Ruko Minimalis
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PENUTUP

AutoCAD 2010 untuk desain bangunan minimalis. Di awal

pembahasan telah dijelaskan tentang pembuatan rumah ber-
tingkat, membuat carport dan taman, pembuatan desain rumah tinggal
minimalis, konstruksi bangunan kantor minimalis, hingga pembuatan
desain ruko minimalis.

Sampai di sini Anda telah belajar banyak hal mengenai aplikasi
)

Penulis berharap Anda dapat memahami materi yang disampaikan
dengan mudah dan cepat. Jika Anda menemui kesulitan dalam
mempelajari materi dalam buku ini, Anda dapat menyampaikan
pertanyaan ke penulis dengan alamat seperti pada bagian Prakata.
Untuk menambah wawasan dan informasi terbaru tentang aplikasi
AutoCAD 2010, Anda dapat mengunjungi URL
www.usa.autodesk.com.




