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PENGANTAR DARI
ONNO W. PURBO

Di akhir dari sebuah studi kita biasanya perlu menulis sebuah
skripsi,  thesis  bahkan  disertasi.  Kita  biasanya  akan  di
pusingkan  oleh  berbagai  masalah  tentang  penelitian  yang  kita
lakukan.  Langkah/tahapan  penyampaian  data  dan  argumentasi
agar  apa  yang  kita  teliti  menjadi  tampil  dengan  baik  menjadi
salah  satu  pokok  pikiran  yang  banyak  menyita  energi.
Di  sisi  lain,  teknik  menulis  skripsi  yang  baik  mulai  dari  Kata
Pengantar,  Daftar  Isi,  Daftar  Tabel  bahkan  penomoran  bab,
subbab,  gambar,  tabel  cukup membuat  pusing jika harus  dilakukan
secara  manual.  Akan  lebih  mudah  jika  semua  dapat  dilakukan
secara automatis.

Kita  cukup  beruntung  dengan  adanya  buku  “Cerdas 
Menyusun Tugas  Akhir  dengan Writer” oleh Rustan dan Kamariah 
menjelaskan  dengan  sangat  baik  dan  detail  berbagai  langkah  yang 
dapat kita gunakan dalam menggunakan LibreOffice 3.3 yang open 
source untuk menulis skripsi. Berbagai kemudahan dalam membantu
penulisan skripsi di jelaskan di buku tersebut.

Mudah-mudahan  buku  ini  dapat  membantu  memperlancar 
para mahasiswa yang sedang menulis tugas akhir dan lulus sebagai
sarjana.

Jakarta, Mei 2011

Onno W. Purbo
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KATA PENGANTAR

Tugas  akhir  seperti  skripsi,  tesis,  dan  disertasi  merupakan 
salah  satu  kewajiban  mahasiswa  sebelum  menyelesaikan  masa 
studinya.  Menyusun  tugas  akhir  bukanlah  hal  yang  mudah.  Selain 
dipusingkan  dengan  apa  yang  harus  ditulis,  kita  juga  dihadapkan 
dengan persoalan tata cara penulisan tugas akhir itu sendiri.

Buku ini membahas tentang aturan penulisan tugas akhir dan 
cara  penulisannya  dengan  LibreOffice  3.3  Writer.  Pembahasan 
dilakukan secara selangkah demi selangkah sehingga mahasiswa yang 
belum terbiasa sekali pun dapat mengikuti langkah-langkah tersebut 
untuk  mengoptimalkan  LibreOffice  3.3  Writer  dalam  penulisan 
skripsi.  Dengan  mempraktikkan  buku  ini,  mahasiswa  akan 
memperoleh template yang dapat digunakan dalam penyusunan tugas 
akhir.  Selain  itu,  dengan sedikit  kreativitas  mereka  dapat  membuat 
template  sendiri  untuk  menyusun  laporan,  makalah,  dan  lain 
sebagainya.

Berikut  ini  beberapa  hal  yang  biasa  dilakukan  secara 
manual :

• Penomoran bab dan subbab

• penomoran gambar, tabel, dan persamaan

• Penomoran gambar, tabel, dan persamaan sebagai penunjuk

• Pembuatan daftar isi, daftar tabel, daftar gambar, dan daftar 
rujukan

Selain  itu,  penulisan  dokumen  biasanya  dilakukan  secara 
terpisah  atau  per  bab.  Artinya,  jika  ada  5  bab  maka  dibutuhkan  5 
dokumen selain  dokumen  bagian  awal  (  kata  pengantar,  daftar  isi, 
daftar  tabel,  dan  lain  sebagainya).  Hal  ini  tentunya  tidak  efisien 
apabila terjadi perubahan dalam dokumen misalnya nomor halaman, 
maka  kita  harus  membuka  satu  per  satu  dokumen  tersebut  untuk 
mengubah nomor halamannya.
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Buku  ini  disusun  berdasarkan  pengalaman  penulis  dalam 
menyelesaikan  tugas  akhir.  Melalui  buku  ini,  mahasiswa  dapat 
mengoptimalkan  fitur-fitur  yang  ada  dalam  LibreOffice  3.3  Writer 
sehingga  hal-hal  seperti  di  atas.  Mahasiswa  tidak  lagi  melakukan 
penyusunan daftar  isi,  daftar  tabel,  daftar  rujukan,  penomoran,  dan 
lain  sebagainya  secara  manual  karena  semua  itu  dapat  dilakukan 
secara otomatis.

Pada kesempatan ini, penulis ingin mengucapkan rasa terima 
kasih yang sebesar-besarnya kepada bapak Onno W. Purbo yang telah 
memberikan  bantuan  yang  luar  biasa  dalam  penulisan  buku  ini. 
Terima kasih juga kepada Jushadi, K' Arman, teman-teman komunitas 
Ubuntu Makassar  yang telah mengenalkan Linux dan Open Source 
kepada penulis dan Relawan TIK khususnya regional timur.  Terima 
kasih  juga  kepada  Ayahanda  Ahmad  Yani,  Jasruddin,  Eko  Hadi 
Sujiono,  Nasrul  Ihsan,  Subaer,  Agus  Susanto.  Aslim,  dan  ibunda 
Nurhayati  serta  bapak/ibu  Dosen  jurusan  Fisika  FMIPA UNM dan 
teman-teman  asisten  Laboratorium  Komputer  Fisika  dan  adinda 
Rabiatul Adawiyah.

Akhir  kata  semoga  buku  ini  dapat  menambah  wawasan 
pembaca.  Kritik  dan  saran  yang  bersifat  membangun  sangat  kami 
hargai demi pengembangan buku ini. Semoga ke depan kami dapat 
terus  berkarya  untuk serta  dalam mencerdaskan  bangsa  dan  negara 
yang kita cintai ini.

Makassar,  Mei 2011

Penulis
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BAB 1
SISTEMATIKA DAN ATURAN 

PENULISAN TUGAS AKHIR

1.1 SISTEMATIKA PENULISAN

Penulisan  skripsi,  tesis,  dan  disertasi  di  berbagai  perguruan  tinggi 
memiliki bagian-bagian yang hampir sama. Isi dan sistematika tugas 
akhir tersebut dibagi menjadi tiga bagian utama, yaitu bagian awal, 
bagian utama, dan bagian akhir. Masing-masing bagian dapat dirinci 
sebagai berikut.

1. Bagian Awal

Hal-hal yang termasuk dalam bagian awal adalah:

Halaman sampul

Halaman judul

Halaman pengesahan

Pernyataan keaslian

Kata pengantar

Persetujuan publikasi

Abstrak (biasanya dalam bahasa Indonesia dan bahasa Inggris)

Daftar isi

Daftar tabel, Daftar gambar, Daftar lampiran, Daftar lainnya

2. Bagian Utama

Bagian utama isi tugas akhir meliputi:

Sistematika Dan Aturan Penulisan Tugas Akhir
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Pilihan pertama

BAB 1 PENDAHULUAN

1.1 Latar Belakang Masalah

1.2 Masalah Penelitian

1.3 Tujuan Penelitian

1.4 Manfaat Penelitian

1.5 Penjelasan Istilah (jika ada)

BAB 2 KAJIAN PUSTAKA

BAB 3 METODE PENELITIAN

3.1 Jenis Penelitian

3.2 Lokasi dan Waktu Penelitian

3.3 Fokus Kajian

3.4 Material Pendukung

3.5 Indikator (atau parameter penelitian)

3.6 Prosedur Pelaksanaan Penelitian

BAB 4 HASIL DAN PEMBAHASAN

BAB 5 SIMPULAN DAN SARAN

5.1 Simpulan

5.2 Saran

Pilihan kedua

BAB I PENDAHULUAN

A. Latar Belakang Masalah

B. Rumusan Masalah

C. Hipotesis Penelitian (jika ada)

D. Kegunaan Penelitian

E. Asumsi Penelitian (jika ada)

Sistematika Dan Aturan Penulisan Tugas Akhir
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F. Definisi Operasional

BAB II KAJIAN PUSTAKA

BAB III METODE PENELITIAN

A. Rancangan Penelitian

B. Populasi dan Sampel

C. Instrumen Penelitian

D. Pengumpulan Data

E. Analisis Data

BAB IV HASIL ANALISIS

A. .................................

B. .................................

C. .................................

BAB V PEMBAHASAN

A. .................................

B. .................................

C. .................................

BAB VI PENUTUP

A. Kesimpulan

B. Saran

3. Bagian Akhir

Bagian akhir dari tugas akhir meliputi:

Daftar Rujukan

Lampiran-lampiran

Riwayat Hidup
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1.1.2 Bagian Awal

Untuk  memperoleh  gambaran  yang  lebih  jelas  tentang  unsur-unsur 
bagian awal, berikut ini diuraikan isi dari unsur-unsur tersebut.

• Halaman sampul/judul

Halaman ini  memuat informasi singkat tentang tugas akhir 

seperti judul, jenis tugas akhir, identitas penulis, institusi, dan 

tahun lulus ujian.

• Halaman Pengesahan

Halaman berfungsi  untuk menjamin keabsahan tugas  akhir 

dari  institusi.  Pada  beberapa  perguruan tinggi,  halaman ini 

terdiri  dari  dua  macam  lembar  persetujuan.  Lembar 

persetujuan  pertama  dari  pembimbing  sedangkan  lembar 

kedua  berisi  pengesahan  tugas  akhir  dari  dewan  penguji, 

ketua jurusan, dan dekan.

• Pernyataan Keaslian

Halaman  ini  berisi  ungkapan  penulis  bahwa  isi  dari  tugas 

akhir  yang  ditulisnya  bukan  merupakan  pengambilalihan 

tulisan  atau  pikiran  orang  lain  yang  diakui  sebagai  hasil 

pemikirannya sendiri.

• Kata Pengantar

Halaman ini berisi ucapan terima kasih dari penulis kepada 

pihak-pihak yang telah membantu dalam penyelesaian tugas 

akhir yang ditulisnya.

• Persetujuan Publikasi

Halaman  ini  berisi  pernyataan  dari  mahasiswa  penyusun 
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tugas akhir yang memberikan kewenangan kepada institusi 

untuk  menyimpan,  mengalih-  media/format-kan,  merawat, 

dan  mempublikasikan  tugas  akhirnya  untuk  kepentingan 

akademis.  Artinya,  pihak  institusi  berwenang  untuk 

mempublikasikan suatu tugas akhir hanya untuk kepentingan 

pengembangan ilmu pengetahuan, sedangkan hak cipta tetap 

pada penulis .

• Halaman Abstrak

Abstrak merupakan ringkasan suatu tugas akhir yang memuat 

permasalahan,  tujuan,  metode  penelitian,  hasil,  dan 

kesimpulan. Abstrak bertujuan untuk memudahkan pembaca 

agar  mengerti  secara  cepat  isi  tugas  akhir.  Halaman  ini 

biasanya ditulis dalam bahasa Indonesia dan bahasa Inggris 

dalam halaman yang terpisah.

• Daftar Isi

Halaman ini  memuat semua bagian tulisan disertai  dengan 

nomor halaman tempat pemuatannya di dalam teks. Daftar isi 

ini sebaiknya menggambarkan keseluruhan isi.

• Daftar Tabel

Halaman  ini  memuat  nomor  tabel,  judul  tabel  dan  nomor 

halaman tempat pemuatannya dalam teks. Judul tabel dalam 

daftar  tabel  harus  sama  dengan  judul  tabel  yang  terdapat 

dalam teks.

• Daftar Gambar

Halaman  ini  memuat  nomor  gambar,  judul  gambar  dan 

nomor  halaman  tempat  pemuatannya  dalam  teks.  Judul 
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gambar  dalam  daftar  gambar  harus  sama  dengan  judul 

gambar yang terdapat dalam teks.

• Daftar Lampiran

Halaman  ini  memuat  nomor  lampiran,  judul  lampiran  dan 

nomor halaman tempat pemuatannya dalam teks.

• Daftar Lainnya

Jika  dalam  tugas  akhir  banyak  digunakan  simbol  dan 

singkatan yang mempunyai makna yang esensial, maka perlu 

dibuat  daftar  khusus  mengenai  simbol  atau  singkatan 

tersebut.

1.1.3 Bagian Utama

Isi bagian utama (pilihan pertama)

Bagian utama terdiri dari lima bab yaitu:

• Bab 1 Pendahuluan sebagai bab pertama, bab ini bertujuan 
mengantarkan pembaca untuk mengetahui apa yang diteliti, 
untuk  apa  dan  mengapa  penelitian  itu  dilakukan.  Bab  ini 
memuat:

◦ Latar Belakang Masalah, pada bagian ini dikemukakan 
hal-hal  yang  menimbulkan  permasalahan  yaitu 
timbulnya  kesenjangan  antara  kenyataan  dan  harapan 
atau antara kenyataan dan kebutuhan serta upaya-upaya 
apa saja yang sudah dilakukan untuk mengatasinya.

◦ Masalah  Penelitian,  terdiri  dari  dua  bagian  yaitu 
“Pembatasan  dan  Lingkup  Penelitian”  dan  “Rumusan 
Masalah”.  Pembatasan  dan  lingkup  penelitian 
mengemukakan  akar  permasalahan  yang  timbul  dalam 
latar  belakang  sedangkan  rumusan  masalah 
mengemukakan  perumusan  permasalahan  yang  akan 
diteliti  dan  dibahas  sesuai  dengan  batas-batas  dan 
lingkup  penelitian.  Rumusan  masalah  dapat  berupa 
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pernyataan dan/atau pertanyaan.

◦ Tujuan Penelitian, bertujuan untuk menjawab masalah 
penelitian dan dikemukakan secara rinci sehingga jelas 
arah yang akan dituju.

◦ Manfaat  Penelitian,  mengemukakan  manfaat  hasil 
penelitian baik secara teoritis maupun praktis. Manfaat 
tersebut  dapat  ditujukan  bagi  pengembangan  ilmu 
pengetahuan, bangsa dan negara, bagi para ahli, peneliti, 
dan lain sebagainya.

◦ Penjelasan  Istilah,  mengemukakan  penjelasan  atau 
definisi  dari  istilah  yang belum umum dipahami  yang 
digunakan  dalam  tugas  akhir.  Untuk  mendefinisikan 
istilah tersebut sebaiknya digunakan literatur.

• Bab 2 Kajian Pustaka,  bagian ini  memuat tentang uraian 
konsep dan prinsip dasar yang diperlukan untuk memecahkan 
permasalahan.  Kajian  pustaka  dapat  berbentuk  uraian 
kualitatif, model matematis, atau persamaan-persamaan yang 
berkaitan dengan permasalahan yang diteliti. Bagian ini juga 
dapat memuat tentang hasil penelitian yang diperoleh peneliti 
sebelumnya dan hubungannya dengan penelitian yang akan 
dilakukan.

• Bab 3 Metode Penelitian, bab ini memuat:

◦ Jenis  Penelitian,  bagian  ini  menjelaskan  apakah 
penelitian  yang  dilakukan  termasuk  penelitian 
dasar/murni  atau  terapan/aplikasi.  Penelitian  dasar 
bertujuan  untuk  memperluas/memperdalam  teori  atau 
untuk memperoleh data empiris yang digunakan untuk 
merumuskan  teori  sedangkan  penelitian  terapan 
bertujuan untuk menyelesaikan masalah praktis dengan 
segera.

◦ Lokasi  dan  Waktu  Penelitian,  lokasi  penelitian 
merupakan tempat atau wilayah dimana penelitian akan 
dilakukan  sedangkan  waktu  penelitian  dimulai  saat 
format  pengajuan  proposal  ditandatangani  oleh 
pembimbing  dan/atau  ketua  jurusan  sampai 
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ditandatanganinya pengesahan skripsi.

◦ Fokus  Kajian,  merupakan  langkah-langkah  utama 
dalam melakukan pembahasan penelitian sesuai dengan 
permasalahan dan  tujuan penelitian. Fokus kajian  juga 
dapat memuat “Populasi dan Sampel” bila diperlukan.

◦ Material  Pendukung, material  yang  digunakan  dapat 
berupa buku teks, jurnal, software, peralatan dan bahan 
yang digunakan dalam penelitian.

◦ Indikator (atau parameter  penelitian),  pada bagian ini 
dikemukakan indikator keberhasilan sesuai dengan fokus 
kajian dalam menjawab masalah penelitian.

◦ Prosedur  Pelaksanaan  Penelitian, pada  bagian  ini 
dikemukakan  langkah-langkah  yang  dilakukan  dalam 
penelitian  untuk  mencapai  indikator  penelitian 
berdasarkan  fokus  kajian  yang  telah  dikemukakan. 
Misalnya  melakukan  percobaan  dalam  laboratorium, 
menyusun alat ukur, melakukan analisis data,pengkajian 
literatur dan lain sebagainya.

• Bab  4  Hasil  dan  Pembahasan,  pembahasan  penelitian 
diuraikan  sesuai  dengan  fokus  kajian  sedangkan  hasil 
penelitian diperoleh berdasarkan prosedur penelitian.

• Bab  5  Simpulan  dan  Saran,  simpulan  yang  diperoleh 
dikemukakan  berdasarkan  hasil  penelitian.  Simpulan 
diarahkan untuk menjawab masalah, tujuan dan pertanyaan, 
hipotesis (jika ada),  temuan-temuan (jika ada).  Saran yang 
dikemukakan  dapat  berupa  implementasi  teoritis  dan/atau 
praktis dari penelitian yang telah dilakukan.

Isi bagian utama (pilihan kedua)

• Bab  I  Pendahuluan,  bab  ini  bertujuan  mengantarkan 
pembaca untuk mengetahui apa yang diteliti, untuk apa dan 
mengapa penelitian itu dilakukan. Bab ini memuat:

◦ Latar Belakang Masalah, pada bagian ini dikemukakan 
adanya kesenjangan antara harapan dan kenyataan, baik 
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teoritis maupun praktis yang melatarbelakangi masalah 
yang diteliti. Teori, hasil penelitian, seminar, dan diskusi 
ilmiah yang berkaitan erat dengan masalah yang diteliti 
dipaparkan secara ringkas.

◦ Rumusan  Masalah,  merupakan  pernyataan  yang 
lengkap dan rinci mengenai ruang lingkup masalah yang 
diteliti.  Rumusan  masalah  sebaiknya  menampakkan 
variabel-variabel yang diteliti, jenis atau sifat hubungan 
antara variabel-variabel tersebut,  dan subjek penelitian, 
serta dapat diuji secara empiris.

◦ Hipotesis Penelitian (jika ada), hipotesis bersumber dari 
teori  dan/atau  kajian  pustaka  yang  berkaitan  dengan 
masalah yang akan diteliti.  Rumusan hipotesis  bersifat 
definitif, artinya dalam perumusan hipotesis tidak hanya 
disebutkan  adanya  hubungan  atau  perbedaan  antar 
variabel  tetapi  juga  ditunjukkan  sifat  hubungan  atau 
keadaan dari variabel-variabel tersebut.

◦ Kegunaan  Penelitian,  pada  bagian  ini  ditunjukkan 
pentingnya  penelitian  bagi  pengembangan  ilmu 
pengetahuan atau pelaksanaan pembangunan dalam arti 
yang luas.

◦ Asumsi  Penelitian (jika  ada),  berupa  anggapan-
anggapan  dasar  yang  dijadikan  pijakan  berfikir  dan 
bertindak dalam melaksanakan penelitian.

◦ Definisi  Operasional,  definisi  operasional  adalah 
definisi  yang  didasarkan  atas  sifat-sifat  hal  yang 
didefinisikan yang dapat diamati. Secara tidak langsung 
definisi  operasional  menunjuk  alat  pengambilan  data 
yang  cocok  untuk  digunakan  atau  mengacu  pada 
bagaimana  mengukur  suatu  variabel.  Definisi 
operasional diperlukan apabila diperkirakan akan timbul 
perbedaan  makna  seandainya  penegasan  istilah  tidak 
diberikan.

• Bab II Kajian Pustaka, pada bagian ini dikemukakan bahan 
pustaka  yang  dikaji  dan  dipaparkan  hasilnya  dengan 
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didasarkan pada tiga kriteria yaitu (1) prinsip kemutakhiran 
(minimal  80%  pustaka  yang  dirujuk  terbit  sepuluh  tahun 
terakhir), (2) prinsip keprimeran (minimal 80% pustaka yang 
dirujuk  berasal  dari  hasil  penelitian  yang  dimuat  dalam 
jurnal,  skripsi,  tesis,  disertasi,  dan  laporan  penelitian),  (3) 
prinsip  relevansi  (hanya pustaka  yang relevan  saja  dengan 
masalah yang diteliti yang dirujuk).

• Bab III Metode Penelitian, bab ini memuat:

◦ Rancangan  Penelitian,  diartikan  sebagai  strategi 
mengatur latar penelitian agar peneliti memperoleh data 
yang  valid  sesuai  dengan  karakteristik  variabel  dan 
tujuan  penelitian.  Untuk  penelitian  eksperimen, 
rancangan  yang  digunakan  adalah  yang  paling 
memungkinkan peneliti  untuk mengendalikan variabel-
variabel lain yang diduga berpengaruh terhadap variabel 
tergantung/terikat.  Sedangkan  pada  penelitian  non-
eksperimen berisi tentang penjelasan dari penelitian yang 
dilakukan ditinjau dari segi tujuan dan sifatnya; apakah 
penelitian  ekplorasi,  deskripsi,  eksplanasi,  survei, 
historis, korelasi, dan komparasi kausal. Selain itu, juga 
dijelaskan  variabel  yang  terkait  serta  hubungan  antara 
variabel-variabel tersebut.

◦ Populasi dan Sampel, istilah populasi dan sampel lebih 
tepat  digunakan  untuk  penelitian  yang  mengambil 
sampel  sebagai  subjek  penelitian.  Jika  sasaran 
penelitiannya  adalah  seluruh  anggota  populasi,  lebih 
cocok digunakan istilah subjek penelitian. Untuk survei 
sumber  data  umumnya  disebut  sebagai  responden  dan 
dalam penelitian kualitatif disebut sebagai informan atau 
subjek.  Hal-hal  yang  akan  dibahas  dalam  bagian 
populasi dan sampel adalah (1) identifikasi dan batasan-
batasan  tentang  populasi  atau  subjek  penelitian,  (2) 
prosedur dan teknik pengambilan sampel,  (3) besarnya 
sampel.

◦ Instrumen  Penelitian,  pada  bagian  ini  dikemukakan 
instrumen  yang  digunakan  untuk  mengukur  variabel 
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yang  diteliti.  Setelah  itu  dipaparkan  prosedur 
pengembangan  instrumen  pengumpul  data  atau 
pemilihan  alat  dan  bahan  yang  digunakan  dalam 
penelitian.

◦ Pengumpulan  Data,  pada  bagian  ini  diuraikan  (1) 
langkah-langkah  yang  ditempuh  dan  teknik  yang 
digunakan untuk mengumpulkan data, (2) kualifikasi dan 
jumlah petugas yang terlibat dalam proses pengumpulan 
data, dan (3) jadwal pelaksanaan pengumpulan data.

◦ Analisis Data,  pada bagian ini diuraikan jenis analisis 
statistik yang digunakan.

• Bab IV Hasil  Analisis,  pada  bagian  ini  diuraikan  tentang 
karakteristik  masing-masing  variabel  dan  hasil  pengujian 
hipotesis.

• Bab  V  Pembahasan,  pada  bagian  ini  diuraikan  temuan-
temuan hasil penelitian. Tujuan dari pembahasan adalah (1) 
menjawab  masalah  penelitian,  (2)  menafsirkan  temuan-
temuan penelitian, (3) mengintegrasikan temuan penelitian ke 
dalam  kumpulan  pengetahuan  yan6  telah  mapan,  (4) 
memodifikasi teori yang ada atau mengemukakan teori yang 
baru,  dan  (5)  menjelaskan  implikasi  lain  dari  penelitian 
termasuk keterbatasan temuan penelitian.

• Bab VI Penutup, bab ini memuat:

◦ Kesimpulan,  isi  kesimpulan  penelitian  lebih  bersifat 
konseptual  dan harus terkait langsung dengan rumusan 
masalah dan tujuan penelitian.

◦ Saran, saran yang diajukan sebaiknya selalu bersumber 
pada  temuan  hasil  penelitian,  pembahasan,  dan 
kesimpulan hasil penelitian.

1.1.4 Bagian Akhir

Bagian akhir dari tugas akhir memuat:

• Daftar  Rujukan,  bahan  pustaka  yang  dimasukkan  dalam 

Sistematika Dan Aturan Penulisan Tugas Akhir



12

daftar  rujukan  harus  sudah  disebutkan  dalam  teks.  Semua 
bahan  rujukan  yang  disebutkan  dalam  tugas  akhir  harus 
dimasukkan  dalam  daftar  rujukan.  Istilah  daftar  pustaka 
digunakan  untuk  menyebutkan  daftar  yang  berisi  bahan-
bahan pustaka yang digunakan oleh penulis baik yang dirujuk 
maupun yang tidak. Dengan demikian lebih tepat digunakan 
istilah  daftar  rujukan  karena  hanya  bahan  pustaka  yang 
dirujuk saja dalam tugas akhir yang dimasukkan.

• Lampiran (jika  ada),  lampiran  hendaknya  hanya  berisi 
dokumen  penting  yang  secara  langsung  perlu  disertakan 
dalam tugas akhir misalnya ringkasan analisis data dan surat 
izin penelitian.

• Riwayat Hidup, riwayat hidup penulis hendaknya disajikan 
secara  narasi.  Hal-hal  yang  perlu  dimuat  adalah  nama 
lengkap  penulis  dan  tanggal  lahir,  riwayat  pendidikan, 
pengalaman organisasi, dan informasi tentang prestasi yang 
pernah  diraih  baik  di  perguruan  tinggi  maupun di  sekolah 
dasar  dan menengah.  Untuk yang sudah berkeluarga  dapat 
mencantumkan  nama  suami/istri  dan  menyebutkan  putra-
putrinya.

1.2 ATURAN PENULISAN

Tiap perguruan tinggi memiliki aturan penulisan tugas akhir sendiri. 
Berikut ini akan diberikan beberapa aturan penulisan tugas akhir.

1.2.1 KERTAS

Spesifikasi kertas yang biasa digunakan dalam penulisan tugas akhir 
yaitu:

• Jenis : HVS

• Warna : Putih

• Berat : 80 gsm

• Ukuran : A4 (21,5x29,7 cm2)
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1.2.2 PENGETIKAN

Aturan pengetikan pada  kertas  dilakukan dengan ketentuan sebagai 
berikut:

• Ukuran batas tepi kertas yang biasa digunakan:

◦ Batas tepi atas : 4 cm

◦ Batas tepi bawah : 3 cm

◦ Batas tepi kiri : 4 cm

◦ Batas tepi kanan : 3 cm

• Jenis  huruf  yang  digunakan  adalah  Times  New  Roman 
dengan ukuran 12 pt untuk isi naskah dan 14 pt untuk judul.

• Spasi yang biasa digunakan:

◦ Spasi 1, untuk jarak antara gambar/tabel/grafik dengan 
judul gambar/tabel/grafik.

◦ Spasi  1,5,  untuk  halaman  judul,  pengesahan,  abstrak, 
daftar isi, daftar gambar, daftar tabel dan daftar lainnya, 
serta isi naskah tugas akhir.

◦ Spasi 2, untuk jarak judul subbab dengan teks isi yang 
pertama.

◦ Spasi 3, untuk jarak teks dengan tabel, gambar, grafik, 
atau diagram, dan jarak akhir teks dengan judul subbab 
selanjutnya.

◦ Spasi  4,  untuk  jarak  judul  bab  dengan  teks  isi  yang 
pertama.

1.2.3 PENOMORAN HALAMAN

Berikut ini aturan penomoran halaman yang biasa digunakan dalam 
penulisan tugas akhir:

• Bagian Awal
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◦ Menggunakan angka Romawi kecil.

◦ Nomor  halaman  dituliskan  di  bagian  bawah  halaman 
dengan rata tengah (1,5 cm dari tepi bawah kertas).

◦ Halaman sampul tidak dituliskan nomor halaman.

• Bagian Utama

◦ Menggunakan angka Arab.

◦ Nomor  halaman  dituliskan  di  bagian  atas  halaman 
dengan rata kanan (1,5 cm dari tepi atas kertas).

◦ Nomor halaman bab dituliskan di bagian bawah halaman 
dengan rata tengah (1,5 cm dari tepi bawah kertas).

• Bagian Akhir

◦ Menggunakan angka Arab.

◦ Nomor  halaman  dituliskan  di  bagian  atas  halaman 
dengan rata kanan (1,5 cm dari tepi atas kertas).

◦ Nomor  halaman  dituliskan  di  bawah  halaman  dengan 
rata  tengah  (1,5  cm  dari  tepi  bawah  kertas)  untuk 
halaman yang memiliki judul.
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Berikut ini contoh ukuran bidang pengetikan:

Sistematika Dan Aturan Penulisan Tugas Akhir

Gambar 1.1: Ukuran Bidang Pengetikan
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Berikut ini contoh pengaturan jarak spasi dan pengetikan teks

Gambar 1.2: Pengaturan Jarak Antarbaris dan Pengetikan Teks

Sistematika Dan Aturan Penulisan Tugas Akhir

Keterangan: * Huruf pertama 1,2 cm dari tepi kiri
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1.3 PENULISAN RUJUKAN DAN KUTIPAN

Penulisan  rujukan  bergantung  pada  penulisan  daftar  rujukan.  Jika 
penulisan daftar rujukan dilakukan berdasarkan urutan abjad pertama, 
maka  rujukan  dilakukan  dengan  menuliskan  nama akhir  pengarang 
dan tahun terbit.  Jika ada dua penulis,  penulisan rujukan dilakukan 
dengan  cara  menyebut  nama  akhir  kedua  penulis  tersebut.  Jika 
penulisnya lebih dari dua orang, penulisan rujukan dilakukan dengan 
cara menulis nama pertama dari penulis tersebut diikuti dengan “dkk” 
atau “et all”. Jika nama penulis tidak disebutkan, yang dicantumkan 
dalam  rujukan  adalah  nama  lembaga  yang  menerbitkan,  nama 
dokumen yang diterbitkan, atau nama koran. Untuk karya terjemahan, 
perujukan dilakukan dengan cara menyebutkan nama penulis aslinya. 
Rujukan dari  dua sumber atau lebih yang ditulis  oleh penulis yang 
berbeda  dicantumkan  dalam  satu  tanda  kurung  dengan  titik  koma 
sebagai tanda pemisahnya.

Jika digunakan urutan nomor, maka perujukan dilakukan berdasarkan 
nomor urut rujukan dalam daftar rujukan (urutan rujukan didasarkan 
pada kemunculan dalam isi tugas akhir).

Penulisan  kutipan  dapat  dilakukan  secara  langsung  dan  tidak 
langsung. Akan tetapi, sebaiknya penulisan kutipan dilakukan secara 
tidak  langsung  untuk  menghindari  parade  pengutipan.  Penulisan 
kutipan langsung mestinya hanya dilakukan untuk pernyataan  yang 
fenomenal dari tokoh atau karya legendaris.

1.3.1 KUTIPAN LANGSUNG

Kutipan  langsung adalah  ide/konsep  orang lain yang disalin  sesuai 
dengan aslinya. Contoh:

She stated, “Students often had difficulty using APA style,” (Jones, 
1998, p. 199), but she did not offer an explanation as to why.

Jones (1998) found “students often had difficulty using APA style” (p. 
199); what implications does this have for teachers?

Sistematika Dan Aturan Penulisan Tugas Akhir
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1.3.2 KUTIPAN TIDAK LANGSUNG

Kutipan  tidak  langsung  adalah  ide/konsep  orang  lain  yang  dikutip 
dengan menggunakan kata-kata penulis sendiri. Contoh:

Jones (1998) compared student performance ...

In a recent study of student performance (Jones, 1998), ...

1.4 PENULISAN TANDA BACA

Penulisan  tanda  baca,  kata,  dan  huruf  harus  mengikuti  Pedoman 
Umum  Bahasa  Indonesia  yang  Disempurnakan,  Pedoman 
Pembentukan  Istilah,  dan  Kamus  (Keputusan  Mendikbud,  Nomor 
0543a/U/487, tanggal 9 September 1987). Berikut ini beberapa kaidah 
yang perlu diperhatikan.

• Titik (.), koma (,), titik dua (:), tanda seru (!), tanda tanya (?), 
dan  tanda  persen  (%)  diketik  rapat  dengan  huruf  yang 
mendahuluinya. Misalnya 10%.

• Tanda kutip (“.....”) dan tanda kurung () diketik rapat dengan 
huruf dari kata atau frasa yang diapit.

• Tanda  hubung  (-),  tanda  pisah  (—),  dan  garis  miring  (/) 
diketik  rapat  dengan  huruf  yang  mendahului  dan 
mengikutinya. Misalnya dan/atau.

• Tanda  sama  dengan  (=),  lebih  besar  (>),  lebih  kecil  (<), 
tambah (+), kurang (-), kali (x), dan bagi (:) diketik dengan 
spasi satu ketukan sebelum dan sesudahnya. Misalnya x < 1. 
Akan tetapi, tanda bagi (:) yang dipakai untuk memisahkan 
tahun  penerbitan  dengan  nomor  halaman  pada  rujukan 
diketik  rapat  dengan  angka  yang  mendahului  dan 
mengikutinya. Misalnya Barufaldi (2002:10).

• Pemenggalan  kata  pada  akhir  baris  (-)  disesuaikan  dengan 
suku katanya.

Sistematika Dan Aturan Penulisan Tugas Akhir
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1.5 PENULISAN DAFTAR RUJUKAN

Berikut ini contoh aturan penulisan daftar rujukan:

• Penulisan  nama  penulis  rujukan  diawali  nama 
keluarga/belakang.

• Rujukan  diurutkan  berdasarkan  abjad  pertama,  tetapi  ada 
juga perguruan tinggi yang mengurutkan berdasarkan urutan 
kemunculan dalam teks tugas akhir.

• Gelar akademik dan gelar lainnya tidak boleh dicantumkan.

• Urutan  daftar  rujukan  tergantung  pada  format  yang 
digunakan  oleh  perguruan  tinggi  masing-masing  misalnya 
style APA, MLA, Chicago, dan lain sebagainya.

Aturan  penulisan  di  atas  hanyalah  sebagai  contoh  sehingga  urutan 
penulisan  tugas  akhir  lebih  tepatnya  disesuaikan  dengan  aturan 
perguruan tinggi masing-masing.

Sistematika Dan Aturan Penulisan Tugas Akhir
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BAB 2
BEKERJA DENGAN WRITER

2.1 MEMULAI WRITER

Writer merupakan komponen pengolah kata dari  Libreoffice.  Cara 
yang  paling  umum  untuk  memulai  Writer adalah  dengan 
menggunakan  sistem  menu.  Pada  Windows,  disebut  menu  Start. 
Pada GNOME, disebut menu Applications. Pada KDE, diidentifikasi 
dengan logo KDE. Pada Mac OS X, menu Applications.

Bekerja Dengan Writer

Gambar 2.1: Tampilan Pemanggilan Program Aplikasi LibreOffice 3.3 Writer  
pada GNOME
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Bekerja Dengan Writer

Gambar 2.2: Tampilan Pemanggilan Program Aplikasi LibreOffice 3.3 Writer  
pada KDE

Gambar 2.3: Tampilan Pemanggilan Program Aplikasi LibreOffice 3.3 Writer  
pada Windows
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2.2 MEMBUKA DOKUMEN BARU

Untuk membuka dokumen pada Writer, silakan pilih salah satu dari 
cara berikut ini :

• Klik File → New → Text Document

• Cara  lain  untuk  membuka  dokumen  baru  adalah  dengan 
menekan tombol Ctrl + N

2.3 MENYIMPAN DOKUMEN

Untuk menyimpan sebuah dokumen baru pada  Writer, silakan pilih 
salah satu dari cara berikut ini :

• Tekan Ctrl + S

• Pilih File → Save

• Klik tombol Save pada toolbar

Ketika  kotak  dialog  Save  As ditampilkan,  isikan  nama  file  dan 
tentukan  tipe  file,  kemudian  klik  Save.  Berikut  ini  tipe  file  yang 
didukung oleh Writer :

ODF Text Document (.odt)

ODF Text Document Template (.ott)

OpenOffice.org 1.0 Text Document (.sxw)

OpenOffice.org 1.0 Text Document Template (.stw)

Microsoft Word 97/2000/XP (.doc)

Microsoft Word 95 (.doc)

Microsoft Word 6.0 (.doc)

Rich Text Format (.rtf)

StarWriter 5.0 (.sdw)

StarWriter 5.0 Template (.vor)

Bekerja Dengan Writer
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StarWriter 4.0 (.sdw)

StarWriter 4.0 Template (.vor)

StarWriter 3.0 (.sdw)

StarWriter 3.0 Template (.vor)

Text (.txt)

Text Encoded (.txt) 

HTML Document (OpenOffice.org Writer) (.html)

AportisDoc (Palm) (.pdb)

DocBook (.xml)

Microsoft Word 2003 XML (.xml)

Microsoft Word 2007 XML (.docx)

Office Open XML Text (.docx)

OpenDocument Text (Flat XML) (.fodt)

Pocket Word (.psw)

Unified Office Format text (.uot)

2.4 MEMBUKA DOKUMEN LAMA

• Klik menu File → Open hingga tampak kotak dialog seperti 
pada Gambar 2.4.

• Cara lain untuk membuka dokumen yaitu dengan menekan 
Ctrl + O.

2.5 MENCETAK DOKUMEN

Mencetak  dokumen  dapat  dilakukan  apabila  sistem  operasi  sudah 
terinstalasi  printer.  Berikut  ini  langkah-langkah  mencetak  dokumen 
pada sistem operasi ubuntu 10.10 :

• Klik menu File → Print atau tekan Ctrl + P hingga tampak 

Bekerja Dengan Writer
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kotak dialog seperti pada Gambar 2.5.

• Pilih nama printer yang digunakan.

• Pada  bagian  Range  and  copies pilih  halaman  yang  akan 
dicetak dan tentukan kelipatan percetakan pada  Number of 
copies.

1. All  pages,  untuk  mencetak  semua  halaman 
dokumen.

2. Pages,  untuk  mencetak  halaman  tertentu  atau 
beberapa halaman misalnya 3, 1-7.

Bekerja Dengan Writer

Gambar 2.4: Kotak Dialog Open
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• Pengaturan  lebih  lanjut  dapat  dilakukan  pada  bagian 
properties dengan menekan tombol properties.

• Klik OK atau tekan ENTER untuk mencetak dokumen anda.

2.6 MENUTUP DOKUMEN

Untuk  menutup  dokumen  yang  sedang  aktif  pada  Writer dapat 
dilakukan dengan mengklik menu File → Close .

2.7 MENGAKHIRI WRITER

Untuk mengakhiri  program aplikasi  Writer dapat dilakukan dengan 
mengklik menu File → Exit atau dengan menekan Ctrl + Q.

Bekerja Dengan Writer

Gambar 2.5: Kotak Dialog Print



BAB 3
PENGAYAAN DAN 

PENOMORAN

3.1 PENGAYAAN (STYLE)

Pada umumnya orang menyusun dokumen berdasarkan atribut fisik. 
Sebagai contoh,  jenis huruf,  ukuran huruf,  dan ketebalan (misalnya 
Times New Roman 12 pt, italic).

Style merupakan  atribut  logikal.  Misalkan  ada  empat  style  dari 
personal  komputer  :  dekstop,  laptop,  notebook,  dan  netbook.  Kita 
tidak pernah mengatakan “ komputer saya adalah tidak berat, terdiri 
dari  layar  LCD,  keyboard,  dan  touchpad”.  Kita  hanya  mengatakan 
bahwa saya punya laptop.

Dengan  menggunakan  style berarti  kita  tidak  lagi  mengatakan  “ 
ukuran font 14 pt, Times New Roman, Bold, Centered”. Kita hanya 
mengatakan  “title”  untuk  mendeskripsikan  bagian  font  yang 
digunakan.

Writer terdiri dari 5 style :

• Paragraph style berpengaruh terhadap seluruh paragraf

• Character style mempengaruhi teks dalam paragraf

• Page style mempengaruhi format halaman (ukuran halaman, 
margin dan sejenisnya)

• Frame style mempengaruhi frame dan grafis

• List style mempengaruhi outline, daftar nomor dan bullet

3.1.1 SATUAN UKURAN

Secara default  satuan ukuran yang digunakan dalam  Writer adalah 

Pengayaan Dan Penomoran
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inchi1.  Sedangkan  setiap  perguruan  tinggi  yang  ada  di  Indonesia 
menggunakan  satuan  centimeter.  Dengan  demikian,  kita  perlu 
mengubah satuan  inchi tersebut menjadi  cm sehingga memudahkan 
dalam pengaturan.

Berikut ini langkah-langkah untuk mengubah satuan inchi menjadi cm 
:

• Klik  pada  menu  Tools  →  Options hingga  tampak  kotak 
dialog seperti pada gambar berikut ini.

• Klik list LibreOffice Writer kemudian pilih General.

• Pada  menu  Settings terdapat  pilihan  Measurement  unit, 
yang berfungsi untuk menentukan satuan ukuran yang akan 
digunakan. Gantilah satuan inchi dengan centimeter.

• Klik OK untuk menutup kotak dialog tersebut.

1 1 inch = 72 pt = 2,54 cm

Pengayaan Dan Penomoran

Gambar 3.1: Kotak Dialog Options
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3.1.2 PENGATURAN STYLE

3.1.2.1 Paragraph Style

1. Heading 1

Style Heading 1 digunakan untuk penulisan  nomor dan judul  bab. 
Berikut ini adalah langkah-langkah pengaturan style Heading 1 :

• Tampilkan  style  melalui  menu  Format→Styles  and 
Formatting atau tekan tombol F11.

• Klik ikon Paragraph Styles 

• Pilihlah  Heading 1,  kemudian klik kanan dan klik  modify 
hingga tampak kotak dialog seperti pada gambar berikut ini :

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Pengayaan Dan Penomoran

Gambar 3.2: Pengaturan Style Heading 1
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Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point2

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Heading 2

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

2. Heading 2

Style Heading 2 digunakan untuk penulisan nomor dan judul subbab 
derajat  ke  satu.  Misalnya  1.1.  Latar  Belakang,  1.2.  Tujuan  dan 
seterusnya. Berikut ini langkah-langkah pengaturan style Heading 2 :

• Pilihlah  Heading 2 yang ada  pada  grup  paragraph style, 
lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut :

2 Jika ukuran huruf dalam pengaturan style ditampilkan dalam 
satuan %, ketikkan saja 14pt pada bagian Size untuk mengubah ke 
dalam satuan point (pt).

Pengayaan Dan Penomoran
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)

Ukuran Huruf : 13 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Pengayaan Dan Penomoran

Gambar 3.3: Pengaturan Style Heading 2
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Above paragraph : 2.032 cm3

Below paragraph : 1.016 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Text Body

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

3. Heading 3

Style Heading 3 digunakan untuk penulisan nomor dan judul subbab 
derajat kedua, misalnya 2.1.1. Judul sub-sub bab. Berikut ini langkah-
langkah pengaturan Style Heading 3:

• Pilihlah  Heading 3 yang ada  pada  grup  paragraph style, 
lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut ini :

3 Untuk Times New Roman 12pt, 1 spasi = 120% x 12pt = 14,4 pt = 
0,2 inch = 0,58 cm.

Pengayaan Dan Penomoran
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Pengayaan Dan Penomoran

Gambar 3.4: Pengaturan Style Heading 3
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Above paragraph : 1.74 cm

Below paragraph : 1.016 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Text Body

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

4. Heading 4

Style Heading 4 digunakan untuk penulisan nomor dan judul subbab 
derajat ketiga, misalnya  2.1.1.2. Judul sub-sub-sub bab. Berikut ini 
langkah-langkah pengaturan style Heading 4 :

• Pilihlah  Heading 4 yang ada  pada  grup  paragraph style, 
lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut ini :

Pengayaan Dan Penomoran

Gambar 3.5: Pengaturan Style Heading 4
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 1.74 cm

Below paragraph : 1.016 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Text Body

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

5. Judul

Style  Judul digunakan  untuk  penulisan  judul  seperti  halaman 
pengesahan, pernyataan keaslian, persetujuan publikasi, abstrak, dan 
kata pengantar. Berikut ini adalah langkah-langkah pengaturan  style 
Judul :

• Klik kanan pada grup paragraph style, kemudian pilih New 
sehingga tampak kotak dialog seperti pada gambar berikut.

Pengayaan Dan Penomoran
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• Pada bagian Name dari menu Organizer, ketikkan “Judul”. 
Selanjutnya lakukan pengaturan pada menu-menu yang lain.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

Pengayaan Dan Penomoran

Gambar 3.6: Pengaturan Style Judul
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After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 2.032 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Text Body

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

6. Text Body

Style Text Body digunakan untuk penulisan isi laporan tugas akhir. 
Berikut ini langkah-langkah pengaturan style Text Body :

• Pilihlah  Text  Body yang ada  pada  grup  paragraph style, 
lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut ini :

Pengayaan Dan Penomoran

Gambar 3.7: Pengaturan Style Text Body
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : 1,5 lines

• Pengaturan pada Organizer

Next Style : Text Body Indent

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

7. Text Body Indent

Style Text Body Indent digunakan untuk penulisan isi laporan tugas 
akhir dengan huruf pertama 1,2 cm dari batas tepi kiri ketikan. Berikut 
ini langkah-langkah pengaturan style Text Body Indent :

• Pilihlah  Text  Body yang ada  pada  grup  paragraph style, 
lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut ini :

Pengayaan Dan Penomoran
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 1.20 cm

Above paragraph : 0.00 cm

Pengayaan Dan Penomoran

Gambar 3.8: Pengaturan Style Text Body Indent
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Below paragraph : 0.00 cm

Line spacing : 1,5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

3.1.2.2 Page Style

Pada bagian ini, kita akan membuat empat buah style halaman yang 
akan digunakan untuk mengatur halaman kertas. Style yang akan kita 
buat yaitu  halaman sampul,  halaman bagian awal,  halaman bab, 
dan  halaman  isi.  Pengaturan  halaman  kertas  ini  dilakukan  untuk 
menghasilkan jenis, ukuran, dan batas tepi kertas. Berikut ini langkah-
langkah untuk membuat keempat style tersebut.

• Pada  grup  page  style,  lakukan  klik  kanan  lalu  klik  New 
sehingga tampak kotak dialog seperti pada gambar berikut.

• Ketikkan “Halaman Sampul” pada bagian Name.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

Pengayaan Dan Penomoran

Gambar 3.9: Pembuatan Style Baru Pada Page Style
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• Dengan  cara  yang  sama,  buat  style  halaman  bagian  awal, 
halaman bab, dan halaman isi.

1. Halaman Sampul

Style Halaman Sampul digunakan untuk mengatur format halaman 
sampul dari  tugas akhir yang akan kita susun. Berikut ini  langkah-
langkah pengaturan style Halaman Sampul.

• Pilih style Halaman Sampul, lakukan klik kanan kemudian 
klik  modify sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini.

• Pengaturan pada menu Organizer

Next Style : Halaman Bagian Awal

Pengaturan  ini  dilakukan  karena  hanya  ada  satu  halaman 
sampul  kemudian  halaman  selanjutnya  adalah  halaman 
bagian awal.

• Pengaturan pada menu Page

Pengayaan Dan Penomoran

Gambar 3.10: Pengaturan Style Halaman Sampul
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Format : A4

Orientation : Portrait

Pada bagian margins

Left : 4.00 cm

Right : 3.00 cm

Top : 4.00 cm

Bottom : 3.00 cm

Pada bagian Layout settings

Format : None

Format None digunakan karena kita tidak ingin memberikan 
nomor pada halaman sampul.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

2. Halaman Bagian Awal

Style  Halaman  Bagian  Awal digunakan  untuk  mengatur  format 
halaman  bagian  awal  yakni  halaman  judul,  halaman  pengesahan, 
pernyataan keaslian, kata pengantar, halaman abstrak, daftar isi, daftar 
tabel, daftar gambar, dan lain sebagainya dari tugas akhir yang akan 
kita susun. Berikut ini langkah-langkah  pengaturan style Halaman 
Bagian Awal.

• Pilih  style  Halaman  Bagian  Awal,  lakukan  klik  kanan 
kemudian klik modify sehingga tampak kotak dialog seperti 
pada gambar berikut ini.

Pengayaan Dan Penomoran
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• Pengaturan pada menu Organizer

Next Style : Halaman Bagian Awal

Pengaturan  ini  dilakukan  karena  ada  beberapa  halaman 
dengan format style Halaman Bagian Awal.

• Pengaturan pada menu Page

Format : A4

Orientation : Portrait

Pada bagian margins

Left : 4.00 cm

Right : 3.00 cm

Top : 1.50 cm

Bottom : 1.50 cm

Pada bagian Layout settings

Pengayaan Dan Penomoran

Gambar 3.11: Pengaturan Style Halaman Bagian Awal
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Format : i, ii, iii, ...

Margins  di  atas  berarti  jarak  teks  dari  batas  tepi  kertas. 
Karena  penulisan  nomor  halaman  atau  Header & Footer 
biasanya 1,5 cm dari batas atas kertas atau 1,5 cm dari batas 
bawah  maka  Top dan  Bottom diisikan  1,5  cm.  Untuk 
Format, halaman bagian awal menggunakan angka romawi.

• Beri  tanda  centang  pada  Header  on dari  menu  Header, 
kemudian isikan 2.00 cm pada bagian Spacing (jarak antara 
isi dengan nomor halaman atau Header & Footer) dan  0.50 
cm pada bagian Height.

• Beri juga tanda centang pada  Footer on dari menu Footer, 
kemudian isikan 1.00 cm pada bagian Spacing dan 0.50 cm 
pada bagian Height.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

3. Halaman Bab

Style Halaman Bab digunakan untuk mengatur format halaman bab 
dari  tugas akhir  yang akan  kita  susun.  Berikut  ini  langkah-langkah 
pengaturan style Halaman bab.

• Pilih style Halaman Bab, lakukan klik kanan kemudian klik 
modify sehingga tampak kotak dialog seperti  pada gambar 
berikut ini.

Pengayaan Dan Penomoran



45

• Pengaturan pada menu Organizer

Next Style : Halaman Isi

Pengaturan ini dilakukan karena hanya ada satu halaman Bab 
kemudian halaman selanjutnya adalah halaman isi.

• Pengaturan pada menu Page

Format : A4

Orientation : Portrait

Pada bagian margins

Left : 4.00 cm

Right : 3.00 cm

Top : 1.50 cm

Bottom : 1.50 cm

Pada bagian Layout settings

Pengayaan Dan Penomoran

Gambar 3.12: Pengaturan Style Halaman BAB
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Format : 1,2,3, ...

Halaman  bab  menggunakan  angka  arab  untuk  penomoran 
halaman. Selain itu, penomoran halaman dituliskan di bagian 
bawah halaman dengan rata tengah (biasanya 1,50 cm dari 
tepi bawah kertas).

• Beri  tanda  centang  pada  Header  on dari  menu  Header, 
kemudian isikan 2.00 cm pada bagian Spacing dan 0.50 cm 
pada bagian Height.

• Beri juga tanda centang pada  Footer on dari menu  Footer, 
kemudian isikan 1.00 cm pada bagian Spacing dan 0.50 cm 
pada bagian Height.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

4. Halaman Isi

Style Halaman Isi digunakan untuk mengatur format halaman isi dari 
tugas  akhir  yang  akan  kita  susun.  Berikut  ini  langkah-langkah 
pengaturan style Halaman isi.

• Pilih  style Halaman isi, lakukan klik kanan kemudian klik 
modify sehingga tampak kotak dialog seperti  pada gambar 
berikut ini.

Pengayaan Dan Penomoran
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• Pengaturan pada menu Organizer

Next Style : Halaman Isi

Pengaturan ini dilakukan karena ada beberapa halaman isi .

• Pengaturan pada menu Page

Format : A4

Orientation : Portrait

Pada bagian margins

Left : 4.00 cm

Right : 3.00 cm

Top : 1.50 cm

Bottom : 1.50 cm

Pada bagian Layout settings

Format : 1,2,3, ...

Pengayaan Dan Penomoran

Gambar 3.13: Pengaturan Style Halaman Isi
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Halaman  isi  menggunakan  angka  arab  untuk  penomoran 
halaman. Selain itu, penomoran halaman dituliskan di bagian 
atas halaman dengan rata kanan (biasanya 1,50 cm dari tepi 
atas kertas).

• Beri  tanda  centang  pada  Header  on dari  menu  Header, 
kemudian isikan 2.00 cm pada bagian Spacing dan 0.50 cm 
pada bagian Height.

• Beri juga tanda centang pada  Footer on dari menu  Footer, 
kemudian isikan 1.00 cm pada bagian Spacing dan 0.50 cm 
pada bagian Height.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

3.1.2.3 Character Style

1. Page Number

Style  Page Number digunakan untuk  mengatur  format  penomoran 
halaman dari  daftar  isi  yang  akan  kita  susun.  Berikut  ini  langkah-
langkah pengaturan style Page Number.

• Pilih style Page Number, lakukan klik kanan kemudian klik 
modify sehingga tampak kotak dialog berikut ini.

Pengayaan Dan Penomoran
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• Lakukan pengaturan pada menu Font Effects.

Font color : Black

Effects : Lowercase

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

2. User Entry

Style User Entry digunakan untuk mengatur format penulisan judul 
buku  (title)  dari  daftar  rujukan.  Berikut  ini  langkah-langkah  untuk 
melakukan pengaturan style User Entry.

• Pilih  style User Entry,  lakukan klik  kanan kemudian klik 
modify sehingga tampak kotak dialog berikut ini.

Pengayaan Dan Penomoran

Gambar 3.14: Pengaturan Chaeacter Style Page Number
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• Lakukan pengaturan pada menu Font.

Font : Times New Roman

Typeface : Cetak miring (Italic atau Cursiva)

Size : 12 pt

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

3.1.2.4 List Styles

1. List 1

Style  List  Style digunakan untuk  penomoran  dan  penulisan  daftar. 
Penomoran daftar biasanya menggunakan huruf kecil, angka romawi 
kecil, angka latin, kadang disertai dengan tanda kurung misalnya 1), 
a),  i),  (2),  (ii),  (c).  Selain  itu,  kadang  juga  menggunakan  bullet. 
Berikut ini langkah-langkah pengaturan List 1 :

• Tampilkan  Styles and Formatting dengan menekan tombol 
F11.

Pengayaan Dan Penomoran

Gambar 3.15: Pengaturan Character Style User Entry



51

• Klik ikon List Styles kemudian pilih List 1.

• Klik kanan pada style List 1 kemudian klik modify sehingga 
tampak kotak dialog seperti pada gambar berikut ini :

• Anda  bisa  saja  memilih  salah  satu  format  yang  ada  pada 
bagian  Bullets,  Numbering  Style,  Graphics,  ataupun  pada 
bagian Outline. Akan tetapi, kali ini kita akan membuat list 
(daftar) sesuai dengan keinginan user (pengguna).

• Lakukan pengaturan pada menu Options

Pengayaan Dan Penomoran

Gambar 3.16: Pengaturan Numbering Style List 1
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◦ Pilih  Level  1 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering : 1,2,3, ...

After : )

Character Style : Numbering Symbols

Start at : 1

◦ Pilih  Level  2 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering : a,b,c, ...

Before : (

After : )

Character Style : Numbering Symbols

Show sublevels : 1

Start at : 1

Pengayaan Dan Penomoran

Gambar 3.17: Pengaturan Menu Options dari Style List 1
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◦ Pilih  Level  3 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering : Bullets

Character Style : Bullets

◦ Pilih  Level  4 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering : i,ii,iii, ...

Character Style : Numbering Symbols

Show sublevels : 1

Start at : 1

• Lakukan pengaturan pada menu Position

◦ Pilih  Level  1 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering followed by : tab stop

Pengayaan Dan Penomoran

Gambar 3.18: Pengaturan Menu Positions dari Style List 1
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at : 0.00 cm

Numbering alignment : Left

Aligned at : 0.50 cm

Indent at : 1.00 cm

◦ Pilih  Level  2 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering followed by : tab stop

at : 0.00 cm

Numbering alignment : Left

Aligned at : 1.00 cm

Indent at : 1.60 cm

◦ Pilih  Level  3 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering followed by : tab stop

at : 0.00 cm

Numbering alignment : Left

Aligned at : 1.60 cm

Indent at : 2.00 cm

◦ Pilih  Level  4 kemudian  lakukan  pengaturan  sebagai 
berikut :

Numbering followed by : tab stop

at : 0.00 cm

Numbering alignment : Left

Aligned at : 2.00 cm

Indent at : 2.40 cm

• Klik  OK untuk  menyimpan  hasil  pengaturan  yang  telah 
dilakukan.

Pengayaan Dan Penomoran
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3.2 PENOMORAN

Nomor Bab maupun subbab diatur sebagai berikut ini :

• Kata BAB merupakan nomor bab dan diikuti dengan angka 
Arab.

• Penomoran untuk subbab dilakukan dengan cara menuliskan 
nomor bab diikuti dengan nomor subbab dan menggunakan 
angka Arab misalnya 1.1, 1.1.1, dan lain sebagainya.

Berikut ini cara untuk menampilkan kotak dialog pengaturan nomor 
bab dan subbab :

• Klik menu Tools → Outline Numbering ... sehingga tampak 
kotak dialog seperti pada gambar berikut.

3.2.1 PENGATURAN NOMOR BAB DERAJAT SATU

• Pada  menu  Numbering,  pilih  level  1 kemudian  lakukan 
pengaturan sebagai berikut :

Pengayaan Dan Penomoran

Gambar 3.19: Kotak Dialog Outline Numbering
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Paragraph Style : Heading 1

Number : 1,2,3, ...

Character style : None

Separator

Before : BAB

Start at : 1

• Pada  menu  Position,  pilih  level  1 kemudian  lakukan 
pengaturan sebagai berikut.

Numbering followed by : Nothing

Numbering alignment : Left

Aligned at : 0.00 cm

Indent at : 0.00 cm

• Klik  OK untuk  menyimpan  perubahan  yang  telah  anda 
lakukan.

3.2.2 PENGATURAN NOMOR BAB DERAJAT KEDUA

• Pada  menu  Numbering,  pilih  level  2 kemudian  lakukan 
pengaturan sebagai berikut :

Paragraph Style : Heading 2

Number : 1,2,3, ...

Character style : None

Show sublevels : 2

Separator

Start at : 1

• Pada  menu  Position,  pilih  level  1 kemudian  lakukan 
pengaturan sebagai berikut.

Numbering followed by : Tab stop

Pengayaan Dan Penomoran
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at : 1.02 cm

Numbering alignment : Left

Aligned at : 0.00 cm

Indent at : 1.02 cm

• Klik  OK untuk  menyimpan  perubahan  yang  telah  anda 
lakukan.

3.2.3 PENGATURAN NOMOR BAB DERAJAT KETIGA

• Pada  menu  Numbering,  pilih  level  3 kemudian  lakukan 
pengaturan sebagai berikut :

Paragraph Style : Heading 3

Number : 1,2,3, ...

Character style : None

Show sublevels : 3

Separator

Start at : 1

• Pada  menu  Position,  pilih  level  1 kemudian  lakukan 
pengaturan sebagai berikut.

Numbering followed by : Tab stop

at : 1.27 cm

Numbering alignment : Left

Aligned at : 0.00 cm

Indent at : 1.27 cm

• Klik  OK untuk  menyimpan  perubahan  yang  telah  anda 
lakukan.

Pengayaan Dan Penomoran
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3.2.4 PENGATURAN NOMOR BAB DERAJAT KEEMPAT

• Pada  menu  Numbering,  pilih  level  4 kemudian  lakukan 
pengaturan sebagai berikut :

Paragraph Style : Heading 4

Number : 1,2,3, ...

Character style : None

Show sublevels : 4

Separator

Start at : 1

• Pada  menu  Position,  pilih  level  1 kemudian  lakukan 
pengaturan sebagai berikut.

Numbering followed by : Tab stop

at : 1.52 cm

Numbering alignment : Left

Aligned at : 0.00 cm

Indent at : 1.52 cm

• Klik  OK untuk  menyimpan  perubahan  yang  telah  anda 
lakukan.

3.3 MENYIMPAN STYLE DENGAN 
TEMPLATE

Template merupakan model yang akan kita gunakan untuk membuat 
dokumen  lain.  Sebagai  contoh  kita  dapat  membuat  template  untuk 
tugas akhir di mana terdapat logo universitas pada halaman pertama. 
Dokumen baru yang kita buat dari template ini juga akan terdapat logo 
universitas pada halaman pertama.

Template dapat  berupa segala sesuatu yang terdapat  pada dokumen 
asli seperti teks, grafik, kumpulan style, dan informasi khusus seperti 

Pengayaan Dan Penomoran
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satuan ukuran, bahasa, default printer, dan toolbar.

3.3.1 MENYIMPAN DOKUMEN SEBAGAI TEMPLATE

Berikut  ini  langkah-langkah  untuk  menyimpan  dokumen  sebagai 
template :

• Klik  menu  File  → Templates  →  Save,  sehingga  tampak 
kotak dialog seperti pada gambar berikut ini .

• Pada bagian  New template, isikan nama template misalnya 
Tugas Akhir.

• Pada  bagian  Categories,  pilih  kategori  dari  template  anda 
misalnya My Templates.

• Klik OK untuk menyimpan template yang telah anda buat.

3.3.2 MENGAKSES STYLE DARI TEMPLATE

Berikut  ini  langkah-langkah  untuk  mengakses  style dari  template 
untuk digunakan dalam dokumen baru yang akan kita susun.

• Tampilkan  menu  Styles  and  Formatting melalui  menu 
Format → Styles and Formatting (atau tekan F11).

• Klik Load Styles seperti pada gambar berikut ini.

Pengayaan Dan Penomoran

Gambar 3.20: Kotak Dialog New Template
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• Pilih Template yang akan anda gunakan kemudian beri tanda 
centang  pada  jenis  style  yang  akan  disalin  (Text,  Frame, 
Pages, Numbering).

• Beri  tanda centang pada bagian  Overwrite jika anda ingin 
menimpa style yang ada pada dokumen anda sekarang.

• Klik  OK untuk  menerapkan  style  tersebut  pada  dokumen 
anda.

Pengayaan Dan Penomoran

Gambar 3.21: Mengakses Template Melalui Load Styles

Gambar 3.22: Kotak Dialog Load Styles



BAB 4
PENYUSUNAN BAGIAN AWAL 

TUGAS AKHIR

4.1 SAMPUL DEPAN

Halaman  sampul  sebaiknya  dituliskan  dengan  menggunakan  style 
Text  Body karena  halaman  ini  biasanya  tidak  dimasukkan  dalam 
daftar isi.  Pada kasus ini,  kita menganggap bahwa halaman sampul 
tidak dihitung sebagai halaman. Dengan demikian halaman ini tidak 
diberikan  nomor  halaman.  Akan  tetapi,  anda  bisa  menyesuaikan 
dengan ketentuan perguruan tinggi masing-masing.

4.1.1 PENYUSUNAN ISI HALAMAN

Berikut ini langkah-langkah pembuatan halaman sampul depan :

• Tempatkan kursor anda pada bagian atas halaman sampul.

• Tampilkan  grup  Styles  and  Formatting dengan  menekan 
tombol F11.

• Klik  style Text Body,  selanjutnya ketikkan isi halaman ini 
dan atur sesuai dengan ketentuan yang berlaku di perguruan 
tinggi masing-masing.

• Setelah  halaman  ini  selesai  dibuat,  tekan  Ctrl  +  ENTER 
untuk berpindah halaman.

4.1.2 PENYISIPAN LOGO

Pada  halaman  sampul,  kita  juga  akan  menyisipkan  logo perguruan 
tinggi masing-masing. Berikut ini langkah-langkah untuk menyisipkan 
logo yang berbentuk gambar.

Penyusunan Bagian Awal Tugas Akhir
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• Tempatkan  kursor  anda  pada  bagian  yang  akan  disisipkan 
logo.

• Klik  menu  Insert  →Picture  →From  File  ... sehingga 
tampak kotak dialog seperti pada gambar berikut ini.

• Pilihlah  lokasi  dokumen  gambar  logo  yang  akan  anda 
sisipkan pada bagian Places.

• Klik  Open untuk menyisipkan gambar logo anda ke dalam 
dokumen.

Berikut ini contoh halaman sampul :

Penyusunan Bagian Awal Tugas Akhir

Gambar 4.1: Kotak Dialog Insert Picture
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Gambar 4.2: Contoh Halaman Sampul

4.2 HALAMAN JUDUL

Pada dasarnya format halaman judul sama dengan sampul depan tetapi 
biasanya  dicantumkan  informasi  tambahan  yaitu  untuk  tujuan  dan 
dalam rangka apa karya ilmiah itu dibuat.

Penyusunan Bagian Awal Tugas Akhir

LOGO
PERGURUAN

TINGGI

SKRIPSI/TESIS/DISERTASI

JUDUL SKRIPSI/TESIS/DISERTASI 

NAMA MAHASISWA

JURUSAN ?? 

FAKULTAS ?? 

UNIVERSITAS ??

MARET 2011
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Pemindahan  ke  halaman  baru  dapat  dilakukan  dengan  menekan 
tombol Ctrl + ENTER dengan posisi kursor di bagian akhir halaman. 
Berikut ini contoh format halaman judul :

Gambar 4.3: Contoh Halaman Judul

Penyusunan Bagian Awal Tugas Akhir

LOGO
PERGURUAN

TINGGI

SKRIPSI/TESIS/DISERTASI

JUDUL SKRIPSI/TESIS/DISERTASI 

Diajukan untuk memenuhi salah satu persyaratan dalam 
menyelesaikan program Sarjana/ Magister/ Doktor

NAMA MAHASISWA

NIM

JURUSAN ?? 

FAKULTAS ?? 

UNIVERSITAS ??

 MARET 2011
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4.3 HALAMAN PENGESAHAN

Halaman pengesahan kadang dimasukkan dalam daftar isi kadang juga 
tidak. Kemudian kata “HALAMAN PENGESAHAN” ada perguruan 
tinggi yang mencantumkan dan ada juga yang tidak.

Penulisan dapat dimulai dengan mengklik terlebih dahulu style Judul 
yang  ada  pada  grup  style  selanjutnya  ketikkan  “HALAMAN 
PENGESAHAN”.  Anda  juga  dapat  menuliskan  katanya  terlebih 
dahulu kemudian klik ganda  style Judul yang akan diterapkan.

Berikut ini langkah-langkah untuk membuat halaman pengesahan :

• Tempatkan  kursor  pada  bagian  atas  halaman  pengesahan 
kemudian  ketikkan  “HALAMAN  PENGESAHAN”. 
Selanjutnya klik ganda style Judul.

• Setelah  menekan  tombol  ENTER,  hal  selanjutnya  adalah 
menuliskan  isi  halaman  ini  dengan  style  Text  Body dan 
sesuaikan dengan format perguruan tinggi masing-masing.

• Setelah  halaman  ini  selesai,  lakukan  pemindahan  halaman 
dengan menekan tombol Ctrl + ENTER.

Berikut ini contoh halaman pengesahan.

Penyusunan Bagian Awal Tugas Akhir
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Gambar 4.4: Contoh Halaman Pengesahan

4.4 PERNYATAAN KEASLIAN

Halaman ini berisi pernyataan tertulis dari penulis bahwa tugas akhir 
yang dibuat merupakan hasil karyanya sendiri.  Berikut ini langkah-

Penyusunan Bagian Awal Tugas Akhir

HALAMAN PENGESAHAN 

Tugas Akhir ini diajukan oleh : 

Nama : 

NPM /NIM : 

Program Studi : 

Judul Tugas Akhir : 

Telah berhasil dipertahankan di hadapan Dewan Penguji dan diterima 
sebagai bagian persyaratan yang diperlukan untuk memperoleh gelar 
Sarjana ?? pada Program Studi ??, Fakultas ??, Universitas ??. 

DEWAN PENGUJI 

Pembimbing : Prof. XXXX ( ) 

Penguji : Prof. XXX ( ) 

Penguji : Prof. XXXX ( ) 

Penguji : Prof. XXXXXX ( ) 
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langkah pembuatan halaman pernyataan keaslian :

• Tempatkan  kursor  anda  pada  bagian  atas  dari  halaman 
pernyataan  keaslian  kemudian  ketikkan  “PERNYATAAN 
KEASLIAN” dan klik ganda style Judul.

• Setelah  menekan  tombol  ENTER,  hal  selanjutnya  adalah 
menuliskan  isi  halaman  ini  dengan  style  Text  Body dan 
sesuaikan dengan format perguruan tinggi masing-masing.

• Setelah  halaman  ini  selesai,  lakukan  pemindahan  halaman 
dengan menekan tombol Ctrl + ENTER.

Berikut ini contoh halaman pernyataan keaslian :

Penyusunan Bagian Awal Tugas Akhir
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Gambar 4.5: Contoh Halaman Pernyataan Keaslian

4.5 KATA PENGANTAR

Kata pengantar memuat pengantar singkat atas karya ilmiah. Dalam 
kata pengantar juga terdapat ucapan terima kasih. Berikut ini langkah-

Penyusunan Bagian Awal Tugas Akhir

PERNYATAAN KEASLIAN

Saya yang bertanda tangan di bawah ini menyatakan bahwa Skripsi/ 
Tesis/ Disertasi ini adalah hasil karya saya sendiri, dan semua sumber 
baik yang dikutip maupun yang dirujuk telah saya nyatakan dengan 
benar. Bila di kemudian hari ternyata pernyataan saya terbukti tidak 
benar,  maka saya  bersedia  menerima sanksi  yang telah  ditetapkan 
oleh Fakultas ?? Universitas ?? .

Yang membuat pernyataan

Ttd di sini

Nama :

NPM/ NIM :

Tanggal :
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langkah penulisan halaman kata pengantar :

• Tempatkan  kursor  anda  pada  bagian  atas  dari  halaman 
pernyataan  keaslian  kemudian  ketikkan  “KATA 
PENGANTAR” dan klik ganda style Judul.

• Setelah  menekan  tombol  ENTER,  hal  selanjutnya  adalah 
menuliskan  isi  halaman  ini  dengan  style  Text  Body dan 
sesuaikan dengan format perguruan tinggi masing-masing.

• Setelah  halaman  ini  selesai,  lakukan  pemindahan  halaman 
dengan menekan tombol Ctrl + ENTER.

Berikut ini contoh halaman kata pengantar :

Penyusunan Bagian Awal Tugas Akhir
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Gambar 4.6: Contoh Halaman Kata Pengantar

4.6 PERSETUJUAN PUBLIKASI

Halaman ini berisi pernyataan dari mahasiswa penyusun tugas akhir 
untuk  memberikan  kewenangan  kepada  pihak  universitas  untuk 

Penyusunan Bagian Awal Tugas Akhir

KATA PENGANTAR

Segala  puji  dan  syukur  kehadirat  Allah  SWT  atas  segala 
limpahan  rahmat  dan  karunia-Nya  serta  ridho-Nya  sehingga  tugas 
akhir dengan judul “Perancangan Media Pembelajaran Berbasis 
Komputer dengan LibreOffice 3.3 Impress untuk Mata Pelajaran 
Fisika SMA” dapat diselesaikan.

Penulis menyadari bahwa penulisan tugas akhir ini terwujud 
berkat  uluran  tangan  dari  berbagai  pihak.  Pada  kesempatan  ini, 
penulis ingin mengucapkan terima kasih kepada :

1. ............

2. ............

3. ...........

Sebagai  sebuah  karya  manusia,  tulisan  ini  tentulah  tidak 
sempurna.  Untuk  itu  penulis  akan  senantiasa  berlapang  dada 
menerima  saran  dan  kritik  yang  sifatnya  membangun  demi 
penyempurnaan tugas akhir ini.

Akhir kata, semoga tugas akhir ini dapat memberikan manfaat 
bagi pembaca.
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menyimpan, mengalih media,  merawat,  dan mempublikasikan tugas 
akhirnya  demi  kepentingan  akademis.  Artinya,  pihak  universitas 
berwenang  untuk  mempublikasikan  suatu  tugas  akhir  untuk 
kepentingan pengembangan ilmu pengetahuan,  sedangkan hak cipta 
tetap  pada  penulis.  Berikut  ini  langkah-langkah  penulisan  halaman 
persetujuan publikasi :

• Tempatkan  kursor  anda  pada  bagian  atas  dari  halaman 
pernyataan  keaslian  kemudian  ketikkan  “PERSETUJUAN 
PUBLIKASI” dan klik ganda style Judul.

• Setelah  menekan  tombol  ENTER,  hal  selanjutnya  adalah 
menuliskan  isi  halaman  ini  dengan  style  Text  Body dan 
sesuaikan dengan format perguruan tinggi masing-masing.

• Setelah  halaman  ini  selesai,  lakukan  pemindahan  halaman 
dengan menekan tombol Ctrl + ENTER.

Berikut ini contoh halaman persetujuan publikasi:

Penyusunan Bagian Awal Tugas Akhir
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Gambar 4.7: Contoh Halaman Persetujuan Publikasi

Penyusunan Bagian Awal Tugas Akhir

PERSETUJUAN PUBLIKASI UNTUK 
KEPENTINGAN AKADEMIK

Sebagai sivitas akademik Universitas ??, saya yang bertanda tangan 
di bawah ini: 

Nama :

NPM /NIM :

Program Studi :

Fakultas :

Jenis Karya :

Demi  pengembangan  ilmu  pengetahuan,  menyetujui  untuk 
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4.7 HALAMAN ABSTRAK/ ABSTRACT

Halaman  abstrak  merupakan  ikhtisar  dari  suatu  tugas  akhir  yang 
dibuat untuk memudahkan pembaca mengerti secara cepat tentang isi 
dari tugas akhir tersebut. Halaman ini biasanya dituliskan dalam dua 
bahasa yaitu dalam bahasa Inggris dan Indonesia .Berikut ini langkah-
langkah penulisan halaman abstrak :

• Tempatkan  kursor  anda  pada  bagian  atas  dari  halaman 
pernyataan  keaslian  kemudian  ketikkan  “ABSTRAK”  dan 
klik ganda style Judul.

• Setelah  menekan  tombol  ENTER,  hal  selanjutnya  adalah 
menuliskan  isi  halaman  ini  dengan  style  Text  Body dan 
sesuaikan dengan format perguruan tinggi masing-masing.

• Setelah  halaman  ini  selesai,  lakukan  pemindahan  halaman 
dengan menekan tombol Ctrl + ENTER.

• Dengan cara yang sama, lakukan penulisan untuk halaman 
abstrak untuk versi bahasa Inggris.

Berikut ini contoh halaman abstrak :

Penyusunan Bagian Awal Tugas Akhir
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Gambar 4.8: Contoh Halaman Abstrak

4.8 DAFTAR ISI

Halaman daftar isi memberikan gambaran secara menyeluruh tentang 
isi  dari  suatu  tugas  akhir  disertai  nomor  halamannya.  Halaman ini 

Penyusunan Bagian Awal Tugas Akhir

ABSTRAK

Nama :

Program Studi :

Judul :

Halaman ini berisi ringkasan skripsi/ tesis/ disertasi. Abstrak 
biasanya dituliskan dalam bahasa Indonesia dan Inggris dengan 
halaman terpisah. Berikut ini beberapa aturan yang biasa digunakan 
dalam penulisan abstrak :

• Jumlah kata antara 250 – 500 kata

• Spasi yang digunakan adalah spasi 1

• terdapat kata kunci

Kata Kunci : ............., ..................., ................., dst.
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akan kita  buat  secara  otomatis  setelah  seluruh  bagian  penulisan isi 
tugas  akhir  selesai.  Dengan  demikian,  kita  lakukan  pemindahan 
halaman dengan menekan tombol Ctrl + ENTER.

4.9 DAFTAR TABEL, GAMBAR, LAINNYA 
(KALAU ADA)

Daftar tabel, gambar, dan lainnya akan digunakan untuk memuat nama 
tabel, nama gambar, dan lain sebagainya yang ada dalam tugas akhir. 
Pembuatan  daftar-daftar  ini  akan  dilakukan secara  otomatis  setelah 
seluruh penulisan tugas akhir sudah lengkap. Jika halaman ini adalah 
halaman  terakhir  untuk  bagian  awal  tugas  akhir,  maka  lakukan 
penomoran  untuk  bagian  ini.  Selanjutnya  lakukan  pemindahan 
halaman baru dengan cara sebagai berikut :

• Tempatkan kursor anda pada bagian akhir halaman.

• Klik menu  Insert → Manual Break ... ,  sehingga tampak 
kotak dialog berikut ini :

• Pilih page break pada bagian Type dan Halaman BAB pada 
bagian Style.

Penyusunan Bagian Awal Tugas Akhir

Gambar 4.9: Kotak Dialog Insert Break
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• Berikan  tanda  centang  pada  CheckBox  Change  page 
number. Kemudian pastikan SpinButton berisi angka 1. Hal 
ini bertujuan untuk memastikan bahwa nomor halaman Bab 1 
dimulai dari angka 1.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

4.10 PENOMORAN BAGIAN AWAL

Format halaman bagian awal biasanya menggunakan angka Romawi 
(i,  ii,  iii,  ...)  dan  lokasi  nomor  halaman disesuaikan  dengan aturan 
yang berlaku di perguruan tinggi masing-masing. Pada kasus ini, kita 
tentukan lokasi halaman di bagian bawah kertas dengan rata tengah.

Berikut ini langkah-langkah untuk memberikan nomor pada halaman 
bagian awal :

• Tempat kursor anda pada bagian footer halaman bagian awal.

• Klik  menu  Insert  →  Fields  →  Page  Number,  sehingga 
nomor halaman akan ditempatkan pada bagian footer.

• Selanjutnya  tekan  Ctrl  +  E untuk  menempatkan  nomor 
halaman tersebut pada bagian tengah.

Penyusunan Bagian Awal Tugas Akhir



BAB 5
PENYUSUNAN BAGIAN 

UTAMA

5.1 PEMBUATAN BAB PERTAMA

Di  bagian  ini,  kita  akan  membahas  tentang  pembuatan  nomor  dan 
judul bab serta nomor dan judul subbab derajat satu. Nomor bab yang 
akan  kita  gunakan  adalah  angka  Arab  begitu  juga  dengan  nomor 
subbabnya. Jika yang anda kehendaki berbeda dengan ini, maka dapat 
dilakukan pengaturan pada bagian  Outline and Numbering ... (3.2 
Penomoran) .

5.1.1 PENULISAN NOMOR DAN JUDUL BAB

Langkah-langkah  penulisan  nomor  dan  judul  bab  adalah  sebagai 
berikut :

• Tempatkan kursor anda pada bagian atas dari halaman bagian 
utama.

• Klik  ganda  style  Heading  1 atau  tekan  Ctrl  +  1 hingga 
tampak tulisan BAB 1 lalu tekan SHIFT + ENTER.

• Ketikkan judul yang diinginkan misalnya PENDAHULUAN.

5.1.2 PENULISAN NOMOR DAN JUDUL SUBBAB DERAJAT 
SATU

Langkah-langkah  penulisan  nomor  dan  judul  subbab  derajat  satu 
adalah sebagai berikut :

• Tempatkan kursor anda pada baris yang dikehendaki untuk 
penempatan  nomor  dan  judul  subbab  dari  halaman  bagian 
utama.

Penyusunan Bagian Utama
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• Klik  ganda  style  Heading  2 atau  tekan  Ctrl  +  2 hingga 
tampak nomor subbab.

• Ketikkan  judul  subbab  yang  diinginkan  misalnya  Latar 
Belakang. Kemudian tekan tombol ENTER.

• Pastikan style berikutnya adalah Text Body.

• Ketikkan  isi  paragraf  pertama  dan  setelah  selesai  tekan 
tombol  ENTER,  maka  style  Text  Body  Indent untuk 
paragraf kedua dan seterusnya akan aktif.

• Selanjutnya  tuliskan  isi  masing-masing  subbab  yang  telah 
dibuat.

• Jika ingin berpindah halaman, anda tidak perlu lagi menekan 
tombol  Ctrl  +  ENTER karena  style  untuk  halaman 
berikutnya  sudah  kita  atur  (3.1.2.2 Page  style).  Dengan 
demikian,  jika  halaman  BAB  sudah  penuh  maka  secara 
otomatis  akan  berpindah  ke  halaman  isi.  Hal  ini  berlaku 
untuk semua halaman BAB.

5.2 PEMBUATAN BAB KEDUA DAN 
SETERUSNYA

Pembuatan halaman pertama untuk BAB 2 dapat dilakukan dengan 
cara sebagai berikut :

• Tempatkan kursor anda pada bagian akhir halaman BAB 1.

• Klik menu  Insert → Manual Break ... ,  sehingga tampak 
kotak dialog seperti pada gambar berikut ini :

Penyusunan Bagian Utama
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• Pilih page break pada bagian Type dan Halaman BAB pada 
bagian Style.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

5.2.1 PENULISAN NOMOR DAN JUDUL SUBBAB DERAJAT 
KEDUA

Langkah-langkah pembuatan nomor dan judul subbab derajat kedua 
adalah sebagai berikut :

• Tempatkan kursor anda pada baris yang dikehendaki untuk 
penempatan nomor dan judul subbab.

• Klik  ganda  style  Heading  3 atau  tekan  Ctrl  +  3 hingga 
tampak nomor subbab derajat kedua.

• Ketikkan judul subbab kemudian tekan ENTER.

• Pastikan style berikutnya adalah Text Body.

• Ketikkan  isi  paragraf  pertama  dan  setelah  selesai  tekan 
tombol  ENTER,  maka  style  Text  Body  Indent untuk 
paragraf kedua dan seterusnya akan aktif.

Penyusunan Bagian Utama

Gambar 5.1: Kotak Dialog Insert Break



80

• Selanjutnya  tuliskan  isi  masing-masing  subbab  yang  telah 
dibuat.

5.2.2 PENULISAN NOMOR DAN JUDUL SUBBAB DERAJAT 
KETIGA

Langkah-langkah pembuatan nomor dan judul subbab derajat ketiga 
adalah sebagai berikut :

• Tempatkan kursor anda pada baris yang dikehendaki untuk 
penempatan nomor dan judul subbab.

• Klik  ganda  style  Heading  4 atau  tekan  Ctrl  +  4 hingga 
tampak nomor subbab derajat ketiga.

• Ketikkan judul subbab kemudian tekan ENTER.

• Pastikan style berikutnya adalah Text Body.

• Ketikkan  isi  paragraf  pertama  dan  setelah  selesai  tekan 
tombol  ENTER,  maka  style  Text  Body  Indent untuk 
paragraf kedua dan seterusnya akan aktif.

• Selanjutnya  tuliskan  isi  masing-masing  subbab  yang  telah 
dibuat.

5.2.3 PENOMORAN DAN PENULISAN DAFTAR (LIST)

Perhatikan contoh berikut ini :

(1) langkah-langkah penyusunan butir tes:

(a) menyusun kisi-kisi tes

(b) menyusun konsep butir soal

(2) menyempurnakan konsep butir soal

(3) melakukan uji-coba test

(4) dst

Berikut ini langkah-langkah untuk melakukan penomoran daftar (list) 
seperti contoh di atas :

Penyusunan Bagian Utama
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• Ketikkan  terlebih  dahulu  teks  tersebut  tanpa  memberikan 
penomoran.

• Jika sudah selesai, sorot semua teks tersebut.

• Tampilkan  Styles and Formatting dengan menekan tombol 
F11, selanjutnya klik ganda  List 1 yang terdapat pada grup 
List Styles.

(1) langkah-langkah penyusunan butir tes:

(2) menyusun kisi-kisi tes

(3) menyusun konsep butir soal

(4) menyempurnakan konsep butir soal

(5) melakukan uji-coba test

(6) dst

• Sorot butir 2) dan 3), kemudian klik Demote One Level pada 
Bullets and Numbering hingga diperoleh hasil yang sama 
seperti contoh di atas.

5.3 PENOMORAN HALAMAN BAGIAN 
UTAMA

Mulai  halaman  BAB  1  sampai  lampiran-lampiran  menggunakan 
angka  latin  (1,2,3,..).  Pada  kasus  ini,  penomoran  diletakkan  pada 
bagian  atas  tepi  kanan,  kecuali  pada  halaman  BAB  penomoran 
diletakkan pada bagian tengah bawah kertas.

5.3.1 PENOMORAN HALAMAN BAB

• Tempatkan kursor anda pada bagian footer halaman BAB.

• Klik  menu  Insert  →  Fields  →  Page  Number,  sehingga 

Penyusunan Bagian Utama

Gambar 5.2: Kotak Dialog Bullets and Numbering
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nomor halaman akan ditempatkan pada bagian footer.

• Selanjutnya  tekan  Ctrl  +  E untuk  menempatkan  nomor 
halaman tersebut pada bagian tengah.

5.3.2 PENOMORAN HALAMAN ISI

• Tempatkan kursor anda pada bagian header halaman isi.

• Klik  menu  Insert  →  Fields  →  Page  Number,  sehingga 
nomor halaman akan ditempatkan pada bagian header.

• Selanjutnya  tekan  Ctrl  +  R untuk  menempatkan  nomor 
halaman tersebut pada bagian kanan kertas.

Penyusunan Bagian Utama



BAB 6
MENYISIPKAN TABEL DAN 

PERSAMAAN

6.1 MENYISIPKAN TABEL

6.1.1 PEMBUATAN TABEL DI WRITER

• Tempatkan kursor anda pada lokasi yang dikehendaki sebagai 
tempat untuk menyisipkan tabel.

• Klik menu  Insert  → Table... atau melalui  menu  Table → 
Insert → Table ... atau dapat juga dengan menekan tombol 
Ctrl + F12.

• Pada  kotak  dialog  yang  tampak,  isikan  banyaknya  jumlah 
kolom  pada  Columns dan  baris  pada  Rows.  Misalkan,  5 
untuk  kolom  dan  4  untuk  baris.  Sebaiknya  anda  juga 
memberikan nama tabel pada bagian Name. Hal ini bertujuan 
untuk  memudahkan  anda  dalam  mencari  tabel  yang  ada 
dalam dokumen melalu fasilitas Navigator.

Menyisipkan Tabel Dan Persamaan

Gambar 6.1: Kotak Dialog Insert Table
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• Klik OK. Selanjutnya lakukan pengaturan pada tabel.

6.1.2 PENYISIPAN TABEL DARI CALC

• Buka file spreadsheet melalui program Calc.

• Blok bagian tabel yang akan disisipkan pada dokumen tugas 
akhir  kemudian klik ikon  copy yang terdapat  pada toolbar 
atau tekan Ctrl + C.

• Selanjutnya  aktifkan  dokumen  tugas  akhir  anda  dan 
tempatkan  kursor  pada  lokasi  penyisipan  tabel.  Kemudian 
tekan  Ctrl  +  V atau  klik  ikon  paste yang  terdapat  pada 
toolbar.

• Lakukan pengaturan pada tabel yang baru saja anda sisipkan. 
Tabel tersebut akan dianggap sebagai  OLE (Object Linking 
Embedded).

6.2 PERSAMAAN

Untuk  membuat  persamaan  atau  rumus,  kita  dapat  membuatnya 
melalui aplikasi  LibreOffice Math atau dapat pula melalui Formula 
yang ada dalam Writer. Berikut ini langkah-langkah untuk membuat 
persamaan melalui Formula :

• Tempatkan kursor anda pada lokasi yang hendak disisipkan 
persamaan.

• Klik menu Insert → Object → Formula .

Menyisipkan Tabel Dan Persamaan

Gambar 6.2: Kotak Dialog Table
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6.2.1 PEMBUATAN PERSAMAAN

• Sebagai  contoh,  kita  akan  membuat  persamaan  seperti 
berikut ini :

r=√ x2
+y2

• Ketik r= .

• Klik kategori f(x) pada kotak dialog Elements kemudian klik 

√( x) .

Menyisipkan Tabel Dan Persamaan

Gambar 6.3: Tampilan Formula pada Writer
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• Klik kotak yang nantinya akan kita isi persamaan x2+y2

• Klik  kategori  Unary/Binary  operator pada  kotak  dialog 
Elements, kemudian klik sub kategori Addition + .

Menyisipkan Tabel Dan Persamaan

Gambar 6.4: Kotak Dialog 
Elements dari Formula
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• Klik  kotak  yang  nantinya  akan  diisi  dengan  persamaan 

x2 .

• Klik  kategori  Formats,  kemudian  klik  sub  kategori 
Superscript Right.

Menyisipkan Tabel Dan Persamaan

Gambar 6.5: Kotak Dialog 
Elements untuk Sub Kategori  

Addition
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• Klik  kotak  yang  nantinya  akan  diisi  dengan  x.  Kemudian 
ketikkan x.

• Klik juga pada kotak yang akan diisikan dengan 2. Kemudian 
ketikkan 2.

• Selanjutnya klik kotak yang akan diisikan dengan persamaan 

y2 .

• Klik  kategori  Formats,  kemudian  klik  sub  kategori 
Superscript Right.

• Klik  kotak  yang  nantinya  akan  diisi  dengan  y.  Kemudian 
ketikkan y.

Menyisipkan Tabel Dan Persamaan

Gambar 6.6: Kotak Dialog 
Elements untuk Sub Kategori  

Superscript Right
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• Klik  kotak  yang  nantinya  akan  diisi  dengan  2.  Kemudian 
ketikkan 2.

• Klik pada bagian luar persamaan untuk melihat  hasil  akhir 
dari persamaan yang telah kita buat.

6.2.2 MENYISIPKAN KARAKTER KHUSUS PADA 
PERSAMAAN

Misalkan kita ingin membuat persamaan v=√ F


,  =
C P

CV

, 

dan  lain sebagainya.  Karakter  khusus tersebut  tidak tersedia  secara 
otomatis sehingga kita perlu melakukan pengaturan terlebih dahulu.

Untuk  menyisipkan  karakter  khusus  seperti  μ,  γ,  λ,  dan  lain 
sebagainya  dapat  dilakukan  melalui  Catalog yang  terdapat  pada 
Toolbar.

Berikut ini langkah-langkah untuk menyisipkan karakter khusus pada 
persamaan :

• Klik  ikon  Catalog yang  terdapat  pada  Toolbar sehingga 
tampak kotak dialog seperti pada gambar berikut :

Menyisipkan Tabel Dan Persamaan

Gambar 6.7: Ikon 
Catalog
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• Pada bagian Symbol set pilih Greek kemudian pilih gamma 
bukan GAMMA (simbol yang akan disisipkan).

• Klik tombol Edit sehingga tampak kotak dialog berikut ini :

• Pilih simbol  gamma. Selanjutnya klik  Modify dan terakhir 
klik OK.

• Pilih simbol yang akan disisipkan (yakni gamma) kemudian 
klik  Insert.  Dengan  demikian  karakter  tersebut  telah 
dimasukkan ke dalam persamaan.

Menyisipkan Tabel Dan Persamaan

Gambar 6.8: Kotak Dialog Symbols

Gambar 6.9: Kotak Dialog Edit Symbols



BAB 7
PENOMORAN GAMBAR, 

TABEL DAN PERSAMAAN

7.1 PEMBUATAN LABEL GAMBAR, 
TABEL, DAN PERSAMAAN

Pada bagian ini kita akan membuat label baru yakni Gambar, Tabel, 
dan  Persamaan karena label default yang ada dalam  Writer adalah 
Drawing,  Illustration,  Table,  Text.  Berikut  ini  langkah-langkah 
pembuatan label baru tersebut :

• Klik menu Insert → Fields → Other ... atau tekan Ctrl + F2 
sehingga tampak kotak dialog seperti  pada gambar berikut 
ini.

Penomoran Gambar, Tabel Dan Persamaan

Gambar 7.1: Kotak Dialog Fields
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• Pada menu Variables, ketikkan label baru yang dikehendaki 
misalnya Tabel pada bagian Name.

• Pada  bagian  Numbering  by  chapter lakukan  pengaturan 
sebagai berikut :

Level : 1

Separator : .

• Pada bagian Format, pilih angka Arab (1,2,3).

• Klik  Insert untuk  menambahkan  label  tersebut  ke  dalam 
kategori caption. Setelah anda mengklik tombol Insert maka 
penomoran  akan  ditampilkan  pada  dokumen  anda.  Untuk 
sementara hasil penomoran tersebut sebaiknya anda hapus.

• Lakukan langkah yang sama untuk pembuatan label Gambar 
dan Persamaan.

• Setelah  pembuatan  label  Tabel,  Gambar,  dan  Persamaan 
selesai, klik Close untuk menutup kotak dialog tersebut.

7.2 PENOMORAN GAMBAR, TABEL DAN 
PERSAMAAN

Pada dasarnya penomoran pada gambar, tabel, dan persamaan hampir 
tidak ada perbedaan, yang berbeda hanyalah penempatannya saja.

7.2.1 GAMBAR

7.2.1.1 Penomoran Gambar

Nomor  dan  judul  gambar  biasanya  diletakkan  pada  bagian  bawah 
tengah. Berikut ini langkah-langkah penyisipan nomor gambar :

• Klik pada gambar yang akan disisipkan nomor.

• Klik menu Insert → Caption, sehingga tampak kotak dialog 
seperti pada gambar berikut ini :

Penomoran Gambar, Tabel Dan Persamaan
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• Lakukan  pengaturan  sebagai  berikut  pada  bagian 
Properties :

Category : Gambar

Numbering : Arabic (1 2 3)

Separator : :

• Ketikkan judul gambar pada bagian Caption

• Klik menu Options... , sehingga tampak kotak dialog seperti 
pada gambar berikut ini :

Penomoran Gambar, Tabel Dan Persamaan

Gambar 7.2: Pengaturan Penomoran Gambar pada Caption
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• Lakukan pengaturan sebagai berikut :

◦ Numbering captions by chapter

Level : 1

Separator : .

◦ Category and frame format

Character style : <None>

◦ Caption

Caption order : Category first

• Klik OK untuk menerapkan perubahan yang telah dilakukan 
pada menu Options ... .

• Klik OK untuk menyisipkan nomor pada gambar.

7.2.1.2 Pengaturan Style Gambar

Style Gambar digunakan untuk penulisan judul gambar. Berikut ini 
langkah-langkah pengaturan pada style Gambar.

• Pilihlah  Gambar yang  ada  pada  grup  paragraph  style, 

Penomoran Gambar, Tabel Dan Persamaan

Gambar 7.3: Pengaturan Menu Options dari Caption
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lakukan klik  kanan dan  klik  modify hingga tampak kotak 
dialog seperti pada gambar berikut ini :

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)

Ukuran Huruf : 9 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi Tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

Penomoran Gambar, Tabel Dan Persamaan

Gambar 7.4: Pengaturan Style Illustration
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First Line : 0.00 cm

Above paragraph : 1.74 cm

Below paragraph : 1.74 cm

Line spacing : Single

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

7.2.2 TABEL

7.2.2.1 Penomoran Tabel

Nomor dan judul tabel biasanya diletakkan pada bagian atas tengah. 
Berikut ini langkah-langkah penyisipan nomor tabel :

• Klik pada baris atau kolom dari tabel yang akan disisipkan 
nomor.

• Klik menu Insert → Caption, sehingga tampak kotak dialog 
seperti pada gambar berikut ini :

• Lakukan  pengaturan  sebagai  berikut  pada  bagian 
Properties :

Category : Gambar

Penomoran Gambar, Tabel Dan Persamaan

Gambar 7.5: Pengaturan Penomoran Tabel pada Caption
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Numbering : Arabic (1 2 3)

Separator : :

Position : Above

• Ketikkan judul tabel pada bagian Caption

• Klik menu Options... .

• Lakukan pengaturan sebagai berikut :

◦ Numbering captions by chapter

Level : 1

Separator : .

◦ Category and frame format

Character style : <None>

◦ Caption

Caption order : Category first

• Klik OK untuk menerapkan perubahan yang telah dilakukan 
pada menu Options ... .

• Klik OK untuk menyisipkan nomor pada tabel.

7.2.2.2 Pengaturan Style Tabel

Style  Tabel digunakan  untuk  penulisan  judul  tabel.  Berikut  ini 
langkah-langkah pengaturan style Tabel.

• Pilihlah Tabel yang ada pada grup paragraph style, lakukan 
klik  kanan  dan  klik  modify hingga  tampak  kotak  dialog 
seperti pada Gambar 7.6.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)

Ukuran Huruf : 12 point

Penomoran Gambar, Tabel Dan Persamaan
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• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi Tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 1.74 cm

Below paragraph : 1.74 cm

Line spacing : Single

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

Penomoran Gambar, Tabel Dan Persamaan
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7.2.3 PERSAMAAN

7.2.3.1 Pengaturan Style Persamaan

Style  Persaman digunakan  untuk  penulisan  persamaan  (rumus). 
Berikut ini langkah-langkah pengaturan style Persamaan :

• Klik kanan pada grup paragraph style, kemudian pilih New 
sehingga tampak kotak dialog seperti pada gambar berikut ini 
:

• Pada  bagian  Name dari  menu  Organizer,  ketikkan 
“Persamaan”.  Selanjutnya  lakukan  pengaturan  pada  menu-
menu yang lain.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Bold atau Negreta)
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Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi Tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 1.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.21 cm

Below paragraph : 0.21 cm

Line spacing : 1,5 lines

Karena  pengaturan  penulisan  nomor  persamaan  harus 
menjorok  dan  rata  kanan,  maka  lakukan  pengaturan  lebih 
lanjut dengan cara :

Penomoran Gambar, Tabel Dan Persamaan
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• Untuk mengatur rata kanan, klik menu Tabs sehingga tampak 
kotak dialog seperti pada Gambar 7.8 di atas.

• Pada bagian Position, isikan 14 cm (sesuaikan dengan batas 
paling kanan kertas).

• Pilih  Right pada  bagian  Type agar  tulisan  rata  kanan 
kemudian klik New.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

7.2.3.2 Penomoran Persamaan

Pada penomoran persamaan, nomor persamaan diletakkan pada bagian 
sebelah kanan persamaan dan diletakkan rata kanan.

Berikut ini langkah-langkah untuk menyisipkan nomor persamaan :

• Tempatkan kursor di sebelah kanan persamaan.

• Klik menu  Insert → Fields → Other ... atau tekan  Ctrl + 
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Gambar 7.8: Pengaturan Tabs pada Style Persamaan
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F2,  kemudian  klik  menu  Variable  → Number range  → 
Persamaan.

• Klik Insert untuk menyisipkan nomor pada persamaan.

• Tempatkan  kursor  anda  pada  persamaan  lain  tanpa  harus 
menutup kotak dialog  Fields.  Kemudian  klik  Insert untuk 
menambahkan nomor pada persamaan tersebut.

• Klik  Close setelah  seluruh  persamaan  yang  ingin  anda 
berikan nomor selesai.

• Selanjutnya ubah style nomor persamaan dengan melakukan 
klik  ganda  pada  style  Persamaan yang  terdapat  pada 
Paragraph Style dari grup Styles and Formatting.

• Tempatkan kursor anda di sebelah kiri nomor persamaan lalu 
tekan  tab satu  kali  agar  nomor  tersebut  ditempatkan  rata 
kanan.

• Terakhir lengkapi persamaan anda dengan tanda kurung.

7.2.4 PENOMORAN GAMBAR DAN TABEL SECARA 
OTOMATIS DENGAN AUTOCAPTION

• Klik  menu  Tools  →  Options... ,  sehingga  tampak  kotak 
dialog seperti pada Gambar 7.9
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Gambar 7.9: Pengaturan Menu Options dari Writer
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• Klik AutoCaption pada bagian Writer.

• Selanjutnya  beri  tanda  centang  pada  LibreOffice  Writer 
Table dan lakukan pengaturan sebagai berikut :

◦ Caption

Category : Tabel

Numbering : Arabic (1 2 3)

Separator : :

Position : Above

◦ Numbering captions by chapter

Level : 1

Separator : .

• Berikan  juga  tanda  centang  pada  LibreOffice  Writer 
Picture dan lakukan pengaturan sebagai berikut :

◦ Caption

Category : Gambar

Numbering : Arabic (1 2 3)

Separator : :

◦ Numbering captions by chapter

Level : 1

Separator : .

• Klik OK untuk menyimpan perubahan yang telah dilakukan. 

Penomoran Gambar, Tabel Dan Persamaan
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7.3 PENUNJUKAN GAMBAR, TABEL DAN 
PERSAMAAN

Pada  penulisan  tugas  akhir,  nomor  gambar,  tabel,  dan  persamaan 
biasanya nomor tersebut selain digunakan untuk urutan nomor, juga 
untuk  menunjukkan  gambar,  tabel  maupun  persamaan  dalam 
pemaparan tugas akhir tersebut.

Contoh :

Pada Gambar 4.19 disajikan hubungan antara medan balik Bc (dalam 
Tesla) dengan suhu T (dalam K).

Penulisan  nomor  tersebut  secara  manual  akan  menyulitkan  kita 
apabila terjadi  perubahan nomor, gambar,  tabel  maupun persamaan. 
Untuk menghindari  permasalahan tersebut,  kita dapat  menggunakan 
Cross-reference sehingga penunjukan nomor dapat dilakukan secara 
otomatis.

7.3.1 PENUNJUKAN GAMBAR

Berikut  ini  langkah-langkah  untuk  melakukan  penunjukan  gambar 
secara otomatis :

• Setelah kita menuliskan penunjukan, misalnya pada .... (titik-
titik tersebut akan kita isi dengan nomor gambar).

• Klik  menu  Insert  →  Cross-reference sehingga  tampak 
kotak dialog seperti pada gambar berikut ini:

Penomoran Gambar, Tabel Dan Persamaan
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• Klik  menu  Cross-reference,  kemudian  pada  pilihan  Type 
pilih tipe referensi yang dikehendaki (yakni Gambar).

• Selanjutnya pada pilihan  Selection pilih gambar yang akan 
ditunjukkan dan pada pilihan  Insert reference to,  tentukan 
format referensi yang akan dimasukkan misalnya  Category 
and  Number jika  label  dan  nomor  label  yang  akan 
disisipkan.

• Klik  Insert untuk menyisipkan label dan nomor label yang 
dipilih.

• Klik Close untuk menutup kotak dialog Fields.

7.3.2 PENUNJUKAN TABEL

Berikut ini langkah-langkah untuk melakukan penunjukan tabel secara 
otomatis :

• Setelah kita menuliskan penunjukan, misalnya pada .... (titik-
titik tersebut akan kita isi dengan nomor tabel).
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Gambar 7.10: Penunjukan Gambar dengan Cross-References
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• Klik  menu  Insert  →  Cross-reference sehingga  tampak 
kotak dialog seperti pada gambar berikut ini:

• Klik  menu  Cross-reference,  kemudian  pada  pilihan  Type 
pilih tipe referensi yang dikehendaki (yakni Tabel).

• Selanjutnya  pada  pilihan  Selection pilih  Tabel  yang  akan 
ditunjukkan dan pada pilihan  Insert reference to,  tentukan 
format referensi yang akan dimasukkan misalnya  Category 
and  Number jika  label  dan  nomor  label  yang  akan 
disisipkan.

• Klik  Insert untuk menyisipkan label dan nomor label yang 
dipilih.

• Klik Close untuk menutup kotak dialog Fields.

7.3.3 PENUNJUKAN PERSAMAAN

Berikut ini langkah-langkah untuk melakukan penunjukan persamaan 
secara otomatis :

• Setelah  kita  menuliskan  penunjukan,  misalnya  berdasarkan 
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Gambar 7.11: Penunjukan Tabel dengan Cross-References
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persamaan .... (titik-titik tersebut akan kita isi dengan nomor 
persamaan).

• Klik  menu  Insert  →  Cross-reference sehingga  tampak 
kotak dialog seperti pada gambar berikut ini:

• Klik  menu  Cross-reference,  kemudian  pada  pilihan  Type 
pilih tipe referensi yang dikehendaki (yakni Persamaan).

• Selanjutnya  pada  pilihan  Selection pilih  Persamaan  yang 
akan  ditunjukkan  dan  pada  pilihan  Insert  reference  to, 
tentukan  format  referensi  yang akan  dimasukkan misalnya 
Category and Number jika label dan nomor label yang akan 
disisipkan.

• Klik  Insert untuk menyisipkan label dan nomor label yang 
dipilih.

• Klik Close untuk menutup kotak dialog Fields.
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Gambar 7.12: Penunjukan Persamaan dengan Cross-References
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BAB 8
PENYUSUNAN BAGIAN 

AKHIR

8.1 PENGATURAN STYLE DAFTAR 
RUJUKAN

Daftar  rujukan  merupakan  kumpulan  sumber  informasi  yang 
digunakan dalam sebuah penulisan, yang disusun secara alfabetis.

Sebelum  membuat  daftar  rujukan  sebaiknya  kita  melakukan 
pengaturan  style.  Style  yang  akan  diatur  adalah  Bibliography 
Heading dan  Bibliography  1 yang  merupakan  bagian  dari 
Paragraph Style.

8.1.1 BIBLIOGRAPHY HEADING

Style Bibliography Heading digunakan untuk penulisan judul daftar 
rujukan. Berikut ini langkah-langkah pengaturan  style Bibliography 
Heading.

• Pilihlah  Bibliography Heading,  kemudian  klik  kanan  dan 
klik modify hingga tampak kotak dialog seperti pada gambar 
berikut.

Penyusunan Bagian Akhir
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Penyusunan Bagian Akhir

Gambar 8.1: Pengaturan Style Bibliography Heading
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Above paragraph : 0.00 cm

Below paragraph : 2.032 cm

Line spacing : 1,5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

8.1.2 BIBLIOGRAPHY 1

Style  Bibliography  1 digunakan  untuk  penulisan  daftar  rujukan 
secara  otomatis.  Pada  penulisan  daftar  rujukan  biasanya  digunakan 
paragraf  menggantung  (hanging).  Berikut  ini  langkah-langkah 
pengaturan pada style Bibliography 1.

• Pilihlah  Bibliography  1,  kemudian  klik  kanan  dan  klik 
modify hingga tampak kotak dialog berikut.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman
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Gambar 8.2: Pengaturan Style Bibliography 1
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Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

• Pengaturan pada menu Alignment

Posisi tulisan : Justified

• Pengaturan pada Indents & Spacing

Before text : 1.00 cm

After text : 0.00 cm

First Line : -1.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.21 cm

Line spacing : Single

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

8.2 PENGATURAN FIELD DARI DATA 
SOURCE

Kita  dapat  melakukan  perubahan  pada  Bibliography  Database 
(misalnya mengubah nama Field, mengubah panjang teks dari  Field) 
dengan mengikuti langkah-langkah berikut ini :

• Klik pada menu  View → Data Sources atau tekan tombol 
F4.
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Gambar 8.3: Data Source dari Bibliography Database
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• Pastikan anda memilih tabel biblio sebagaimana tampak pada 
Gambar 8.3.

• Lakukan  klik  kanan  pada  biblio,  kemudian  klik  Edit 
Database  File sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini :

• Pilih Tables pada bagian Database.

• Lakukan  klik  kanan  pada  biblio,  kemudian  klik  Edit 
sehingga tampak kotak dialog seperti pada gambar berikut ini 
:
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Gambar 8.4: Kotak Dialog Utama untuk Bekerja dengan Database
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• Sebagai  contoh,  pada  Field  Name pilih  URL  (8.3.4 
Pengisian referensi dari situs).

• Selanjutnya pada kotak isian Length, ubah angka 50 menjadi 
100 (sesuai kebutuhan).

• Silahkan simpan perubahan yang telah anda lakukan dengan 
menekan Ctrl + S.

8.3 PENULISAN DATA SUMBER PUSTAKA

Sebelum  daftar  rujukan  dibuat,  terlebih  dahulu  kita  harus 
memasukkan  data  sumber-sumber  pustaka  yang  kita  miliki  dengan 
cara sebagai berikut :

• Klik  menu  Tools  →  Bibliography  Database,  sehingga 
tampak kotak dialog seperti pada gambar berikut ini :
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Gambar 8.5: Kotak Dialog Modifikasi Table Properties
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• Pada  pilihan  Type,  kita  dapat  memilih  jenis  pustaka  yang 
digunakan.

• Lakukan  pengisian  seluruh  daftar  isian  referensi  yang 
digunakan.

• Klik  OK untuk  menutup  kotak  dialog  tersebut  dan 
menyimpan perubahan yang telah dilakukan.

8.3.1 PENGISIAN REFERENSI DARI BUKU

1. Buku Dengan Penulis Tunggal

• Klik Insert → Record, sehingga tampak kotak dialog seperti 
tampak pada gambar berikut ini :
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Gambar 8.6: Kotak Dialog Bibliography Database
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• Pilih Book pada kotak isian Type.

• Ketikkan nama penulis pada kotak isian  Author(s) dengan 
menuliskan nama keluarga/  nama belakang terlebih dahulu 
kecuali  nama China,  Jepang,  Korea  karena  nama keluarga 
sudah  di  awal.  Misalnya  nama  penulis  :  Nana  Syaodih 
Sukmadinata,  maka  kita  ketikkan  Sukmadinata,  Nana 
Syaodih.

• Ketikkan judul buku pada kotak isian Title, Misalnya Metode 
Penelitian Pendidikan.

• Ketikkan tahun penerbitan pada kotak isian  Year. Misalnya 
2007.

• Ketikkan  kota  penerbitan  buku pada  kotak  isian  Address. 
Misalnya Bandung.

• Ketikkan  nama penerbit  buku pada  kotak  isian  Publisher. 
Misalnya Remaja Rosdakarya.

• Ketikkan  nama keluarga/  nama  terakhir  penulis  dan  tahun 
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Gambar 8.7: Tampilan Bibliography Database Pengisian Rekaman Baru
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penerbitan  pada  kotak  isian  Short  name.  Misalnya 
Sukmadinata, 2007. Kotak isian  Short name ini digunakan 
untuk penulisan kutipan.

• Klik menu File → Save untuk melakukan penyimpanan data.

8.3.1.2 Buku Dengan Penulis Lebih Dari Satu

• Klik Insert → Record.

• Pilih Book pada kotak isian Type.

• Ketikkan  nama penulis  pertama  terlebih  dahulu  lalu  nama 
penulis  selanjutnya  pada kotak  isian  Author(s) .  Misalnya 
Cone, J.D., & Foster, S.L.

• Ketikkan  judul  buku  pada  kotak  isian  Title,  Misalnya 
Dissertation and Theses From Start to Finish.

• Ketikkan tahun penerbitan pada kotak isian  Year. Misalnya 
1993.

• Ketikkan  kota  penerbitan  buku pada  kotak  isian  Address. 
Misalnya Washington DC.

• Ketikkan  nama penerbit  buku pada  kotak  isian  Publisher. 
Misalnya American Psychological Association.

• Ketikkan nama keluarga/  nama terakhir dari semua penulis 
dan tahun penerbitan pada kotak isian Short name. Misalnya 
Cone and Foster, 1993. Hal ini berlaku untuk karya dengan 2 
penulis. Untuk karya dengan lebih dari 2 penulis, yang ditulis 
hanya  nama  keluarga/  belakang  penulis  pertama,  dengan 
memberi inisial et al atau dkk. Misalnya Smith et all., 1997).

• Klik menu File → Save untuk melakukan penyimpanan data.

8.3.2 PENGISIAN REFERENSI DARI PROSIDING

1. Artikel Dengan Penulis Tunggal

• Klik Insert → Record.
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• Pilih Conference Proceedings pada kotak isian Type.

• Ketikkan nama penulis pada kotak isian Author(s). Misalnya 
Yurnetti.

• Ketikkan  judul  artikel  pada  kotak  isian  Title,  Misalnya 
Pembelajaran  Kooperatif  sebagai  Metode  Alternatif 
Pembelajaran Fisika.

• Ketikkan tahun penerbitan prosiding pada kotak isian  Year. 
Misalnya 2002.

• Ketikkan  kota  penerbitan  buku pada  kotak  isian  Address. 
Misalnya Denpasar.

• Ketikkan halaman artikel dalam prosiding pada kotak isian 
Page(s). Misalnya 1.

• Ketikkan  nama  konferensi  atau  seminar  pada  kotak  isian 
Institution. Misalnya Simposium Fisika Nasional XIX.

• Ketikkan  nama  penerbit  prosiding  pada  kotak  isian 
Publisher. Misalnya Himpunan Fisika Indonesia.

• Ketikkan  nama keluarga/  nama  terakhir  penulis  dan  tahun 
penerbitan pada kotak isian Short name. Misalnya Yurnetti, 
2002. Kotak isian Short name ini digunakan untuk penulisan 
kutipan.

• Klik menu File → Save untuk melakukan penyimpanan data.

2. Artikel Dengan Penulis Lebih Dari Satu

Pada dasarnya pengisian sumber artikel dengan penulis lebih dari satu 
dapat dilakukan dengan mengikuti langkah-langkah pengisian artikel 
dengan satu penulis.  Kita  hanya melakukan sedikit  perubahan pada 
bagian Author(s) dan Short name.

• Pada kotak isian  Author(s), ketikkan nama penulis pertama 
terlebih dahulu lalu nama penulis selanjutnya.

• Pada kotak isian Short name, ketikkan nama keluarga/ nama 
terakhir dari semua penulis dan tahun penerbitan.

Penyusunan Bagian Akhir
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Jika karya lebih dari 2 penulis, maka yang ditulis hanya nama 
keluarga/ belakang penulis pertama, dengan memberi inisial 
et al atau dkk.

8.3.3 PENYISIAN REFERENSI DARI JURNAL

• Klik Insert → Record.

• Pilih Journal pada kotak isian Type.

• Ketikkan nama penulis pada kotak isian Author(s). Misalnya 
nama penulis  :  Mehmet  Altan Kurnaz,  maka kita  ketikkan 
Kurnaz, M .A. .

• Ketikkan judul artikel pada kotak isian Title, Misalnya Using 
Different Conceptual Change Methods Embedded within the 
5E Model.

• Ketikkan  tahun  penerbitan  jurnal  pada  kotak  isian  Year. 
Misalnya 2008.

• Ketikkan  nama  jurnal  pada  kotak  isian  Publisher,  contoh 
Journal of Physcs Teacher Education Online.

• Ketikkan  halaman  artikel  dalam  jurnal  pada  kotak  isian 
Page(s). Misalnya 3.

• Ketikkan  nama keluarga/  nama  terakhir  penulis  dan  tahun 
penerbitan pada kotak isian  Short name. Misalnya Kurnaz, 
M .A. , 2008. Kotak isian Short name ini digunakan untuk 
penulisan kutipan.

• Klik menu File → Save untuk melakukan penyimpanan data.

8.3.4 PENGISIAN REFERENSI DARI SITUS

• Pada Type, pilihlah WWW Document.

• Ketikkan nama penulis pada kotak isian Author(s). Misalnya 
nama penulis : Antoni W. Losbarch, maka ketikkan Losbarch, 
A. W. .

• Ketikkan  judul  dokumen  pada  kotak  isian  Title,  Misalnya 

Penyusunan Bagian Akhir



120

The  Learning  Cycle  as  A  Tool  for  Planning  Science 
Instuction.

• Ketikkan tahun, bulan, dan tanggal pembuatan dokumen pada 
kotak isian Year. Misalnya 2002, December 10.

• Ketikkan  bulan,  tanggal,  dan  tahun  pengaksesan  dokumen 
pada kotak isian Annotation. Misalnya Desember 23, 2010.

• Tuliskan  alamat  lengkap  situs  pada  kotak  isian  URL. 
Misalnya www.coe.ilstu.edu/scienceed/losbarch/257lrcy.html

• Ketikkan  nama keluarga/  nama  terakhir  penulis  dan  tahun 
penerbitan pada kotak isian Short name. Misalnya Losbarch, 
2002. Kotak isian Short name ini digunakan untuk penulisan 
kutipan.

• Klik menu File → Save untuk melakukan penyimpanan data.

8.4 PENULISAN ACUAN TULISAN 
(RUJUKAN)

Berikut ini langkah-langkah penulisan acuan pada kutipan :

• Tempatkan kursor pada bagian akhir kutipan.

• Klik menu  Insert → Indexes and Tables → Bibliography 
Entry... , sehingga tampak kotak dialog seperti pada gambar 
berikut ini :
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• Pada bagian Entry, pilih From bibliography database.

• Pada bagian Short name, pilih sumber pustaka yang menjadi 
acuan kutipan.

Berikut ini contoh penulisan acuan tulisan untuk format APA :

[Cone & Foster, 1993]

[Yurnetti, 2002]

Jika di perguruan tinggi anda menggunakan style yang lain, anda bisa 
mengubah acuan tulisan pada kotak isian Short name.

Style Penulisan acuan kutipan

APA (Cone & Foster, 1993)

Chicago (Cone and Foster 1993)

MLA (Cone and Foster)
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8.5 PENULISAN DAFTAR RUJUKAN

8.5.1 MENYUSUN DAFTAR RUJUKAN DENGAN CEPAT

Berikut ini langkah-langkah penulisan daftar rujukan dengan cepat :

• Tempatkan kursor pada halaman daftar rujukan.

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables ... sehingga tampak kotak dialog seperti pada gambar 
berikut ini:

• Pada  bagian  Title,  ganti  kata  “Bibliography”  dengan 
“DAFTAR RUJUKAN”.

• Klik  OK untuk menyisipkan daftar  rujukan pada dokumen 
anda.

8.5.2 MENYUSUN DAFTAR RUJUKAN SESUAI DENGAN 
KEBUTUHAN

Untuk menyusun daftar rujukan sesuai dengan kebutuhan, kita perlu 
melakukan pengaturan pada  Entries.  Berikut ini  contoh pengaturan 
Entries untuk style APA :

Penyusunan Bagian Akhir

Gambar 8.9: Kotak Dialog Insert Index/Table untuk Bibliography
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1. Buku

Berikut ini format style APA untuk buku :

Au. (Ye). Ti. Ad: Pu.

Keterangan :

Au (Author) : Nama penulis buku

Ye (Year) : Tahun penerbitan buku

Ti (Title) : Judul buku

Ad (Address) : Alamat penerbitan buku

Pu (Publisher) : Nama penerbit buku

Berikut ini langkah-langkah pengaturan style APA untuk buku :

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables  ... .  Selanjutnya  klik  menu  Entries hingga tampak 
kotak dialog seperti pada gambar berikut ini :

• Pada bagian Type, pilih Book.

• Klik  tombol  Sh pada  bagian  Structure  and  Formatting, 
selanjutnya  klik  tombol  Remove atau  tekan  Del pada 
keyboard untuk menghapus tombol Sh tersebut.

• Hapus juga tombol  Ti, tanda  titik dua (:), tanda  koma (,), 
spasi yang terletak pada kotak isian  Text di antara tombol-

Penyusunan Bagian Akhir

Gambar 8.10: Kotak dialog Index and Tables untuk menu Entries
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tombol tersebut.

• Klik pada kotak isian Text yang terletak setelah tombol Ye.

• Pada  SpinButton,  ganti  kata  “Address”  dengan  “Title”. 
Kemudian  klik  tombol  Insert sehingga  pada  Structure 
terdapat tombol Ti.

• Klik pada kotak isian  Text yang terletak setelah tombol  Ti. 
Pilih  Address pada  SpinButton,  selanjutnya  klik  tombol 
Insert.

• Klik pada kotak isian Text yang terletak setelah tombol Ad. 
Pilih  Publisher pada  SpinButton,  selanjutnya  klik  tombol 
Insert.

• Klik pada kotak isian Text yang terletak diantara tombol Au 
dan Ye, selanjutnya isikan “.” diikuti spasi satu kali dan “(“.

• Klik pada kotak isian Text yang terletak diantara tombol Ye 
dan Ti, selanjutnya isikan “).“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak diantara tombol  Ti 
dan Ad, selanjutnya isikan “.“ diikuti spasi satu kali.

• Klik pada kotak isian Text yang terletak diantara tombol Ad 
dan Pu, selanjutnya isikan “:“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak setelah tombol  Pu, 
selanjutnya isikan “.“.

• Klik tombol Ti, selanjutnya pada Character style pilih User 
Entry.

• Pilih  Content pada  bagian  Sort  by dan  Author(s) pada 
bagian Sort keys urutan 1.

• Klik OK.

Penyusunan Bagian Akhir

Gambar 8.11: Hasil Pengaturan Structure untuk Buku
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2. Prosiding

Berikut ini format style APA untuk Prosiding :

Au. (Ye). Ti. In (p. Pa). Ad. Pu.

Keterangan :

Au (Author) : Nama penulis artikel

Ye (Year) : Tahun penerbitan prosiding

Ti (Title) : Judul artikel

In (Institution) : Nama konferensi atau seminar

Pa (Page) : Halaman artikel dalam prosiding

Ad (Address) : Alamat penyelenggara konferensi atau seminar

Pu (Publisher) : Nama penerbit prosiding

Berikut ini langkah-langkah pengaturan style APA untuk prosiding :

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables ... . Selanjutnya klik menu Entries.

• Pada bagian Type, pilih Conference Proceedings.

• Klik  tombol  Sh pada  bagian  Structure  and  Formatting, 
selanjutnya  klik  tombol  Remove atau  tekan  Del pada 
keyboard untuk menghapus tombol Sh tersebut.

• Hapus juga tombol  Ti, tanda  titik dua (:), tanda  koma (,), 
spasi yang terletak pada kotak isian  Text di antara tombol-
tombol tersebut.

• Klik pada kotak isian Text yang terletak setelah tombol Ye.

• Pada  SpinButton,  ganti  kata  “Address”  dengan  “Title”. 
Kemudian  klik  tombol  Insert sehingga  pada  Structure 
terdapat tombol Ti.

• Klik pada kotak isian  Text yang terletak setelah tombol  Ti. 
Pilih  Institution pada  SpinButton, selanjutnya klik tombol 
Insert.

Penyusunan Bagian Akhir
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• Klik pada kotak isian  Text yang terletak setelah tombol  In. 
Pilih  Page(s) pada  SpinButton,  selanjutnya  klik  tombol 
Insert.

• Klik pada kotak isian Text yang terletak setelah tombol Pa. 
Pilih  Address  pada  SpinButton,  selanjutnya  klik  tombol 
Insert.

• Klik pada kotak isian Text yang terletak setelah tombol Ad. 
Pilih  Publisher  pada  SpinButton,  selanjutnya  klik  tombol 
insert.

• Klik pada kotak isian Text yang terletak diantara tombol Au 
dan Ye, selanjutnya isikan “.” diikuti spasi satu kali dan “(“.

• Klik pada kotak isian Text yang terletak diantara tombol Ye 
dan Ti, selanjutnya isikan “).“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak diantara tombol  Ti 
dan In, selanjutnya isikan “.“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yan terletak diantara tombol  In 
dan Pa, selanjutnya isikan “(p.” diikuti spasi satu kali.

• Klik pada kotak isian Text yang terletak diantara tombol Pa 
dan Ad, selanjutnya isikan “.” diikuti spasi satu kali.

• Klik pada kotak isian Text yang terletak diantara tombol Ad 
dan Pu, selanjutnya isikan “.“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak setelah tombol  Pu, 
selanjutnya isikan “.“.

• Klik tombol Ti, selanjutnya pada Character style pilih User 
Entry.

• Pilih  Content pada  bagian  Sort  by dan  Author(s) pada 
bagian Sort keys urutan 1.

Penyusunan Bagian Akhir
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• Klik OK.

3. Jurnal

Berikut ini format style APA untuk jurnal :

Au. (Ye). Ti. Pu, Pa.

Keterangan :

Au (Author) : Nama penulis artikel

Ye (Year) : Tahun penerbitan jurnal

Ti (Title) : Judul artikel

Pu (Publisher) : Nama jurnal

Pa (Page) : Halaman artikel dalam jurnal

Berikut ini langkah-langkah pengaturan style APA untuk jurnal :

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables ... . Selanjutnya klik menu Entries.

• Pada bagian Type, pilih Journal.

• Klik  tombol  Sh pada  bagian  Structure  and  Formatting, 
selanjutnya  klik  tombol  Remove atau  tekan  Del pada 
keyboard untuk menghapus tombol Sh tersebut.

• Hapus juga tombol  Ti, tanda  titik dua (:), tanda  koma (,), 
spasi yang terletak pada kotak isian  Text di antara tombol-
tombol tersebut.

• Klik pada kotak isian Text yang terletak setelah tombol Ye.

• Pada  SpinButton,  ganti  kata  “Address”  dengan  “Title”. 
Kemudian  klik  tombol  Insert sehingga  pada  Structure 
terdapat tombol Ti.

• Klik pada kotak isian  Text yang terletak setelah tombol  Ti. 
Pilih  Publisher pada  SpinButton,  selanjutnya  klik  tombol 
Insert.

• Klik pada kotak isian  Text yang terletak setelah tombol  Pu. 
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Pilih Page pada SpinButton, selanjutnya klik tombol Insert.

• Klik pada kotak isian Text yang terletak diantara tombol Au 
dan Ye, selanjutnya isikan “.” diikuti spasi satu kali dan “(“.

• Klik pada kotak isian Text yang terletak diantara tombol Ye 
dan Ti, selanjutnya isikan “).“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak diantara tombol  Ti 
dan Pu, selanjutnya isikan “.“ diikuti spasi satu kali.

• Klik pada kotak isian Text yang terletak diantara tombol Pu 
dan Pa, selanjutnya isikan “,“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak setelah tombol  Pa, 
selanjutnya isikan “.“.

• Klik tombol Ti, selanjutnya pada Character style pilih User 
Entry.

• Pilih  Content pada  bagian  Sort  by dan  Author(s) pada 
bagian Sort keys urutan 1.

• Klik OK.

4. Situs

Berikut ini format style APA untuk Situs :

Au. (Ye). Ti. An. UR

Keterangan :

Au (Author) : Nama penulis

Ye (Year) : Tahun, bulan, dan tanggal pembuatan dokumen

Ti (Title) : Judul dokumen

An (Annotation) : Tahun, bulan, dan tanggal pembuatan dokumen
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UR (URL) : Alamat lengkap situs

Berikut ini langkah-langkah pengaturan style APA untuk situs :

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables ... . Selanjutnya klik menu Entries.

• Pada bagian Type, pilih WWW Document.

• Klik  tombol  Sh pada  bagian  Structure  and  Formatting, 
selanjutnya  klik  tombol  Remove atau  tekan  Del pada 
keyboard untuk menghapus tombol Sh tersebut.

• Hapus juga tombol  Ti, tanda  titik dua (:), tanda  koma (,), 
spasi yang terletak pada kotak isian  Text di antara tombol-
tombol tersebut.

• Klik pada kotak isian Text yang terletak setelah tombol Ye.

• Pada  SpinButton,  ganti  kata  “Address”  dengan  “Title”. 
Kemudian  klik  tombol  Insert sehingga  pada  Structure 
terdapat tombol Ti.

• Klik pada kotak isian  Text yang terletak setelah tombol  Ti. 
Pilih Annotation pada SpinButton, selanjutnya klik tombol 
Insert.

• Klik pada kotak isian Text yang terletak setelah tombol An. 
Pilih URL pada SpinButton, selanjutnya klik tombol Insert.

• Klik pada kotak isian Text yang terletak diantara tombol Au 
dan Ye, selanjutnya isikan “.” diikuti spasi satu kali dan “(“.

• Klik pada kotak isian Text yang terletak diantara tombol Ye 
dan Ti, selanjutnya isikan “).“ diikuti spasi satu kali.

• Klik pada kotak isian  Text yang terletak diantara tombol  Ti 
dan An, selanjutnya isikan “.“ diikuti spasi satu kali.
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Gambar 8.14: Hasil Pengaturan Structure untuk Situs



130

• Klik pada kotak isian Text yang terletak diantara tombol An 
dan UR, selanjutnya isikan “.“ diikuti spasi satu kali.

• Klik tombol Ti, selanjutnya pada Character style pilih User 
Entry.

• Pilih  Content pada  bagian  Sort  by dan  Author(s) pada 
bagian Sort keys urutan 1.

• Klik OK.

Berikut ini contoh hasil penulisan daftar rujukan untuk format APA :

Cone, J.D., & Foster, S.L. (1993). Dissertation and Theses From Start  
to Finish. Washington DC: Psychological Association.

Kurnaz, M .A. ( 2008). Using Different Conceptual Change Methods  
Embedded  within  the  5E  Model.  Journal  of  Physcs  Teacher 
Education Online, 3.

Losbarch, A. W.(2002, December 10)  The Learning Cycle as A Tool  
for  Planning  Science  Instuction.   Desember  23,  2010. 
www.coe.ilstu.edu/scienceed/losbarch/257lrcy.html

Sukmadinata,  Nana  Syaodih  (2007).  Metode  Penelitian  Penelitian  
Pendidikan. Bandung: Remaja Rosdakarya.

Yurnetti. (2002). Pembelajaran Kooperatif sebagai Metode Alternatif  
Pembelajaran  Fisika.  Simposium  Fisika  Nasional  XIX(p.1). 
Himpunan Fisika Indonesia.

8.6 RIWAYAT HIDUP PENULIS

Riwayat hidup penulis Skripsi/ Tesis/ Disertasi berisi identitas pribadi, 
keluarga, pengalaman pendidikan, dan sebagainya yang dilampirkan 
pada  halaman  paling  akhir  dari  skripsi.  Penulisan  riwayat  hidup 
penulis menggunakan huruf Times New Roman ukuran 12 pt.
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BAB 9
PENULISAN DAFTAR

Setelah  seluruh  isi  tugas  akhir  selesai  dibuat,  hal  berikutnya  yang 
harus dilakukan adalah membuat daftar isi, daftar gambar, daftar tabel, 
dan  lain  sebagainya.  Daftar-daftar  tersebut  dapat  dibuat  secara 
otomatis apabila pengaturan di bagian sebelumnya sudah dilakukan. 
Pembuatan  daftar  secara  otomatis  akan  mempermudah  kita  dalam 
melakukan perbaikan jika terjadi perubahan isi daftar maupun nomor 
halaman.

9.1 PENGATURAN STYLE DAFTAR ISI

Pada bagian ini kita akan mengatur style yang akan digunakan untuk 
pengaturan daftar isi. Style yang akan diatur yang berkaitan dengan 
daftar  isi  adalah  Contents  Heading,  Contents  1,  Contents  2, 
Contents 3,  dan  Contents 4.  Style tersebut merupakan bagian dari 
Paragraph Style.

9.1.1 CONTENTS HEADING

Style Contents Heading digunakan untuk penulisan judul daftar isi. 
Berikut ini langkah-langkah pengaturan style Contents Heading.

• Pilihlah  Contents Heading,  kemudian klik kanan dan klik 
modify hingga  tampak  kotak  dialog  seperti  pada  gambar 
berikut ini :

Penulisan Daftar
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Penulisan Daftar

Gambar 9.1: Pengaturan Style Contents Heading
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Above paragraph : 0.00 cm

Below paragraph : 2.032 cm

Line spacing : 1,5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.1.2 CONTENTS 1

Style Contents 1 merupakan penulisan daftar isi  untuk Heading 1. 
Berikut ini langkah-langkah pengaturan style Contents 1.

• Pilihlah  Contents 1, kemudian klik kanan dan klik  modify 
hingga tampak kotak dialog seperti pada gambar berikut.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Penulisan Daftar

Gambar 9.2: Pengaturan Style Contents 1
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Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : Single

• Pada menu Tabs, buatlah tab stop position ujung baris pada 
posisi 14 cm atau sesuaikan dengan kebutuhan anda.

• Gunakan  alignment  Right (rata  kanan)  dan  Fill  character 
yang kedua (.....) lalu klik tombol New.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.1.3 CONTENTS 2

Style Contents 2 merupakan penulisan daftar isi  untuk Heading 2. 
Berikut ini langkah-langkah pengaturan style Contents 2.

Penulisan Daftar
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• Pilihlah  Contents 2, kemudian klik kanan dan klik  modify 
hingga  tampak  kotak  dialog  seperti  pada  gambar 
berikut.Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 0.76 cm

Penulisan Daftar

Gambar 9.3: Pengaturan Style Contents 2



136

After text : 0.00 cm

First Line : -0.76 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : Single

• Pada menu Tabs, buatlah tab stop position ujung baris pada 
posisi 14 cm atau sesuaikan dengan kebutuhan anda.

• Gunakan  alignment  Right (rata  kanan)  dan  Fill  character 
yang kedua (.....) lalu klik tombol New.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.1.4 CONTENTS 3

Style Contents 3 merupakan penulisan daftar isi  untuk Heading 3. 
Berikut ini langkah-langkah pengaturan style Contents 3.

• Pilihlah  Contents 3, kemudian klik kanan dan klik  modify 
hingga tampak kotak dialog seperti pada gambar berikut ini :

Penulisan Daftar
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 1.76 cm

After text : 0.00 cm

First Line : -1.00 cm

Penulisan Daftar

Gambar 9.4: Pengaturan Style Contents 3
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Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : Single

• Pada menu Tabs, buatlah tab stop position ujung baris pada 
posisi 14 cm atau sesuaikan dengan kebutuhan anda.

• Gunakan  alignment  Right (rata  kanan)  dan  Fill  character 
yang kedua (.....) lalu klik tombol New.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.1.5 CONTENTS 4

Style Contents 4 merupakan penulisan daftar isi  untuk Heading 4. 
Berikut ini langkah-langkah pengaturan style Contents 4.

• Pilihlah  Contents 4, kemudian klik kanan dan klik  modify 
hingga tampak kotak dialog seperti pada gambar berikut ini :

Penulisan Daftar

Gambar 9.5: Pengaturan Style Contents 4
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 3.00 cm

After text : 0.00 cm

First Line : -1.30 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : Single

• Pada menu Tabs, buatlah tab stop position ujung baris pada 
posisi 14 cm atau sesuaikan dengan kebutuhan anda.

• Gunakan  alignment  Right (rata  kanan)  dan  Fill  character 
yang kedua (.....) lalu klik tombol New.

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.2 PENULISAN DAFTAR ISI

Daftar  isi  memuat  seluruh  bagian  tulisan  beserta  nomor  halaman 
masing-masing yang sesuai dengan isi. Daftar isi harus singkat dan 
jelas, sehingga subbab derajat kedua dan ketiga tidak dituliskan. 
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9.2.1 MEMBUAT DAFTAR DENGAN CEPAT

• Tempatkan kursor anda pada halaman daftar isi.

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables  ... ,  sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini :

• Klik  menu  Index/Table,  kemudian  pada  bagian  Title 
ketikkan “ DAFTAR ISI ” dan pada bagian Type pilih Table 
of Contents.

• Jika anda tidak menghilangkan tanda centang pada Protected 
against  manual  changes,  maka  daftar  isi  yang anda  buat 
tidak bisa diedit secara manual.

• Jika Evaluate up to level bernilai 10, hal ini berarti Heading 
1 – Heading 10 akan ditampilkan dalam daftar isi. Jadi jika 
kita hanya ingin menampilkan sampai Heading 3 saja, maka 
nilai tersebut kita ubah menjadi 3.

• Klik OK.

Penulisan Daftar

Gambar 9.6: Kotak Dialog Insert Index/ Table untuk Type Table of  
Contents



141

9.2.2 PENULISAN DAFTAR ISI DENGAN ADDITIONAL 
STYLE

Berikut ini langkah-langkah penulisan daftar isi secara otomatis :

• Tempatkan kursor anda pada halaman daftar isi.

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables  ... ,  sehingga  tampak  kotak  dialog  seperti  pada 
Gambar 9.6.

• Klik  menu  Index/Table,  kemudian  pada  bagian  Title 
ketikkan “ DAFTAR ISI ” dan pada bagian Type pilih Table 
of Contents.

• Jika anda tidak menghilangkan tanda centang pada Protected 
against  manual  changes,  maka  daftar  isi  yang anda  buat 
tidak bisa diedit secara manual.

• Berikan tanda centang pada  Additional Styles. Selanjutnya 
klik  tombol  ... yang  di  sebelah  kanan  Additional  Styles 
sehingga tampak kotak dialog seperti pada gambar berikut ini 
:

• Pilih  Bibliography Heading yang terdapat pada kolom Not 
applied kemudian  klik  tombol  >> sebanyak  satu  kali. 
Dengan  demikian  Bibliography  Heading kita  anggap 
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sebagai  Contents  1 dan  pengaturannya  mengikuti  style 
Contents 1.

• Lakukan  pengaturan  yang  sama  dengan  Bibliography 
Heading untuk Heading 1, Judul, Contents Heading, Table 
Index Heading, dan Illustration Index Heading.

• Selanjutnya  pilih  Heading  2 kemudian  klik  tombol  >> 
sebanyak dua kali.  Heading 2 merupakan  Contents  2 dan 
pengaturannya mengikuti Contents 2.

• Untuk Contents 3, pilih  Heading 3 dengan melakukan klik 
pada tombol >> sebanyak 3 kali. Pengaturan Heading 3 juga 
mengikuti Contents 3 yang telah kita atur sebelumnya pada 
bagian pengayaan (styles).

• Klik OK untuk menerapkan perubahan yang telah dilakukan 
pada bagian Assign Styles.

• Hilangkan tanda centang yang ada pada bagian Outline dan 
Index marks dari menu Index/Table.

• Klik  menu  Entries sehingga  tampak  kotak  dialog  seperti 
pada gambar berikut ini :

• Berikut ini tombol-tombol yang ada pada Structure :

◦ Tombol  E# merepresentasikan  “nomor  BAB”,  yang 
berarti  nomor  Heading,  tidak  hanya  untuk  BAB  tapi 
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juga untuk  Heading yang lain misalnya subbab. Untuk 
beberapa sistem operasi tombol E# biasanya ditampilkan 
sebagai F#.

◦ Tombol E merepresentasikan teks Entry yakni Heading 
misalnya  PENDAHULUAN.  Untuk  beberapa  sistem 
operasi tombol E biasanya ditampilkan sebagai F.

◦ Tombol T merepresentasikan tab stop.

◦ Tombol # merepresentasikan nomor halaman.

◦ Tombol  LS merepresentasikan  awal  hyperlink (secara 
default  tombol  ini  tidak  ditampilkan).  Untuk  beberapa 
sistem operasi tombol  LS biasanya ditampilkan sebagai 
IS.

◦ Tombol  LE merepresentasikan akhir  hyperlink (secara 
default  tombol  ini  tidak  ditampilkan).Untuk  beberapa 
sistem operasi tombol LE biasanya ditampilkan sebagai 
IF.

• Pilih  Level 1, lalu tempatkan kursor anda di antara tombol 
E# dan  E. Setelah itu tekan  spasi 1 kali. Lakukan hal yang 
sama untuk  Level  2 dan  Level  3.  Hal  ini  bertujuan untuk 
memberikan spasi diantara nomor bab/ subbab dengan teks 
dari bab/ subbab tersebut.

• Pada  Level  1,  di  bagian  Structure klik  tombol  # (page 
number)  dan  pilih  Page  Number pada  bagian  Character 
Style.

• Klik OK untuk menyisipkan daftar isi pada dokumen anda.

9.2.3 PENGEDITAN DAFTAR ISI

Berikut  ini  langkah-langkah  untuk  mengedit  daftar  isi  yang  telah 
dibuat pada dokumen :

• Klik kanan pada daftar isi yang anda buat.

• Klik Edit Index/Table sehingga tampak kotak dialog Insert 
Index/Table ditampilkan kembali.

Penulisan Daftar
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• Klik pada kotak  Text sebelum tombol  E#,  selanjutnya klik 
Hyperlink. Klik juga kotak Text setelah tombol  #, lalu klik 
Hyperlink kembali.  Dengan  demikian  akan  ditampilkan 
tombol LS dan LE.

• Klik  kotak  Text yang  terletak  antara  tombol  T dan  #, 
selanjutnya klik Tab stop.

• Klik  tombol  T pertama  yang  terletak  setelah  tombol  E. 
Kemudian lakukan pengaturan berikut :

Fill character : .

Tab stop position : 13.00 cm

• Klik tombol  T kedua yang berdampingan dengan tombol  #. 
Kemudian klik Align right.

• Klik OK untuk menyimpan perubahan yang telah dilakukan.

9.3 PENULISAN DAFTAR GAMBAR DAN 
TABEL

9.3.1 PENGATURAN STYLE DAFTAR GAMBAR DAN 
TABEL

Pada  bagian  ini  kita  akan  melakukan  pengaturan  style  yang  akan 
digunakan untuk penulisan daftar gambar dan daftar tabel. Style yang 
digunakan untuk daftar  gambar adalah  Illustration Index Heading 
dan  Illustration  Index  1 sedangkan  untuk  daftar  tabel  digunakan 
Table Index Heading dan  Table Index 1. style tersebut merupakan 
bagian dari Paragraph Style.

9.3.1.1 Illustration Index Heading

Style Illustration Index Heading digunakan untuk penulisan judul 
daftar  Gambar.  Berikut  ini  langkah-langkah  pengaturan  style 
Illustration Index Heading.

• Pilihlah  Illustration Index Heading,  kemudian klik kanan 
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dan  klik  modify hingga tampak  kotak  dialog  seperti  pada 
gambar berikut.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

Penulisan Daftar
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After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 2.032 cm

Line spacing : 1,5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.3.1.2 Illustration Index 1

Style Illustration Index 1 digunakan untuk penulisan daftar gambar 
secara otomatis.  Berikut  ini  langkah-langkah pengaturan  pada  style 
Illustration Index 1.

• Pilihlah Illustration Index 1, kemudian klik kanan dan klik 
modify hingga  tampak  kotak  dialog  seperti  pada  gambar 
berikut.Pengaturan pada menu Font
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Jenis Huruf : Times New Roman

Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : 1.5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.3.1.3 Table Index Heading

Style Table Index Heading digunakan untuk penulisan judul daftar 
tabel.  Berikut  ini  langkah-langkah  pengaturan  style  Table  Index 
Heading.

• Pilihlah Table Index Heading, kemudian klik kanan dan klik 
modify hingga  tampak  kotak  dialog  seperti  pada  gambar 
berikut ini :
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• Pengaturan pada menu Font

Jenis Huruf : Times New Roman

Format Huruf : Cetak tebal (Negreta atau Bold)

Ukuran Huruf : 14 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Capitals

• Pengaturan pada menu Alignment

Posisi tulisan : Center

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Penulisan Daftar
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Above paragraph : 0.00 cm

Below paragraph : 2.032 cm

Line spacing : 1,5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.3.1.4 Table Index 1

Style Table Index 1 digunakan untuk penulisan daftar tabel  secara 
otomatis.  Berikut  ini  langkah-langkah pengaturan  pada  style  Table 
Index 1.

• Pilihlah  Table  Index  1,  kemudian  klik  kanan  dan  klik 
modify hingga  tampak  kotak  dialog  seperti  pada  gambar 
berikut.

• Pengaturan pada menu Font

Jenis Huruf : Times New Roman
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Format Huruf : Normal

Ukuran Huruf : 12 point

• Pengaturan pada menu Font Effects

Warna Tulisan : Hitam (Black)

Efek : Title

• Pengaturan pada menu Alignment

Posisi tulisan : Left

• Pengaturan pada Indents & Spacing

Before text : 0.00 cm

After text : 0.00 cm

First Line : 0.00 cm

Above paragraph : 0.00 cm

Below paragraph : 0.00 cm

Line spacing : 1.5 lines

• Klik OK untuk menerapkan perubahan yang telah dilakukan.

9.3.2 PENULISAN DAFTAR GAMBAR

Berikut ini langkah-langkah pembuatan daftar gambar secara otomatis 
:

• Tempatkan kursor anda pada halaman daftar gambar.

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables  ... ,  sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini :
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• Klik  menu  Index/Table,  kemudian  pada  bagian  Title 
ketikkan  “  DAFTAR  GAMBAR  ”  dan  pada  bagian  Type 
pilih Illustration Index.

• Jika anda tidak menghilangkan tanda centang pada Protected 
against  manual  changes,  maka  daftar  gambar  yang  anda 
buat tidak bisa diedit secara manual.

• Pada  bagian  Create  from pilih  caption dan  lakukan 
pengaturan sebagai berikut :

Category : Gambar

Display : References

• Klik  OK untuk menyisipkan daftar  gambar pada dokumen 
anda.

9.3.3 PENULISAN DAFTAR TABEL

Berikut ini langkah-langkah pembuatan daftar tabel secara otomatis :

• Tempatkan kursor anda pada halaman daftar tabel.

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables  ... ,  sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini :
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• Klik  menu  Index/Table,  kemudian  pada  bagian  Title 
ketikkan “ DAFTAR TABEL ” dan pada bagian  Type pilih 
Index of Tables.

• Jika anda tidak menghilangkan tanda centang pada Protected 
against manual changes, maka daftar tabel yang anda buat 
tidak bisa diedit secara manual.

• Pada  bagian  Create  from pilih  caption dan  lakukan 
pengaturan sebagai berikut :

Category : Tabel

Display : References

• Klik  OK untuk menyisipkan daftar  gambar pada dokumen 
anda.

9.4 MENG-UPDATE DAFTAR

Untuk  melakukan  perbaikan  daftar  baik  daftar  isi,  daftar  gambar 
maupun  daftar  tabel  dapat  dilakukan  dengan  cara  mengklik  kanan 
pada  bagian  daftar  yang  akan  diperbaiki  kemudian  pilih  Update 
Index/Table. Dengan demikian daftar anda telah diupdate.
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BAB 10
TAMBAHAN

10.1 NAVIGATOR

Dalam  penulisan  dokumen  biasanya  dokumen  tersebut  terdiri  atas 
berbagai  macam bentuk  misalnya  dalam  bentuk  teks,  tabel,  link, 
objek, komentar, frame, formula, gambar dan lain sebagainya. Kita 
akan mengalami kesulitan untuk mengecek penulisan dokumen satu 
persatu atau untuk melakukan perubahan sementara halaman dokumen 
tersebut cukup banyak.

Untuk  berpindah  dengan  cepat  dalam  suatu  dokumen,  kita  dapat 
menggunakan  Navigator  yang  telah  disediakan  oleh  Writer.  Untuk 
menampilkan  Navigator  dapat  dilakukan  melalui  menu  View  → 
Navigator atau tekan tombol F5.
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Misalkan kita ingin berpindah dari halaman BAB 1 ke BAB 5, maka 
kita  hanya melakukan klik  ganda pada  BAB 5 yang terdapat  pada 
bagian Headings.

10.2 PEMBUATAN CATATAN KAKI 
(FOOTNOTE)

10.2.1 MEMBUAT FOOTNOTE

Sebelum  membuat  Footnote terlebih  dahulu  kita  harus  mengatur 
format Footnote dengan langkah-langkah sebagai berikut :

• Klik menu Tools → Footnotes/ Endnotes... sehingga tampak 
kotak dialog seperti pada gambar berikut ini :

• Pada  bagian  AutoNumbering,  lakukan  pengaturan  format 
Numbering, Counting, dan Position.

• Anda juga  bisa  mengatur  jenis  style  yang digunakan pada 
bagian Styles.

• Klik  OK untuk  menyimpan  hasil  pengaturan  yang  telah 
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dilakukan

Untuk menuliskan Footnote dapat dilakukan dengan langkah-langkah 
sebagai berikut :

• Tempatkan  kursor  anda  pada  teks  yang  akan  diberikan 
Footnote.

• Klik  menu  Insert  →  Footnote/Endnote.. hingga  tampak 
kotak dialog seperti pada gambar berikut ini :

• Klik  OK,  selanjutnya  tuliskan  keterangan  dari  Footnote 
tersebut.

10.2.2 MENGHAPUS FOOTNOTE

Untuk menghapus Footnote dapat dilakukan dengan memblok nomor 
Footnote kemudian  menekan  tombol  Del pada  keyboard.  Tulisan 
Footnote akan terhapus secara otomatis.

10.3 PEMBUATAN INDEKS

10.3.1 MENANDAI INDEKS

Indeks merupakan  kumpulan  istilah  penting  dalam  tulisan  yang 
disertai  dengan  posisi  keberadaannya.  Langkah-langkah  dalam 
membuat Indeks adalah sebagai berikut :
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• Lakukan blok pada teks yang akan ditampilkan dalam daftar 
indeks.

• Klik  menu  Insert  →  Indexes  and  Tables  →  Entry... 
sehingga tampak kotak dialog seperti pada gambar berikut ini 
:

• Pada  bagian  Selection,  pilih  Alphabetical  Index  untuk 
Index.

• Entry dalam  bagian  Selection berisi  istilah  yang  akan 
ditampilkan dalam daftar indeks.

• Berikan tanda centang pada Main Entry begitu pula dengan 
Apply to all similar texts agar teks yang sama diberi indeks.

• Klik Insert untuk memberikan tanda indeks pada teks.

• Lakukan blok pada istilah lain yang akan dijadikan indeks 
(tanpa  menutup  kotak  dialog  Insert  Index  Entry), 
selanjutnya lakukan langkah yang sama seperti pada istilah 
sebelumnya.

• Setelah  semua  penandaan  indeks  selesai,  klik  Close pada 
kotak dialog tersebut.
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10.3.2 MENAMPILKAN DAFTAR INDEKS

Untuk  menampilkan  daftar  indeks  dapat  dilakukan  dengan  cara 
sebagai berikut :

• Klik menu  Insert → Indexes and Tables → Indexes and 
Tables... sehingga tampak kotak dialog seperti pada gambar 
berikut ini :

• Ketikkan “INDEKS” untuk Title pada bagian Type and title 
dan pilih Alphabetical Indeks untuk Type.

• Pada  bagian  Options,  Hilangkan  tanda  centang  pada 
Combine Identical entries with p or pp dan berikan tanda 
centang pada AutoCapitalize entries.

• Pada  bagian  Format dari  menu  Entries,  berikan  tanda 
centang pada Alphabetical delimiter.

• Tentukan  jumlah  kolom  yang  diinginkan  pada  menu 
Columns.

• Setelah selesai, klik OK.

10.3.3 MENGHAPUS INDEKS

Untuk menghapus indeks dapat dilakukan dengan cara sebagai berikut 
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:

• Lakukan klik kanan pada teks yang akan dihapus dari daftar 
indeks.  Selanjutnya  klik  Index  Entry... sehingga  tampak 
kotak dialog seperti pada Gambar 10.6.

• Klik tombol Delete untuk menghapus indeks tersebut.

• Setelah  selesai,  klik  Close untuk  menutup  kotak  dilaog 
tersebut.

10.4 COMMENT

Comment merupakan  fasilitas  yang  disediakan  oleh  Writer  untuk 
menyisipkan komentar berupa teks pada dokumen yang diinginkan. 
Berikut ini langkah-langkah untuk menyisipkan komentar :

• Klik pada teks yang akan diberikan komentar.

• Klik menu  Insert → Comment atau gunakan  Ctrl + Alt + 
N.

• Tuliskan komentar anda pada kotak komentar tersebut.
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• Untuk menghapus komentar tertentu dapat dilakukan dengan 
mengklik  Delete  Comment atau  Delete  All  Comments 
untuk menghapus semua komentar dalam dokumen.

10.5 PENCARIAN DAN PERGANTIAN 
TEKS

Berikut  ini  langkah-langkah  untuk  melakukan  pencarian  dan 
pergantian teks :

• Klik menu  Edit → Find & Replace... atau tekan  Ctrl + F 
sehingga tampak kotak dialog seperti pada gambar berikut :

• Tuliskan teks yang akan dicari atau diganti pada kotak isian 
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Search for.

• Untuk  mencari  teks  tersebut  dapat  dilakukan  dengan 
mengklik tombol Find. Sedangkan untuk mengganti teks klik 
tombol  Replace atau  Replace All untuk mengganti seluruh 
teks yang sama dalam dokumen.

• Setelah selesai, klik Close.

10.6 TRACK CHANGES

Track changes digunakan untuk memantau dokumen ketika terjadi 
perubahan.  Dengan adanya fasilitas  ini dokumen-dokumen dapat  di 
pantau sehingga  keaslian dokumen tetap terjaga.  Ketika fungsi  ini 
diaktifkan,  maka  perubahan  yang  terjadi  seperti  penyisipan  teks 
maupun penghapusan teks dapat dipantau. Bila terjadi penyisipan teks 
maka tulisan penyisipan tersebut terlihat dengan jelas berwarna dan 
bergaris  bawah  sedangkan  bila  terjadi  penghapusan  teks,  dokumen 
teks  yang  dihapus  tidak  hilang,  melainkan  muncul  garis  coretan 
berwarna  pada  teks  tersebut.  Kita  dapat  menentukan  tindakan  atas 
perubahan-perubahan yang terjadi baik itu diterima (accept) maupun 
di tolak (deny).

Track Changes dapat diaktifkan melalui menu  Edit  → Change  → 
Record, untuk menampilkan seluruh dokumen bila terjadi perubahan 
dengan mengaktifkan menu Edit → Change → Show. 

Untuk memproteksi dokumen, klik menu Edit → Change → Protect 
Record. Selanjutnya inputkan kode sandi dan kode sandi yang diinput 
minimal 1 karakter.
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Tindakan selanjutnya, apakah perubahan-perubahan tersebut diterima 
atau  di  tolak,  caranya  dari  menu  Edit  → Change  → Accept  or 
Reject.  Ketika  anda  memilih  accept berarti  menyetujui  perubahan 
sebaliknya reject berarti menolak.
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Gambar 10.9: Contoh Penerapan Track Changes
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10.7 MENGEKSPOR DOKUMEN SEBAGAI 
PDF

Berikut  ini  langkah-langkah  untuk  mengekspor  dokumen  dalam 
bentuk PDF :

• Klik menu File → Export as PDF... sehingga tampak kotak 
dialog seperti pada gambar berikut ini :

• Pada bagian  Range, pilih  All untuk mengekspor seluruh isi 
dokumen,  Pages untuk  satu  atau  beberapa  halaman,  dan 
Selection untuk halaman yang sedang aktif saja yang akan 
diekspor.

• Klik  export untuk mengekspor dokumen tersebut  sehingga 
tampak kotak dialog seperti pada gambar berikut :
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Gambar 10.11: Kotak Dialog PDF Options  
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• Tentukan lokasi penyimpanan file anda, setelah itu klik Save.

10.7.1 MENGEKSPOR DOKUMEN SEBAGAI PDF 
TERENKRIPSI

Untuk mengekspor dokumen sebagai  file  pdf  yang terenkripsi,  kita 
perlu melakukan pengaturan lebih lanjut pada menu Securiy. Berikut 
ini langkah-langkah pengaturan tersebut : 

• Lakukan  klik  pada  menu  Security untuk  melakukan 
pengaturan  keamanan  dokumen  pada  kotak  dialog  PDF 
Options.

• Klik  Set  open  password... untuk  melakukan  enkripsi 
dokumen.   untuk  membuka  dokumen  tersebut,  terlebih 
dahulu harus dimasukkan password (kode sandi ) yang benar.
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• Selanjutnya  masukkan  password  anda  pada  kotak  dialog 
seperti yang tampak pada gambar berikut ini :

• Selanjutnya silakan anda ekspor dokumen tersebut.
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Gambar 10.14: Kotak Dialog Set open password

Gambar 10.13: Menu Security pada Kotak  
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10.7.2 MENGEKSPOR DOKUMEN SEBAGAI PDF YANG 
TIDAK DAPAT DICETAK

Misalkan anda menginginkan dokumen masih bisa dibaca oleh orang 
lain  tetapi  dokumen  tersebut  tidak  bisa  disalin,  diubah,  bahkan 
dicetak.  Berikut  ini  langkah-langkah  untuk  melakukan  pengaturan 
tersebut :

• Klik menu Security untuk melakukan pengaturan keamanan 
dokumen pada kotak dialog PDF Options.

• Klik  Set  permission  password... sehingga  tampak  kotak 
dialog seperti pada gambar berikut ini :

• Masukkan  password  anda  pada  kotak  dilaog  tersebut. 
Selanjutnya klik OK.

• Pada bagian Printing, pilih Not permitted.

• Pada bagian Changes, pilih juga Not permitted.

• Hilangkan tanda centang pada  Enable copying of content 
dan Enable text acces for accessibility tools.

• Selanjutnya silakan ekspor dokumen anda.

10.8 EXTENSION MANAGER

Kita  dapat  menambahkan  fungsi  baru  dalam  Writer dengan 
menginstal  Extension.  Kita  bisa  mengunduh  (mendownload) 
extension yang  dibutuhkan  dari  http://extensions.libreoffice.org/ 

Tambahan
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atau http://extensions.services.openoffice.org/. 

Berikut  ini  langkah-langkah  untuk  memasang  extension dalam 
Writer :

• Download (unduh)  extension dan  simpan dalam komputer 
anda.

• Klik menu Tools → Extension manager... sehingga tampak 
kotak dialog seperti pada gambar berikut ini :

• Klik  Add... sehingga  tampak  kotak  dialog  seperti  pada 
gambar berikut ini :
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Gambar 10.16: Kotak Dialog Extension Manager
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• Pilih Extension yang ingin install misalnya id.oxt (extension 
untuk  kamus  bahasa  Indonesia),  selanjutnya  klik  Open. 
Extension  tersebut  akan  mulai  terinstall  dan  kemungkinan 
anda akan dimintai untuk menerima persetujuan lisensi.

• Jika proses instalasi  sudah selesai,  maka extension tersebut 
akan terpasang pada kotak dialog extension manager.

• klik Close untuk menutup kotak dialog tersebut. 
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Gambar 10.17: Kotak Dialog Add Extension
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